ifile: fix ssp build on NetBSD

This commit is contained in:
nros 2021-12-26 23:54:01 +00:00
parent 14cc5633f6
commit 8d90c7e6e3
5 changed files with 87 additions and 7 deletions

View File

@ -1,8 +1,10 @@
$NetBSD: distinfo,v 1.13 2021/10/26 10:54:02 nia Exp $
$NetBSD: distinfo,v 1.14 2021/12/26 23:54:01 nros Exp $
BLAKE2s (ifile-1.3.8/ifile-1.3.8.tar.gz) = 1f484a0689d3d7afae497dea28626fac48b4815ba288249fde4c09ccd4b329f2
SHA512 (ifile-1.3.8/ifile-1.3.8.tar.gz) = d69315da0eae777fb764d9db5157d1e7232f7c17fa3b42dcdf21dd81205999f1740d1d59727a951cbd48327cdd05ce47f9c1a30d6c67cca4b744f879d82a8b32
Size (ifile-1.3.8/ifile-1.3.8.tar.gz) = 190558 bytes
SHA1 (patch-aa) = f60b5642496e83707f722c2ea1d63460599226ba
SHA1 (patch-aa) = 259413b004057433d49202e1ab1ba57d33f22f99
SHA1 (patch-ad) = 6b92eec1416a40cc692ff58915f8ebf133160f6a
SHA1 (patch-argp_argp-fmtstream.h) = 505591cb210f783422a9e600e1f97a2ca3ae09ad
SHA1 (patch-argp_argp-fmtstream.h) = 384edba4ffa1449e0b7f7ccf117e2de11514e496
SHA1 (patch-argp_argp-fs-xinl.c) = 208a1f3d2711ddae6fc175a5b8dd03744053662e
SHA1 (patch-argp_argp-xinl.c) = 508c2afe0b452443f745722e28ce2cb8f336d49a

View File

@ -1,6 +1,9 @@
$NetBSD: patch-aa,v 1.3 2012/10/15 09:35:17 joerg Exp $
$NetBSD: patch-aa,v 1.4 2021/12/26 23:54:01 nros Exp $
--- argp/argp.h.orig 2004-11-19 22:51:25.000000000 +0000
* defining __OPTIMIZE__ to nothing causes ssp.h on NetBSD
to crash use __ARGP_OPTIMIZE__ instead to avoid conflict
--- argp/argp.h.orig 2006-05-22 16:49:22.000000000 +0000
+++ argp/argp.h
@@ -352,7 +352,7 @@ struct argp_state
#define ARGP_NO_EXIT 0x20
@ -38,6 +41,15 @@ $NetBSD: patch-aa,v 1.3 2012/10/15 09:35:17 joerg Exp $
/* Return the input field for ARGP in the parser corresponding to STATE; used
by the help routines. */
@@ -508,7 +512,7 @@ extern void *_argp_input __P ((__const s
extern void *__argp_input __P ((__const struct argp *argp,
__const struct argp_state *state));
-#ifdef __OPTIMIZE__
+#ifdef __ARGP_OPTIMIZE__
#if !_LIBC
# define __argp_usage argp_usage
@@ -518,7 +522,11 @@ extern void *__argp_input __P ((__const
#endif
@ -50,3 +62,12 @@ $NetBSD: patch-aa,v 1.3 2012/10/15 09:35:17 joerg Exp $
#endif
ARGP_EI void
@@ -552,7 +560,7 @@ __option_is_end (__const struct argp_opt
# undef __option_is_end
#endif
-#endif /* __OPTIMIZE__ */
+#endif /* __ARGP_OPTIMIZE__ */
#ifdef __cplusplus
}

View File

@ -1,6 +1,9 @@
$NetBSD: patch-argp_argp-fmtstream.h,v 1.1 2012/10/20 22:13:28 joerg Exp $
$NetBSD: patch-argp_argp-fmtstream.h,v 1.2 2021/12/26 23:54:01 nros Exp $
--- argp/argp-fmtstream.h.orig 2004-11-19 22:51:26.000000000 +0000
* defining __OPTIMIZE__ to nothing causes ssp.h on NetBSD
to crash use __ARGP_OPTIMIZE__ instead to avoid conflict
--- argp/argp-fmtstream.h.orig 2006-05-22 16:49:23.000000000 +0000
+++ argp/argp-fmtstream.h
@@ -139,6 +139,7 @@ extern ssize_t argp_fmtstream_printf (ar
;
@ -34,6 +37,15 @@ $NetBSD: patch-argp_argp-fmtstream.h,v 1.1 2012/10/20 22:13:28 joerg Exp $
/* Internal routines. */
extern void _argp_fmtstream_update (argp_fmtstream_t __fs);
@@ -186,7 +190,7 @@ extern void __argp_fmtstream_update (arg
extern int _argp_fmtstream_ensure (argp_fmtstream_t __fs, size_t __amount);
extern int __argp_fmtstream_ensure (argp_fmtstream_t __fs, size_t __amount);
-#ifdef __OPTIMIZE__
+#ifdef __ARGP_OPTIMIZE__
/* Inline versions of above routines. */
#if !_LIBC
@@ -202,7 +206,11 @@ extern int __argp_fmtstream_ensure (argp
#endif
@ -46,3 +58,12 @@ $NetBSD: patch-argp_argp-fmtstream.h,v 1.1 2012/10/20 22:13:28 joerg Exp $
#endif
ARGP_FS_EI size_t
@@ -298,7 +306,7 @@ __argp_fmtstream_point (argp_fmtstream_t
#undef __argp_fmtstream_ensure
#endif
-#endif /* __OPTIMIZE__ */
+#endif /* __ARGP_OPTIMIZE__ */
#endif /* ARGP_FMTSTREAM_USE_LINEWRAP */

View File

@ -0,0 +1,18 @@
$NetBSD: patch-argp_argp-fs-xinl.c,v 1.1 2021/12/26 23:54:01 nros Exp $
* defining __OPTIMIZE__ to nothing causes ssp.h on NetBSD
to crash use __ARGP_OPTIMIZE__ instead to avoid conflict
--- argp/argp-fs-xinl.c.orig 2021-12-26 22:34:56.922104884 +0000
+++ argp/argp-fs-xinl.c
@@ -23,8 +23,8 @@
#endif
#define ARGP_FS_EI
-#undef __OPTIMIZE__
-#define __OPTIMIZE__
+#undef __ARGP_OPTIMIZE__
+#define __ARGP_OPTIMIZE__
#include "argp-fmtstream.h"
/* Add weak aliases. */

View File

@ -0,0 +1,18 @@
$NetBSD: patch-argp_argp-xinl.c,v 1.1 2021/12/26 23:54:01 nros Exp $
* defining __OPTIMIZE__ to nothing causes ssp.h on NetBSD
to crash use __ARGP_OPTIMIZE__ instead to avoid conflict
--- argp/argp-xinl.c.orig 2021-12-26 22:35:33.786126632 +0000
+++ argp/argp-xinl.c
@@ -23,8 +23,8 @@
#endif
#define ARGP_EI
-#undef __OPTIMIZE__
-#define __OPTIMIZE__
+#undef __ARGP_OPTIMIZE__
+#define __ARGP_OPTIMIZE__
#include "argp.h"
/* Add weak aliases. */