Use patch provided by the ATK maintainers to fix GNOME bug 654767. Tested
under NetBSD/amd64 5.1_STABLE and Mac OS 10.6.8. Bump package revision because the shared library version was increased.
This commit is contained in:
parent
8ba16ba64d
commit
8da3ffe3d1
4 changed files with 54 additions and 14 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.77 2011/07/17 12:04:26 tron Exp $
|
||||
# $NetBSD: Makefile,v 1.78 2011/07/18 12:02:02 tron Exp $
|
||||
|
||||
DISTNAME= atk-2.0.1
|
||||
PKGREVISION= 1
|
||||
PKGREVISION= 2
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/atk/2.0/}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.39 2011/07/17 12:04:26 tron Exp $
|
||||
$NetBSD: distinfo,v 1.40 2011/07/18 12:02:02 tron Exp $
|
||||
|
||||
SHA1 (atk-2.0.1.tar.bz2) = f830ff27590e4dd486ebe6538e2b03484faee10a
|
||||
RMD160 (atk-2.0.1.tar.bz2) = 8161a41614bcd13d82b90ae654b24437a165d2c9
|
||||
Size (atk-2.0.1.tar.bz2) = 734314 bytes
|
||||
SHA1 (patch-aa) = fbbcde090aae72ef996bfeee87b9d2075059cdd0
|
||||
SHA1 (patch-aa) = 87889d513b380b8475e8e2190ff9a2fb6a2e59cb
|
||||
SHA1 (patch-ab) = 3b58e35cc51a8d49dd7cfc044547add33611183e
|
||||
|
|
|
@ -1,18 +1,30 @@
|
|||
$NetBSD: patch-aa,v 1.6 2011/07/17 12:04:27 tron Exp $
|
||||
$NetBSD: patch-aa,v 1.7 2011/07/18 12:02:02 tron Exp $
|
||||
|
||||
Work around shared library version problems which cause a version number
|
||||
downgrade that e.g. break Mac OS X. Details are available here:
|
||||
Fix broken shared library version number. Patch taken from here:
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=654767
|
||||
|
||||
--- configure.orig 2011-06-13 17:34:43.000000000 +0100
|
||||
+++ configure 2011-07-17 12:57:10.000000000 +0100
|
||||
@@ -2971,7 +2971,7 @@
|
||||
--- configure.ac.orig 2011-06-13 17:18:30.000000000 +0100
|
||||
+++ configure.ac 2011-07-18 12:43:20.000000000 +0100
|
||||
@@ -21,17 +21,18 @@
|
||||
m4_define([atk_version],
|
||||
[atk_major_version.atk_minor_version.atk_micro_version])
|
||||
|
||||
-dnl The X.Y in -latk-X.Y line. This is expected to stay 1.0 until Atk 2.
|
||||
+dnl The X.Y in -latk-X.Y line. This is expected to stay 1.0 until Atk 3.
|
||||
m4_define([atk_api_version], [1.0])
|
||||
|
||||
dnl Number of releases since we've added interfaces
|
||||
m4_define([atk_interface_age], [1])
|
||||
|
||||
-LT_VERSION_INFO=10:1:10
|
||||
+LT_VERSION_INFO=3210:1:3210
|
||||
LT_CURRENT_MINUS_AGE=0
|
||||
|
||||
+dnl binary_age includes major version as ATK 2 is still fully API and ABI compatible
|
||||
m4_define([atk_binary_age],
|
||||
- [m4_eval(100 * atk_minor_version + 10 + atk_micro_version)])
|
||||
+ [m4_eval(10000 * atk_major_version + 100 * atk_minor_version + 10 + atk_micro_version)])
|
||||
|
||||
m4_define([lt_current],
|
||||
- [m4_eval(100 * atk_minor_version + 10 + atk_micro_version - atk_interface_age)])
|
||||
+ [m4_eval(10000 * atk_major_version + 100 * atk_minor_version + 10 + atk_micro_version - atk_interface_age)])
|
||||
m4_define([lt_revision], [atk_interface_age])
|
||||
m4_define([lt_age], [m4_eval(atk_binary_age - atk_interface_age)])
|
||||
m4_define([lt_version_info], [lt_current:lt_revision:lt_age])
|
||||
|
|
27
devel/atk/patches/patch-ab
Normal file
27
devel/atk/patches/patch-ab
Normal file
|
@ -0,0 +1,27 @@
|
|||
$NetBSD: patch-ab,v 1.6 2011/07/18 12:02:02 tron Exp $
|
||||
|
||||
Fix broken shared library version number. Create with "autoreconf" after
|
||||
applying "patch-aa". Please look here for more details:
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=654767
|
||||
|
||||
--- configure.orig 2011-06-13 17:34:43.000000000 +0100
|
||||
+++ configure 2011-07-18 12:44:14.000000000 +0100
|
||||
@@ -2961,7 +2961,7 @@
|
||||
ATK_VERSION=2.0.1
|
||||
ATK_API_VERSION=1.0
|
||||
ATK_INTERFACE_AGE=1
|
||||
-ATK_BINARY_AGE=11
|
||||
+ATK_BINARY_AGE=20011
|
||||
|
||||
|
||||
|
||||
@@ -2971,7 +2971,7 @@
|
||||
|
||||
|
||||
|
||||
-LT_VERSION_INFO=10:1:10
|
||||
+LT_VERSION_INFO=20010:1:20010
|
||||
LT_CURRENT_MINUS_AGE=0
|
||||
|
||||
|
Loading…
Reference in a new issue