sysutils: Add cfm
Cactus File Manager (cfm) is a TUI file manager with the goal of being simple, easy, and bloat-free, utilizing Vi-inspired keybinds.
This commit is contained in:
parent
bc36f289ae
commit
8dcc088715
6 changed files with 68 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.891 2020/07/01 08:52:38 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.892 2020/07/23 12:38:44 nia Exp $
|
||||
#
|
||||
|
||||
COMMENT= System utilities
|
||||
|
@ -82,6 +82,7 @@ SUBDIR+= cdrkit
|
|||
SUBDIR+= cdrtools
|
||||
SUBDIR+= cfengine2
|
||||
SUBDIR+= cfengine3
|
||||
SUBDIR+= cfm
|
||||
SUBDIR+= checkpassword
|
||||
SUBDIR+= checkpassword-pam
|
||||
SUBDIR+= checkperms
|
||||
|
|
2
sysutils/cfm/DESCR
Normal file
2
sysutils/cfm/DESCR
Normal file
|
@ -0,0 +1,2 @@
|
|||
Cactus File Manager (cfm) is a TUI file manager with the goal of being
|
||||
simple, easy, and bloat-free, utilizing Vi-inspired keybinds.
|
18
sysutils/cfm/Makefile
Normal file
18
sysutils/cfm/Makefile
Normal file
|
@ -0,0 +1,18 @@
|
|||
# $NetBSD: Makefile,v 1.1 2020/07/23 12:38:44 nia Exp $
|
||||
|
||||
DISTNAME= cfm-0.6.3
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= ${MASTER_SITE_GITHUB:=willeccles/}
|
||||
GITHUB_TAG= v${PKGVERSION_NOREV}
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= https://eccles.dev/cfm/
|
||||
COMMENT= Simple and fast TUI file manager with no dependencies
|
||||
LICENSE= mpl-2.0
|
||||
|
||||
MAKE_FLAGS+= MANDIR=${PKGMANDIR}
|
||||
|
||||
CPPFLAGS.NetBSD+= -D_NETBSD_SOURCE # dirfd
|
||||
|
||||
.include "../../mk/curses.buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
3
sysutils/cfm/PLIST
Normal file
3
sysutils/cfm/PLIST
Normal file
|
@ -0,0 +1,3 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2020/07/23 12:38:44 nia Exp $
|
||||
bin/cfm
|
||||
man/man1/cfm.1
|
7
sysutils/cfm/distinfo
Normal file
7
sysutils/cfm/distinfo
Normal file
|
@ -0,0 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.1 2020/07/23 12:38:44 nia Exp $
|
||||
|
||||
SHA1 (cfm-0.6.3.tar.gz) = 864747d2fbd8b6905e6a28b3e25fb5ce49830feb
|
||||
RMD160 (cfm-0.6.3.tar.gz) = 5d43bf4625dad5cc87da8b88426ba4f8a1d59773
|
||||
SHA512 (cfm-0.6.3.tar.gz) = 7e9db3f49b107d97917683870176fb05a21a664cf610e76234bdc74b98a4d254bb4bb7efffb9fe34f314c0316bbc5e9b3a6f523e867b13de32578cab8e4615e3
|
||||
Size (cfm-0.6.3.tar.gz) = 72922 bytes
|
||||
SHA1 (patch-Makefile) = f60dbb3f7c800742ba7ce6d27355d72154b5f3cd
|
36
sysutils/cfm/patches/patch-Makefile
Normal file
36
sysutils/cfm/patches/patch-Makefile
Normal file
|
@ -0,0 +1,36 @@
|
|||
$NetBSD: patch-Makefile,v 1.1 2020/07/23 12:38:44 nia Exp $
|
||||
|
||||
- Don't pass -O3 unconditionally
|
||||
- Support PKGMANDIR
|
||||
|
||||
--- Makefile.orig 2020-07-07 20:26:19.000000000 +0000
|
||||
+++ Makefile
|
||||
@@ -3,9 +3,10 @@ SRC = cfm.c
|
||||
CONF = config.h
|
||||
DEFCONF = config.def.h
|
||||
MANPAGE = cfm.1
|
||||
+MANDIR = share/man
|
||||
PREFIX ?= /usr/local
|
||||
|
||||
-CFLAGS += -O3 -std=c11 -Wall -W -pedantic
|
||||
+CFLAGS += -std=c11 -Wall -W -pedantic
|
||||
CPPFLAGS += -D_XOPEN_SOURCE=700
|
||||
|
||||
.PHONY: all install uninstall clean
|
||||
@@ -20,13 +21,13 @@ $(CONF):
|
||||
|
||||
install: $(TARGET)
|
||||
mkdir -p $(DESTDIR)$(PREFIX)/bin
|
||||
- mkdir -p $(DESTDIR)$(PREFIX)/share/man/man1
|
||||
+ mkdir -p $(DESTDIR)$(PREFIX)/$(MANDIR)/man1
|
||||
install -m755 $(TARGET) $(DESTDIR)$(PREFIX)/bin/$(TARGET)
|
||||
- install -m644 $(MANPAGE) $(DESTDIR)$(PREFIX)/share/man/man1/$(MANPAGE)
|
||||
+ install -m644 $(MANPAGE) $(DESTDIR)$(PREFIX)/$(MANDIR)/man1/$(MANPAGE)
|
||||
|
||||
uninstall:
|
||||
$(RM) $(DESTDIR)$(PREFIX)/bin/$(TARGET)
|
||||
- $(RM) $(DESTDIR)$(PREFIX)/share/man/man1/$(MANPAGE)
|
||||
+ $(RM) $(DESTDIR)$(PREFIX)/$(MANDIR)/man1/$(MANPAGE)
|
||||
|
||||
clean:
|
||||
$(RM) $(TARGET)
|
Loading…
Reference in a new issue