Update libktorrent to version 1.3.1

Also add patches to build with latest boost.

The biggest changes since the 4.2 release include:
- Reintroduction of a tabbed torrent list widget, though a bit different
  then the old tab widget from the 4.1 days.
- Improved support for magnet links
- Support for removable storage
- A whole bunch of bugfixes and smaller improvements over ktorrent
This commit is contained in:
markd 2014-11-17 19:59:40 +00:00
parent 4d351cff0e
commit 8dfa34e702
6 changed files with 154 additions and 76 deletions

View file

@ -1,15 +1,15 @@
# $NetBSD: Makefile,v 1.27 2014/11/07 19:39:25 adam Exp $
# $NetBSD: Makefile,v 1.28 2014/11/17 19:59:40 markd Exp $
DISTNAME= libktorrent-${LIBKTORRENT_VER}
PKGREVISION= 25
CATEGORIES= net kde
MASTER_SITES= http://ktorrent.org/downloads/${KTORRENT_VER}/
DISTFILES= libktorrent-${LIBKTORRENT_FILEVER}.tar.bz2
MASTER_SITES= http://ktorrent.pwsp.net/downloads/${KTORRENT_VER}/
EXTRACT_SUFX= .tar.bz2
.include "../../net/libktorrent/Makefile.version"
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://ktorrent.org/
HOMEPAGE= http://ktorrent.pwsp.net/
COMMENT= Torrent library split from KTorrent
LICENSE= gnu-gpl-v2

View file

@ -1,5 +1,5 @@
# $NetBSD: Makefile.version,v 1.1 2012/09/03 10:06:40 marino Exp $
# $NetBSD: Makefile.version,v 1.2 2014/11/17 19:59:40 markd Exp $
KTORRENT_VER= 4.2.1
LIBKTORRENT_VER= 1.2.1.2
LIBKTORRENT_FILEVER= 1.2.1-2
KTORRENT_VER= 4.3.1
LIBKTORRENT_VER= 1.3.1
LIBKTORRENT_FILEVER= 1.3.1

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.1 2012/09/03 10:06:40 marino Exp $
@comment $NetBSD: PLIST,v 1.2 2014/11/17 19:59:40 markd Exp $
include/libktorrent/bcodec/bdecoder.h
include/libktorrent/bcodec/bencoder.h
include/libktorrent/bcodec/bnode.h
@ -8,20 +8,32 @@ include/libktorrent/datachecker/datacheckerjob.h
include/libktorrent/datachecker/datacheckerthread.h
include/libktorrent/datachecker/multidatachecker.h
include/libktorrent/datachecker/singledatachecker.h
include/libktorrent/dht/announcereq.h
include/libktorrent/dht/announcersp.h
include/libktorrent/dht/announcetask.h
include/libktorrent/dht/database.h
include/libktorrent/dht/dht.h
include/libktorrent/dht/dhtbase.h
include/libktorrent/dht/dhtpeersource.h
include/libktorrent/dht/findnodereq.h
include/libktorrent/dht/findnodersp.h
include/libktorrent/dht/getpeersreq.h
include/libktorrent/dht/getpeersrsp.h
include/libktorrent/dht/kbucket.h
include/libktorrent/dht/kbucketentry.h
include/libktorrent/dht/kbuckettable.h
include/libktorrent/dht/kclosestnodessearch.h
include/libktorrent/dht/key.h
include/libktorrent/dht/node.h
include/libktorrent/dht/nodelookup.h
include/libktorrent/dht/pack.h
include/libktorrent/dht/pingreq.h
include/libktorrent/dht/pingrsp.h
include/libktorrent/dht/rpccall.h
include/libktorrent/dht/rpcmsg.h
include/libktorrent/dht/rpcmsgfactory.h
include/libktorrent/dht/rpcserver.h
include/libktorrent/dht/rpcserverinterface.h
include/libktorrent/dht/task.h
include/libktorrent/dht/taskmanager.h
include/libktorrent/diskio/cache.h
@ -97,6 +109,7 @@ include/libktorrent/peer/authenticate.h
include/libktorrent/peer/authenticatebase.h
include/libktorrent/peer/authenticationmonitor.h
include/libktorrent/peer/chunkcounter.h
include/libktorrent/peer/connectionlimit.h
include/libktorrent/peer/packetreader.h
include/libktorrent/peer/peer.h
include/libktorrent/peer/peerconnector.h
@ -172,13 +185,15 @@ include/libktorrent/utp/utpserverthread.h
include/libktorrent/utp/utpsocket.h
include/libktorrent/version.h
lib/libktorrent.so
lib/libktorrent.so.4
lib/libktorrent.so.4.0.1
lib/libktorrent.so.5
lib/libktorrent.so.5.0.1
${PLIST.docs}share/docs/libktorrent-api/html/accessmanager_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/address_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/addressresolver_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/advancedchokealgorithm_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/annotated.html
${PLIST.docs}share/docs/libktorrent-api/html/announcereq_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/announcersp_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/announcetask_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/array_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/authenticate_8h_source.html
@ -365,6 +380,10 @@ ${PLIST.docs}share/docs/libktorrent-api/html/classbt_1_1CompressThread.html
${PLIST.docs}share/docs/libktorrent-api/html/classbt_1_1CompressThread__inherit__graph.map
${PLIST.docs}share/docs/libktorrent-api/html/classbt_1_1CompressThread__inherit__graph.md5
${PLIST.docs}share/docs/libktorrent-api/html/classbt_1_1CompressThread__inherit__graph.png
${PLIST.docs}share/docs/libktorrent-api/html/classbt_1_1ConnectionLimit-members.html
${PLIST.docs}share/docs/libktorrent-api/html/classbt_1_1ConnectionLimit.html
${PLIST.docs}share/docs/libktorrent-api/html/classbt_1_1ConnectionLimit_1_1Token-members.html
${PLIST.docs}share/docs/libktorrent-api/html/classbt_1_1ConnectionLimit_1_1Token.html
${PLIST.docs}share/docs/libktorrent-api/html/classbt_1_1DNDFile-members.html
${PLIST.docs}share/docs/libktorrent-api/html/classbt_1_1DNDFile.html
${PLIST.docs}share/docs/libktorrent-api/html/classbt_1_1DataChecker-members.html
@ -645,6 +664,11 @@ ${PLIST.docs}share/docs/libktorrent-api/html/classbt_1_1ServerInterface__inherit
${PLIST.docs}share/docs/libktorrent-api/html/classbt_1_1Server__inherit__graph.map
${PLIST.docs}share/docs/libktorrent-api/html/classbt_1_1Server__inherit__graph.md5
${PLIST.docs}share/docs/libktorrent-api/html/classbt_1_1Server__inherit__graph.png
${PLIST.docs}share/docs/libktorrent-api/html/classbt_1_1SignalCatcher-members.html
${PLIST.docs}share/docs/libktorrent-api/html/classbt_1_1SignalCatcher.html
${PLIST.docs}share/docs/libktorrent-api/html/classbt_1_1SignalCatcher__inherit__graph.map
${PLIST.docs}share/docs/libktorrent-api/html/classbt_1_1SignalCatcher__inherit__graph.md5
${PLIST.docs}share/docs/libktorrent-api/html/classbt_1_1SignalCatcher__inherit__graph.png
${PLIST.docs}share/docs/libktorrent-api/html/classbt_1_1SingleDataChecker-members.html
${PLIST.docs}share/docs/libktorrent-api/html/classbt_1_1SingleDataChecker.html
${PLIST.docs}share/docs/libktorrent-api/html/classbt_1_1SingleDataChecker__inherit__graph.map
@ -664,11 +688,6 @@ ${PLIST.docs}share/docs/libktorrent-api/html/classbt_1_1StreamingChunkSelector__
${PLIST.docs}share/docs/libktorrent-api/html/classbt_1_1StreamingChunkSelector__inherit__graph.png
${PLIST.docs}share/docs/libktorrent-api/html/classbt_1_1SuperSeeder-members.html
${PLIST.docs}share/docs/libktorrent-api/html/classbt_1_1SuperSeeder.html
${PLIST.docs}share/docs/libktorrent-api/html/classbt_1_1SuperSeederClient-members.html
${PLIST.docs}share/docs/libktorrent-api/html/classbt_1_1SuperSeederClient.html
${PLIST.docs}share/docs/libktorrent-api/html/classbt_1_1SuperSeederClient__inherit__graph.map
${PLIST.docs}share/docs/libktorrent-api/html/classbt_1_1SuperSeederClient__inherit__graph.md5
${PLIST.docs}share/docs/libktorrent-api/html/classbt_1_1SuperSeederClient__inherit__graph.png
${PLIST.docs}share/docs/libktorrent-api/html/classbt_1_1TimeEstimator-members.html
${PLIST.docs}share/docs/libktorrent-api/html/classbt_1_1TimeEstimator.html
${PLIST.docs}share/docs/libktorrent-api/html/classbt_1_1Timer-members.html
@ -871,6 +890,9 @@ ${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1KBucketEntrySet__inheri
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1KBucketEntry__inherit__graph.map
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1KBucketEntry__inherit__graph.md5
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1KBucketEntry__inherit__graph.png
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1KBucketTable-members.html
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1KBucketTable.html
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1KBucket_1_1UnableToSplit.html
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1KBucket__inherit__graph.map
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1KBucket__inherit__graph.md5
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1KBucket__inherit__graph.png
@ -881,11 +903,6 @@ ${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1Key.html
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1Key__inherit__graph.map
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1Key__inherit__graph.md5
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1Key__inherit__graph.png
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1MsgBase-members.html
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1MsgBase.html
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1MsgBase__inherit__graph.map
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1MsgBase__inherit__graph.md5
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1MsgBase__inherit__graph.png
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1Node-members.html
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1Node.html
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1NodeLookup-members.html
@ -921,8 +938,22 @@ ${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1RPCCallListener__inheri
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1RPCCall__inherit__graph.map
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1RPCCall__inherit__graph.md5
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1RPCCall__inherit__graph.png
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1RPCMethodResolver-members.html
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1RPCMethodResolver.html
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1RPCMsg-members.html
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1RPCMsg.html
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1RPCMsgFactory-members.html
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1RPCMsgFactory.html
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1RPCMsg__inherit__graph.map
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1RPCMsg__inherit__graph.md5
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1RPCMsg__inherit__graph.png
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1RPCServer-members.html
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1RPCServer.html
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1RPCServerInterface-members.html
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1RPCServerInterface.html
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1RPCServerInterface__inherit__graph.map
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1RPCServerInterface__inherit__graph.md5
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1RPCServerInterface__inherit__graph.png
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1RPCServer__inherit__graph.map
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1RPCServer__inherit__graph.md5
${PLIST.docs}share/docs/libktorrent-api/html/classdht_1_1RPCServer__inherit__graph.png
@ -1122,6 +1153,7 @@ ${PLIST.docs}share/docs/libktorrent-api/html/classutp_1_1UTPSocket__inherit__gra
${PLIST.docs}share/docs/libktorrent-api/html/closed.png
${PLIST.docs}share/docs/libktorrent-api/html/compressfilejob_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/connection_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/connectionlimit_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/constants_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/database_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/datachecker_8h_source.html
@ -1209,14 +1241,16 @@ ${PLIST.docs}share/docs/libktorrent-api/html/dynsections.js
${PLIST.docs}share/docs/libktorrent-api/html/encryptedauthenticate_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/encryptedpacketsocket_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/encryptedserverauthenticate_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/errmsg_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/error_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/exitoperation_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/extractfilejob_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/file_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/fileops_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/files.html
${PLIST.docs}share/docs/libktorrent-api/html/findnodereq_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/findnodersp_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/ftv2blank.png
${PLIST.docs}share/docs/libktorrent-api/html/ftv2cl.png
${PLIST.docs}share/docs/libktorrent-api/html/ftv2doc.png
${PLIST.docs}share/docs/libktorrent-api/html/ftv2folderclosed.png
${PLIST.docs}share/docs/libktorrent-api/html/ftv2folderopen.png
@ -1224,62 +1258,62 @@ ${PLIST.docs}share/docs/libktorrent-api/html/ftv2lastnode.png
${PLIST.docs}share/docs/libktorrent-api/html/ftv2link.png
${PLIST.docs}share/docs/libktorrent-api/html/ftv2mlastnode.png
${PLIST.docs}share/docs/libktorrent-api/html/ftv2mnode.png
${PLIST.docs}share/docs/libktorrent-api/html/ftv2mo.png
${PLIST.docs}share/docs/libktorrent-api/html/ftv2node.png
${PLIST.docs}share/docs/libktorrent-api/html/ftv2ns.png
${PLIST.docs}share/docs/libktorrent-api/html/ftv2plastnode.png
${PLIST.docs}share/docs/libktorrent-api/html/ftv2pnode.png
${PLIST.docs}share/docs/libktorrent-api/html/ftv2splitbar.png
${PLIST.docs}share/docs/libktorrent-api/html/ftv2vertline.png
${PLIST.docs}share/docs/libktorrent-api/html/functions.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_0x62.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_0x63.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_0x64.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_0x65.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_0x66.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_0x67.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_0x68.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_0x69.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_0x6b.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_0x6c.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_0x6d.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_0x6e.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_0x6f.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_0x70.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_0x71.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_0x72.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_0x73.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_0x74.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_0x75.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_0x76.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_0x77.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_0x78.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_0x7e.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_b.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_c.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_d.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_e.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_f.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_0x62.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_0x63.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_0x64.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_0x65.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_0x66.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_0x67.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_0x68.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_0x69.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_0x6b.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_0x6c.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_0x6d.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_0x6e.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_0x6f.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_0x70.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_0x72.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_0x73.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_0x74.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_0x75.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_0x76.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_0x77.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_0x78.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_0x7e.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_b.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_c.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_d.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_e.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_f.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_g.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_h.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_i.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_k.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_l.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_m.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_n.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_o.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_p.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_r.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_s.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_t.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_u.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_v.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_w.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_x.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_func_~.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_g.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_h.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_i.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_k.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_l.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_m.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_n.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_o.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_p.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_q.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_r.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_rela.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_s.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_t.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_u.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_v.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_vars.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_w.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_x.html
${PLIST.docs}share/docs/libktorrent-api/html/functions_~.html
${PLIST.docs}share/docs/libktorrent-api/html/getpeersreq_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/getpeersrsp_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/globals_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/graph_legend.html
${PLIST.docs}share/docs/libktorrent-api/html/graph_legend.md5
@ -1371,6 +1405,15 @@ ${PLIST.docs}share/docs/libktorrent-api/html/inherit_graph_120.png
${PLIST.docs}share/docs/libktorrent-api/html/inherit_graph_121.map
${PLIST.docs}share/docs/libktorrent-api/html/inherit_graph_121.md5
${PLIST.docs}share/docs/libktorrent-api/html/inherit_graph_121.png
${PLIST.docs}share/docs/libktorrent-api/html/inherit_graph_122.map
${PLIST.docs}share/docs/libktorrent-api/html/inherit_graph_122.md5
${PLIST.docs}share/docs/libktorrent-api/html/inherit_graph_122.png
${PLIST.docs}share/docs/libktorrent-api/html/inherit_graph_123.map
${PLIST.docs}share/docs/libktorrent-api/html/inherit_graph_123.md5
${PLIST.docs}share/docs/libktorrent-api/html/inherit_graph_123.png
${PLIST.docs}share/docs/libktorrent-api/html/inherit_graph_124.map
${PLIST.docs}share/docs/libktorrent-api/html/inherit_graph_124.md5
${PLIST.docs}share/docs/libktorrent-api/html/inherit_graph_124.png
${PLIST.docs}share/docs/libktorrent-api/html/inherit_graph_13.map
${PLIST.docs}share/docs/libktorrent-api/html/inherit_graph_13.md5
${PLIST.docs}share/docs/libktorrent-api/html/inherit_graph_13.png
@ -1661,6 +1704,8 @@ ${PLIST.docs}share/docs/libktorrent-api/html/job_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/jobqueue_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/jquery.js
${PLIST.docs}share/docs/libktorrent-api/html/kbucket_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/kbucketentry_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/kbuckettable_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/kclosestnodessearch_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/key_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/kioannouncejob_8h_source.html
@ -1686,6 +1731,7 @@ ${PLIST.docs}share/docs/libktorrent-api/html/nodelookup_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/open.png
${PLIST.docs}share/docs/libktorrent-api/html/outputqueue_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/pack_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/packednodecontainer_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/packet_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/packetbuffer_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/packetreader_8h_source.html
@ -1704,6 +1750,8 @@ ${PLIST.docs}share/docs/libktorrent-api/html/peeruploader_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/piece_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/piecedata_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/piecedownloader_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/pingreq_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/pingrsp_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/pipe_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/poll_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/pollpipe_8h_source.html
@ -1719,7 +1767,9 @@ ${PLIST.docs}share/docs/libktorrent-api/html/resourcemanager_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/reverseresolver_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/rpccall_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/rpcmsg_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/rpcmsgfactory_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/rpcserver_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/rpcserverinterface_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/server_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/serverauthenticate_8h_source.html
${PLIST.docs}share/docs/libktorrent-api/html/serverinterface_8h_source.html
@ -1769,8 +1819,6 @@ ${PLIST.docs}share/docs/libktorrent-api/html/structbt_1_1UPnPDeviceDescription-m
${PLIST.docs}share/docs/libktorrent-api/html/structbt_1_1UPnPDeviceDescription.html
${PLIST.docs}share/docs/libktorrent-api/html/structbt_1_1UPnPService-members.html
${PLIST.docs}share/docs/libktorrent-api/html/structbt_1_1UPnPService.html
${PLIST.docs}share/docs/libktorrent-api/html/structdht_1_1BucketHeader-members.html
${PLIST.docs}share/docs/libktorrent-api/html/structdht_1_1BucketHeader.html
${PLIST.docs}share/docs/libktorrent-api/html/structdht_1_1Stats-members.html
${PLIST.docs}share/docs/libktorrent-api/html/structdht_1_1Stats.html
${PLIST.docs}share/docs/libktorrent-api/html/structnet_1_1Port-members.html

View file

@ -1,7 +1,9 @@
$NetBSD: distinfo,v 1.2 2012/11/16 01:05:33 joerg Exp $
$NetBSD: distinfo,v 1.3 2014/11/17 19:59:40 markd Exp $
SHA1 (libktorrent-1.2.1-2.tar.bz2) = 857e4227c4bba685755d66581d881f893f6311ae
RMD160 (libktorrent-1.2.1-2.tar.bz2) = 3daa90d1da8de816ff5b02b46c93e6741a97c8fa
Size (libktorrent-1.2.1-2.tar.bz2) = 896558 bytes
SHA1 (libktorrent-1.3.1.tar.bz2) = 71b377c0cad01dca6061f1fe92f91c4cf05476b3
RMD160 (libktorrent-1.3.1.tar.bz2) = 1fba9d388868345f623d30dd8d7f5bc2c7c68b4b
Size (libktorrent-1.3.1.tar.bz2) = 863105 bytes
SHA1 (patch-examples_ktcli_main.cpp) = 6ed9db8aa7701402d8784cb5209be9b433dc9680
SHA1 (patch-src_net_address.h) = 0689a5efc34062868ffb6e0ebbfe3b00ffdc8c20
SHA1 (patch-src_utp_connection.h) = c9a8f549fe053f6ebe31a2c0d620898f9b12b20e
SHA1 (patch-src_utp_delaywindow.h) = 34854d352993b42836726d3db326661aa78c4aa7

View file

@ -0,0 +1,14 @@
$NetBSD: patch-src_utp_connection.h,v 1.1 2014/11/17 19:59:40 markd Exp $
--- src/utp/connection.h.orig 2014-11-17 18:38:46.000000000 +0000
+++ src/utp/connection.h
@@ -32,7 +32,9 @@
#include <util/circularbuffer.h>
#include <util/timer.h>
#include <utp/remotewindow.h>
+#ifndef Q_MOC_RUN
#include <boost/concept_check.hpp>
+#endif

View file

@ -0,0 +1,14 @@
$NetBSD: patch-src_utp_delaywindow.h,v 1.1 2014/11/17 19:59:40 markd Exp $
--- src/utp/delaywindow.h.orig 2013-01-14 17:09:10.000000000 +0000
+++ src/utp/delaywindow.h
@@ -22,7 +22,9 @@
#ifndef UTP_DELAYWINDOW_H
#define UTP_DELAYWINDOW_H
+#ifndef Q_MOC_RUN
#include <boost/circular_buffer.hpp>
+#endif
#include <utp/utpprotocol.h>
namespace utp