devel/blosc: Import version 1.12.1 from pkgsrc-wip

Blosc is a high performance compressor optimized for binary data. It
has been designed to transmit data to the processor cache faster than
the traditional, non-compressed, direct memory fetch approach via a
memcpy() OS call. Blosc is the first compressor that is meant not only
to reduce the size of large datasets on-disk or in-memory, but also to
accelerate memory-bound computations.

Packaged by me and improved by wiz and coypu.
This commit is contained in:
minskim 2017-09-26 17:38:22 +00:00
parent 95912c5eeb
commit 8e00213dd8
6 changed files with 81 additions and 0 deletions

6
devel/blosc/DESCR Normal file
View file

@ -0,0 +1,6 @@
Blosc is a high performance compressor optimized for binary data. It
has been designed to transmit data to the processor cache faster than
the traditional, non-compressed, direct memory fetch approach via a
memcpy() OS call. Blosc is the first compressor that is meant not only
to reduce the size of large datasets on-disk or in-memory, but also to
accelerate memory-bound computations.

31
devel/blosc/Makefile Normal file
View file

@ -0,0 +1,31 @@
# $NetBSD: Makefile,v 1.1 2017/09/26 17:38:22 minskim Exp $
DISTNAME= blosc-1.12.1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GITHUB:=Blosc/}
GITHUB_PROJECT= c-blosc
GITHUB_TAG= v${PKGVERSION_NOREV}
MAINTAINER= minskim@NetBSD.org
HOMEPAGE= http://blosc.org/
COMMENT= Blocking, shuffling, and lossless compression library
LICENSE= modified-bsd
USE_CMAKE= yes
USE_TOOLS+= pkg-config
USE_LANGUAGES= c c++
CMAKE_ARGS+= -DPREFER_EXTERNAL_LZ4=ON
CMAKE_ARGS+= -DPREFER_EXTERNAL_SNAPPY=ON
CMAKE_ARGS+= -DPREFER_EXTERNAL_ZLIB=ON
CMAKE_ARGS+= -DPREFER_EXTERNAL_ZSTD=ON
TEST_TARGET= test
PKGCONFIG_OVERRIDE+= blosc.pc.in
.include "../../archivers/lz4/buildlink3.mk"
.include "../../archivers/zstd/buildlink3.mk"
.include "../../devel/snappy/buildlink3.mk"
.include "../../devel/zlib/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

8
devel/blosc/PLIST Normal file
View file

@ -0,0 +1,8 @@
@comment $NetBSD: PLIST,v 1.1 2017/09/26 17:38:22 minskim Exp $
include/blosc-export.h
include/blosc.h
lib/libblosc.so.${PKGVERSION}
lib/libblosc.so.1
lib/libblosc.a
lib/libblosc.so
lib/pkgconfig/blosc.pc

13
devel/blosc/buildlink3.mk Normal file
View file

@ -0,0 +1,13 @@
# $NetBSD: buildlink3.mk,v 1.1 2017/09/26 17:38:22 minskim Exp $
BUILDLINK_TREE+= blosc
.if !defined(BLOSC_BUILDLINK3_MK)
BLOSC_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.blosc+= blosc>=1.12.1
BUILDLINK_PKGSRCDIR.blosc?= ../../devel/blosc
.endif # BLOSC_BUILDLINK3_MK
BUILDLINK_TREE+= -blosc

7
devel/blosc/distinfo Normal file
View file

@ -0,0 +1,7 @@
$NetBSD: distinfo,v 1.1 2017/09/26 17:38:22 minskim Exp $
SHA1 (blosc-1.12.1.tar.gz) = 234ca85e3602cceee4d8b106c27fda526bbd733d
RMD160 (blosc-1.12.1.tar.gz) = b04b93363b90015b79964dc4615699fa897e5273
SHA512 (blosc-1.12.1.tar.gz) = f65bbbfce6fc59d0c5a0889d5771dd78cae2796244c6ee69edf15b27c4563c28ce789fded9104a8626d12be3e46418d596dfdb204c43e33abae8dca40debfd92
Size (blosc-1.12.1.tar.gz) = 683510 bytes
SHA1 (patch-CMakeLists.txt) = 70dfc44c1541b1fccd200905acbd16e17a9313e1

View file

@ -0,0 +1,16 @@
$NetBSD: patch-CMakeLists.txt,v 1.1 2017/09/26 17:38:22 minskim Exp $
Don't force -std=gnu99 if we want to possibly use C11
for aligned_alloc
--- CMakeLists.txt.orig 2017-07-19 08:08:12.000000000 +0000
+++ CMakeLists.txt
@@ -201,8 +201,6 @@ if(CMAKE_SYSTEM_PROCESSOR STREQUAL i386
CMAKE_SYSTEM_PROCESSOR STREQUAL amd64 OR
CMAKE_SYSTEM_PROCESSOR STREQUAL AMD64)
if(CMAKE_C_COMPILER_ID STREQUAL GNU)
- # We need C99 (GNU99 more exactly)
- SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu99")
set(COMPILER_SUPPORT_SSE2 TRUE)
if(CMAKE_C_COMPILER_VERSION VERSION_GREATER 4.7 OR CMAKE_C_COMPILER_VERSION VERSION_EQUAL 4.7)
set(COMPILER_SUPPORT_AVX2 TRUE)