Use guile 1.6 instead of 1.4.

Add two patches for modern compilers/usage (unrelated to guile, probably).
PKGREVISION++.
This commit is contained in:
gdt 2007-05-16 18:40:12 +00:00
parent c8429a5376
commit 8e0d83156f
4 changed files with 31 additions and 4 deletions

View file

@ -1,11 +1,11 @@
# $NetBSD: Makefile,v 1.49 2006/12/15 20:32:59 joerg Exp $
# $NetBSD: Makefile,v 1.50 2007/05/16 18:40:12 gdt Exp $
#
# Note: I have tried to update this package to 3.6.0, but there were
# some undefined identifiers "DndDrop" and "DndRawData" in the
# xsiag/window.c file.
DISTNAME= siag-3.5.7
PKGREVISION= 6
PKGREVISION= 7
CATEGORIES= misc textproc math
MASTER_SITES= ftp://siag.nu/pub/siag/
@ -39,7 +39,7 @@ CONFIGURE_ARGS+=--with-xawm=Xaw
.endif
.include "../../devel/ncurses/buildlink3.mk"
.include "../../lang/guile14/buildlink3.mk"
.include "../../lang/guile/buildlink3.mk"
.include "../../x11/libXpm/buildlink3.mk"
.include "../../x11/mowitz/buildlink3.mk"
.include "../../mk/xaw.buildlink3.mk"

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.9 2006/01/20 02:19:22 joerg Exp $
$NetBSD: distinfo,v 1.10 2007/05/16 18:40:13 gdt Exp $
SHA1 (siag-3.5.7.tar.gz) = 007030eb29fc1a4d3a0d78f9d93893cf40b6b84b
RMD160 (siag-3.5.7.tar.gz) = 41f20210e4b5b4704ecd0f539cbcf1d409bb9a1a
@ -8,4 +8,6 @@ SHA1 (patch-ab) = 564a906957521afae681662d0e19fc06996682ac
SHA1 (patch-ac) = e037d16bada6730dfc02890c317d7365a314eb99
SHA1 (patch-ad) = ffcf23d86942253eea4965af4241f62f73e490f4
SHA1 (patch-ae) = 25d31c562a492395b10d680df9e8eabe6aa85603
SHA1 (patch-af) = 6df3759696b2d30314d007a58a4604f97accd769
SHA1 (patch-ag) = b8aa8ab9d51ab0254307f294234cbf2242e29d44
SHA1 (patch-av) = 2e2598ca694ed93ff6bd34c9bb4625f915d412ad

View file

@ -0,0 +1,12 @@
$NetBSD: patch-af,v 1.3 2007/05/16 18:40:13 gdt Exp $
--- xegon/window.c.orig 2003-01-15 18:56:56.000000000 -0500
+++ xegon/window.c
@@ -27,6 +27,7 @@
#include <stdio.h>
#include <string.h>
#include <unistd.h>
+#include <stdlib.h>
#include <X11/Xlib.h>
#include <X11/Xutil.h>

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ag,v 1.3 2007/05/16 18:40:13 gdt Exp $
--- xegon/xegon.h.orig 2003-01-15 18:56:54.000000000 -0500
+++ xegon/xegon.h
@@ -23,7 +23,7 @@ typedef struct {
Boolean play;
} AppData;
-extern AppData app_data;
+/*extern AppData app_data;*/
/* Each list has a frame, a title, a viewport and a list */
typedef struct egon_ui {