Unbreak on php-8, from

<https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=263759>
This commit is contained in:
hauke 2023-10-16 13:02:26 +00:00
parent e1dcb9a538
commit 8e2647a58a
4 changed files with 40 additions and 2 deletions

View File

@ -1,7 +1,8 @@
# $NetBSD: Makefile,v 1.39 2021/04/01 02:42:17 taca Exp $
# $NetBSD: Makefile,v 1.40 2023/10/16 13:02:26 hauke Exp $
DISTNAME= phpPgAdmin-7.13.0
PKGNAME= ${PHP_PKG_PREFIX}-${DISTNAME:S/PgAdmin/pgadmin/}
PKGREVISION= 1
CATEGORIES= databases www
MASTER_SITES= ${MASTER_SITE_GITHUB:=phppgadmin/}
GITHUB_PROJECT= phppgadmin

View File

@ -1,5 +1,7 @@
$NetBSD: distinfo,v 1.17 2021/10/26 10:09:46 nia Exp $
$NetBSD: distinfo,v 1.18 2023/10/16 13:02:26 hauke Exp $
BLAKE2s (phpPgAdmin-7.13.0.tar.gz) = 190395d8201c4dbf7a1c169ce105fddf91d8964825da0780db7fb12b2cfe6425
SHA512 (phpPgAdmin-7.13.0.tar.gz) = 744718b49cd3cb1aa23aea0c402076e1a911892c8b871bac9650e39bcf73c45853f6b24bf699ad3b9432f3e082362577ac899baa4e89f14a4da8cf2fb017fb19
Size (phpPgAdmin-7.13.0.tar.gz) = 804431 bytes
SHA1 (patch-all__db.php) = 6c66ec6e6dab3713c909c3e54e10a9e56f5a6d70
SHA1 (patch-libraries_adodb_drivers_adodb-postgres64.inc.php) = c963b943fb755c7e0a42bc4ba088ac3bae5c1991

View File

@ -0,0 +1,16 @@
$NetBSD: patch-all__db.php,v 1.1 2023/10/16 13:02:26 hauke Exp $
Replace deprecated while instruction, from
<https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=263759>
--- all_db.php.orig 2020-11-07 06:09:12.000000000 +0000
+++ all_db.php
@@ -199,7 +199,7 @@
echo "\t\t<td class=\"data1\">\n";
echo "\t\t\t<select name=\"formEncoding\">\n";
echo "\t\t\t\t<option value=\"\"></option>\n";
- while (list ($key) = each ($data->codemap)) {
+ foreach ($data->codemap as $key => $value) {
echo "\t\t\t\t<option value=\"", htmlspecialchars($key), "\"",
($key == $_POST['formEncoding']) ? ' selected="selected"' : '', ">",
$misc->printVal($key), "</option>\n";

View File

@ -0,0 +1,19 @@
$NetBSD: patch-libraries_adodb_drivers_adodb-postgres64.inc.php,v 1.1 2023/10/16 13:02:26 hauke Exp $
Unbreak on php-8, from
<https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=263759>
--- libraries/adodb/drivers/adodb-postgres64.inc.php.orig 2020-11-07 06:09:12.000000000 +0000
+++ libraries/adodb/drivers/adodb-postgres64.inc.php
@@ -121,6 +121,11 @@ WHERE relkind in ('r','v') AND (c.relnam
{
// changes the metaColumnsSQL, adds columns: attnum[6]
}
+
+ function __construct()
+ {
+ // non-virtual
+ }
function ServerInfo()
{