Add apg-1.2.12: Tool set for random password generation
An automated password generator, using several strong algorithms for random and/or pronounceable password generation, and a built-in pseudo-random number generator. Package contributed by Tomasz Luchowski <zuntum@eik.pl> in PR 12010
This commit is contained in:
parent
0af086a2fb
commit
8e78666e56
8 changed files with 77 additions and 0 deletions
23
security/apg/Makefile
Normal file
23
security/apg/Makefile
Normal file
|
@ -0,0 +1,23 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2001/03/05 23:21:03 hubertf Exp $
|
||||
#
|
||||
|
||||
DISTNAME= apg-1.2.12
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= http://www.adel.nursat.kz/apg/download/
|
||||
|
||||
MAINTAINER= zuntum@eik.pl
|
||||
HOMEPAGE= http://www.adel.nursat.kz/apg/
|
||||
COMMENT= Tool set for random password generation
|
||||
|
||||
MAKE_ENV+= "CC=${CC}" \
|
||||
"FLAGS=${CFLAGS}" \
|
||||
"INSTALL_PREFIX=${PREFIX}"
|
||||
|
||||
post-patch:
|
||||
${SED} "s|/usr/bin/perl|${LOCALBASE}/bin/perl|g" \
|
||||
${WRKSRC}/perl/apgcli.pl > ${WRKDIR}/apgcli.pl
|
||||
|
||||
post-install:
|
||||
${INSTALL_SCRIPT} ${WRKDIR}/apgcli.pl ${PREFIX}/bin/apgcli
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
3
security/apg/files/md5
Normal file
3
security/apg/files/md5
Normal file
|
@ -0,0 +1,3 @@
|
|||
$NetBSD: md5,v 1.1.1.1 2001/03/05 23:21:03 hubertf Exp $
|
||||
|
||||
MD5 (apg-1.2.12.tar.gz) = 02f183cd1170aef922e90c75e81e041d
|
4
security/apg/files/patch-sum
Normal file
4
security/apg/files/patch-sum
Normal file
|
@ -0,0 +1,4 @@
|
|||
$NetBSD: patch-sum,v 1.1.1.1 2001/03/05 23:21:03 hubertf Exp $
|
||||
|
||||
MD5 (patch-aa) = b7b4403483a8c7f9f38bcee2736fbb9a
|
||||
MD5 (patch-ab) = 6dea5f12ef3b1f42a5b3a04bdfe814e9
|
23
security/apg/patches/patch-aa
Normal file
23
security/apg/patches/patch-aa
Normal file
|
@ -0,0 +1,23 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2001/03/05 23:21:03 hubertf Exp $
|
||||
|
||||
--- Makefile.orig Thu Feb 22 12:00:10 2001
|
||||
+++ Makefile
|
||||
@@ -1,10 +1,8 @@
|
||||
# You can modify CC variable if you have compiler other than GCC
|
||||
# But the code was designed and tested with GCC
|
||||
-CC = gcc
|
||||
|
||||
# compilation flags
|
||||
# You should comment the line below for AIX+native cc
|
||||
-FLAGS = -Wall
|
||||
|
||||
# libraries
|
||||
LIBS = -lcrypt
|
||||
@@ -15,7 +13,6 @@
|
||||
CRYPTED_PASS = APG_USE_CRYPT
|
||||
|
||||
# Install dirs
|
||||
-INSTALL_PREFIX = /usr/local
|
||||
APG_BIN_DIR = /bin
|
||||
APG_MAN_DIR = /man/man1
|
||||
APGD_BIN_DIR = /sbin
|
14
security/apg/patches/patch-ab
Normal file
14
security/apg/patches/patch-ab
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2001/03/05 23:21:03 hubertf Exp $
|
||||
|
||||
--- apg.c.orig Thu Feb 22 12:00:10 2001
|
||||
+++ apg.c
|
||||
@@ -35,6 +35,9 @@
|
||||
#include <strings.h>
|
||||
#include <string.h>
|
||||
#include <time.h>
|
||||
+#ifdef __NetBSD__
|
||||
+#include <unistd.h>
|
||||
+#endif
|
||||
#define MAX_MODE_LENGTH 5
|
||||
|
||||
#ifndef _XOPEN_SOURCE
|
3
security/apg/pkg/DESCR
Normal file
3
security/apg/pkg/DESCR
Normal file
|
@ -0,0 +1,3 @@
|
|||
An automated password generator, using several strong algorithms
|
||||
for random and/or pronounceable password generation, and a built-in
|
||||
pseudo-random number generator.
|
1
security/apg/pkg/MESSAGE
Normal file
1
security/apg/pkg/MESSAGE
Normal file
|
@ -0,0 +1 @@
|
|||
You will need perl to use ${PREFIX}/bin/apgcli
|
6
security/apg/pkg/PLIST
Normal file
6
security/apg/pkg/PLIST
Normal file
|
@ -0,0 +1,6 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2001/03/05 23:21:03 hubertf Exp $
|
||||
bin/apg
|
||||
bin/apgcli
|
||||
sbin/apgd
|
||||
man/man1/apg.1
|
||||
man/man8/apgd.8
|
Loading…
Reference in a new issue