pg_repack: updated to 1.4.8

1.4.8
* Added support for PostgreSQL 15
* Fixed --parent-table on declarative partitioned tables
* Removed connection info from error log

1.4.7
* Added support for PostgreSQL 14

1.4.6
* Added support for PostgreSQL 13
* Dropped support for PostgreSQL before 9.4

1.4.5
* Added support for PostgreSQL 12
* Fixed parallel processing for indexes with operators from public schema

1.4.4
* Added support for PostgreSQL 11
* Remove duplicate password prompt
This commit is contained in:
adam 2023-03-03 10:51:10 +00:00
parent 610a7ffa14
commit 8e978aaeaa
4 changed files with 19 additions and 49 deletions

View file

@ -1,22 +1,25 @@
# $NetBSD: Makefile,v 1.10 2022/04/25 06:25:43 wiz Exp $
# $NetBSD: Makefile,v 1.11 2023/03/03 10:51:10 adam Exp $
DISTNAME= pg_repack-1.4.3
DISTNAME= pg_repack-1.4.8
PKGNAME= postgresql${PGSQL_VERSION}-${DISTNAME}
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_GITHUB:=reorg/}
GITHUB_PROJECT= pg_repack
GITHUB_TAG= ver_${PKGVERSION_NOREV}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://reorg.github.io/pg_repack/
COMMENT= Reorganize tables in PostgreSQL databases with minimal locks
LICENSE= modified-bsd
PGSQL_VERSIONS_ACCEPTED?= 10
GITHUB_PROJECT= pg_repack
GITHUB_TAG= ver_${PKGVERSION_NOREV}
WRKSRC= ${WRKDIR}/${GITHUB_PROJECT}-${GITHUB_TAG}
USE_TOOLS+= gmake
PLIST_VARS+= llvm
.include "../../mk/pgsql.buildlink3.mk"
.if !empty(PKG_OPTIONS.postgresql${PGSQL_VERSION}:Mllvm)
PLIST.llvm= yes
.endif
.include "../../mk/bsd.pkg.mk"

View file

@ -1,5 +1,8 @@
@comment $NetBSD: PLIST,v 1.1 2017/08/15 08:34:20 fhajny Exp $
@comment $NetBSD: PLIST,v 1.2 2023/03/03 10:51:10 adam Exp $
bin/pg_repack
${PLIST.llvm}lib/postgresql/bitcode/pg_repack.index.bc
${PLIST.llvm}lib/postgresql/bitcode/pg_repack/pgut/pgut-spi.bc
${PLIST.llvm}lib/postgresql/bitcode/pg_repack/repack.bc
lib/postgresql/pg_repack.so
share/postgresql/extension/pg_repack--${PKGVERSION}.sql
share/postgresql/extension/pg_repack.control

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.6 2021/10/26 10:09:43 nia Exp $
$NetBSD: distinfo,v 1.7 2023/03/03 10:51:10 adam Exp $
BLAKE2s (pg_repack-1.4.3.tar.gz) = 8d6a4d24dc1a110b983fc38b4f4eac91d25d03393697c59a02473226a0edbe5f
SHA512 (pg_repack-1.4.3.tar.gz) = 8fad625665446d7852d09e5c431fa2bf4e767bb5eeaf6718c824c51c558b0ff975af1f2dcce20bc714002fc755c2f6c1d23b0adc2bfa1f9167d198fc59d34cf8
Size (pg_repack-1.4.3.tar.gz) = 93994 bytes
BLAKE2s (pg_repack-1.4.8.tar.gz) = 73479178dcc06ee14b93f9d7dcecf1c57c1dddacc7f0f08880c68dddbeb534dd
SHA512 (pg_repack-1.4.8.tar.gz) = 9854a979aa9056b7c49d52e22622b8faf91cdf4acdb6551044d25733848c2c07b95166a464769da23e0174a63f2b132aa58ba6d6f9b596d1fb95f29098ac3968
Size (pg_repack-1.4.8.tar.gz) = 95801 bytes
SHA1 (patch-bin_Makefile) = 7e82083f0df7e9a1532be323196875bd8ba44520
SHA1 (patch-bin_pg__repack.c) = 55cfbde4e5aeac83c9d6ec75ee0954411f2ca5ad
SHA1 (patch-bin_pg__repack.c) = e983b5e9ce21368fec6fd2c550cd1fad78e94d5b

View file

@ -1,16 +1,7 @@
$NetBSD: patch-bin_pg__repack.c,v 1.1 2020/05/14 19:10:47 joerg Exp $
$NetBSD: patch-bin_pg__repack.c,v 1.2 2023/03/03 10:51:11 adam Exp $
--- bin/pg_repack.c.orig 2020-05-10 00:05:15.102859009 +0000
+++ bin/pg_repack.c
@@ -1176,7 +1176,7 @@ repack_one_table(repack_table *table, co
if (!advisory_lock(connection, buffer))
goto cleanup;
- if (!(lock_exclusive(connection, buffer, table->lock_table, TRUE)))
+ if (!(lock_exclusive(connection, buffer, table->lock_table, true)))
{
if (no_kill_backend)
elog(INFO, "Skipping repack %s due to timeout", table->target_name);
@@ -1210,7 +1210,7 @@ repack_one_table(repack_table *table, co
indexres = execute(
@ -20,30 +11,3 @@ $NetBSD: patch-bin_pg__repack.c,v 1.1 2020/05/14 19:10:47 joerg Exp $
" FROM pg_index WHERE indrelid = $1 AND indisvalid",
2, indexparams);
@@ -1483,7 +1483,7 @@ repack_one_table(repack_table *table, co
/* Bump our existing AccessShare lock to AccessExclusive */
if (!(lock_exclusive(conn2, utoa(table->target_oid, buffer),
- table->lock_table, FALSE)))
+ table->lock_table, false)))
{
elog(WARNING, "lock_exclusive() failed in conn2 for %s",
table->target_name);
@@ -1502,7 +1502,7 @@ repack_one_table(repack_table *table, co
command("BEGIN ISOLATION LEVEL READ COMMITTED", 0, NULL);
if (!(lock_exclusive(connection, utoa(table->target_oid, buffer),
- table->lock_table, FALSE)))
+ table->lock_table, false)))
{
elog(WARNING, "lock_exclusive() failed in connection for %s",
table->target_name);
@@ -2045,7 +2045,7 @@ repack_table_indexes(PGresult *index_det
resetStringInfo(&sql);
appendStringInfo(&sql, "LOCK TABLE %s IN ACCESS EXCLUSIVE MODE",
table_name);
- if (!(lock_exclusive(connection, params[1], sql.data, TRUE)))
+ if (!(lock_exclusive(connection, params[1], sql.data, true)))
{
elog(WARNING, "lock_exclusive() failed in connection for %s",
table_name);