Upgrade net/nagios-plugins to 2.2.1.

Clean up the package a little, and merge in patches from the shared
nagios-plugin-* packages to avoid duplication.  Changes since 2.0.3:

2.2.1 2017-04-19
	FIXES
	check_users: not accepting zero as the threshold
	check_http: reports warning where it should report ok with -e
	check_snmp: does not work with -6 --ipv6 flags
	check_swap: threshold calculation in bytes requires subtracting 65
	check_uptime: fixed backward help text for thresholds
	check_http: Don’t prematurely report success when checking HTTP TLS cert validity
	check_http: fix parsing the last header
	check_mailq: Fix for Postfix and better Sudo Checking
	configure.ac: Fix spelling error
	check_ntp_peer: requires newline when there is a socket timeout (fix in netutils.c)
	check_users: segmentation fault if both thresholds are not provided
	check_dns: DNS CRITICAL - expected ‘{hostname}.’ but got 'name = {hostname}.'
	check_mailq: Nullmailer Regex is not working for Ubuntu 16.04
	check_swap: Downstream Fedora patch: Prevent check_swap from returning OK, if no swap activated
	Building RPMs on Amazon Linux - Add 'install-root' on line 165 of spec file


2.2.0 2017-01-19
	ENHANCEMENTS
	check_flexlm: if `-F <license file>` is not specified, will use `LM_LICENSE_FILE` environment var
	check_load: Added per cpu load average message
	check_smtp: add -L flag to support LMTP (LHLO instead of HELO/EHLO)

	FIXES
	check_http: -e breaks -f
	check_mrtg: Add state to status output
	check_ping: ping runs 30 times when host is down
	check_icmp: does not have the -p argument in the help
	check_dns: Segfaulting with timeout > 26 sec
	check_disk: missing -lrt on Solaris
	check_http: segmentation fault
	check_http: help text update for virtual hosts
	check_snmp: Thresholds were being shown twice
	check_hpjd: some jd 610 cards have a false flag that printer is offline
	check_http: Handle reference redirect like //www.site.org/test
	check_disk: alerts issued too soon
	fix: Allocator sizeof operand mismatch
	fix: Dead assignment
	Shellcheck: fix most of the shellcheck warnings.
	check_ntp: touch ntp servers at most once every seconds
	check_dns: authoritative test (-A) is broken
	check_dns: reports TXT records incorrectly
	check_file_age: does not handle filenames WITHOUT space!
	de,fr.po: fix syntax errors end-of-line within string
	lib/parse_ini.c: fix gcc warning: implicit declaration of function ‘idpriv_temp_drop’ and ‘idpriv_temp_restore’
	add openssl 1.1 support


2.1.4 2016-11-17
	FIXES
	check_http: Don't include default Accept header if one is provided
	check_disk: added "fuse.gvfsd-fuse" to list of fs types to ignore
	check_http: Fixed non-text chunked-encoded decoding
	check_http: segmentation fault (FreeBSD)
	check_dns: Update IF_RECORD to not erase query_found
	check_http: SSL Certificate check returns 12:00:00AM <local timezone>
	check_http: -u is misleading. Changed help text
	check_file_age: does not handle filenames with space
	check_snmp: units label option outputs the label in the incorrect location
	plugins-root/check_dhcp.c: fix a potential segfault
    check_users: not correctly detecting thresholds


2.1.3 2016-09-12
	ENHANCEMENTS
	SNI support in check_tcp (ddbilik)
	check_disk_smb.pl: add support for -k for kerberos authentication
	check_file_age.c: allow wildcard matching

	FIXES
	check_tcp.c: tools/build_perl_modules hardcodes the perl used
	check_game.c: reports ping as number of players (Jason Rivers)
	fix some gcc5 warnings (Mario Trangoni)
	check_cluster.c: Update wording in comments (Troy Lea)
	check_nagios.c: could not locate a running nagios process
	check_swap.c: does not accept threshold of zero
	check_swap.c: uses inconsistent checks on negative thresholds
	check_snmp.c: --offset does not appear to do anything (Troy Lea)
	sslutils.c: output has first line of "SSL Version: xxxxxx"
	  effects anything using sslutils including check_http, check_dhcp
	  and others
	utils_cmd.c: when using ssh (or check-by-ssh) with ControlMaster/ControlPersist,
	  nagios times out the first time and one gets zombie processes (Gordon Messmer)


2.1.2 2016-08-01
	SECURITY FIXES

	ENHANCEMENTS
	check_snmp's performance data now also includes warning/critical
	  thresholds
	New check_snmp "-N" option to specify SNMPv3 context name
	New check_nt "-l" parameters: seconds|minutes|hours|days
	New check_mailq -s option which tells the plugin to use sudo(8)
	New -W/-C option for check_ldap to check number of entries (Gerhard Lausser)
	The check_http -S/--ssl option now accepts the arguments "1.1" and "1.2"
	  to force TLSv1.1 and TLSv1.2 connections, respectively
	The check_http -S/--ssl option now allows for specifying the desired
	  protocol with a "+" suffix to also accept newer versions
	New check_disk "-v" option to show troubled partition in verbose mode
	check_log.sh: Added a parameter -w (--max_warning) defining upper value to return a warning code
	check_ldap: Add support for LDAP URIs.
	check_file_age: Provide performance data
	check_by_ssh: added --hostname support
	check_ifstatus.pl: Add check_ifstatus option to ignore interfaces by name
	check_snmp: Introduce support for SNMPv3 context using "-N" option
	check_snmp.c: Added IPv6 support
	check_http: Added support for checking SSL-Websites through Proxies

	FIXES
	check_dig can now also use "drill" instead of "dig"
	check_dig honor the -4 and -6 switches
	check_ntp_peer: do not use uninitialized results for max state
	check_log.sh, check_oracle.sh, check_sensors.sh: Setting PATH at first
	check_log.sh: droping path from basename while evaluating PROGNAME
	check_tcp: Fix check_jabber to work with Openfire servers
	check_ifstatus.pl: Fix "-n" and "-u" options to ignore if either is set, not just both
	check_mrtgtraf: Fix perfdata to comply with perfdata UOM definition
	check_real, check_ntp: fix null termination
	check_apt: fix memset
	check_ssh: change warning to critical for protocal/version errors
	utils_cmd.c: avoid a segfault, if ulimit is set to unlimited
	utils_cmd.c: make constants from maxfd values
	configure.ac: Added particular ps command for HP-UX
	check_disk: Fix pthread start routine type
	check_http: Make header_value() and chunked-encoding decoding more robust
	check_http: fix Host header if explicitly set with -k
	sslutils.c: Forcing furter restriction of ciphers for current security concerns
	check_nagios, check_procs: Enable check_proc to monitor processes in PID name-spaced environments.
	check_dhcp.c: use /dev/urandom if available
	check_http.c: Don't decode page if it's not there
	check_disk.c: Prevent large tide values from truncation
	pst3.c: Fix for unclosed filehandle in pst3 on Solaris
	check_snmp: Timeticks are not being parsed correctly before performance data
        multiple *.h files: standardized header include fences
        multiple plugins/*.c files: fix unsafe signal handling
	sslutils.c: Fix compilation with GnuTLS which doesn't provide SSL_CTX_check_private_key()
	check_mailq.pl: fixed mailer names
	check_swap.c: Improving output when swap space has zero size
	check_icmp.c: Use kernel reception time on ICMP packets to compute rtt.
	check_icmp.c: make use of MSG_CONFIRM optional
	check_ldap.c: add counting of entries to check_ldap
	utils.c: add sperfdata() function which can handle threshold ranges
	sslutils.c: Check if OpenSSL supports SSLv3.
	check_dhcp.c: Fixes segfaults when running via monitoring worker (off-by-one)
	check_fping.c: autodetect ipv6 addresses
	sslutils.c: optimize output if certificate expires in less then 24h
	check_smtp.c: Let "-D" option imply "-S". Also QUIT SMTP connection when "-D" is used
	check_smtp.c: modified SSL check for use with -e
	check_tcp.c: Validate sent data size
	check_dns.c: conditional assignment
	check_dns.c: macro querytypes and auto cnames
	utils_cmd.c, utils_base.c: Multiple resource leaks
	check_http.c: Increase MAX_RE_SIZE from 256 to 2048
	check_procs.c: Changed the ps command args from axwo to axwwo allowing for longer output
	check_http.c: Allow a server to reply using only 'HTTP/1.x 200 OK' and a
		body, with no headers
	check_nt.c: check_nt does not correctly report a DNS entry it cannot resolve
	check_dhcp.c: check_dhcp broken on BSD

	TESTS
	check_procs.t: Add delay after forking in test to avoid race condition
	test.pl.in: Use "C" locale when running test suite
	check_http.t: Adjust date strings to the now-localized output
	check_dns.t - Fix Perl Warning. perl doesn't understand /d within "".
	check_snmp.t: skip extented snmp tests if snmpd has no perl support
	check_snmp.t: fix snmp test for included threshold
	check_http.t: fix tests for certificates expire date with seconds
	check_http.t: add faketime based tests for check_http

	LOCALIZATION

2.1.0 30th July 2015
	SECURITY FIXES
	ssl_utils.c - Disable SSLv3 & SSLv2 autonegotiation by default to limit poodle and other weak cipher attacks (sreinhardt)

	ENHANCEMENTS
	Timeout States Implemented - Plugins that support a timeout state will now also support specifying the exit state in case of timeout with the syntax -t <timeout>:<state> (abrist)
	Perl plugins now use FindBin for path discovery, obsoleting the nasty AWK script (evgeni, abrist)
	check_http.c - Added support for chunked transfer-encoding (koenwtje, dermoth, sreinhardt)
	check_radius.c - Added support for the FreeRADIUS Client library (weiss)
	check_snmp.c - Added thresholds to performance data (seemuellera)
	check_snmp.c - Added new option (-N) for SNMPv3 context (Johannes Engel)
	check_snmp.c - Added IPv6 support (abrist)
	check_ldap.c - Added a new option (-U) for LDAP URI support (qris)
	check_ifstatus.pl - Added new option (-n) to exclude interfaces (peelman, weiss)
	check_file_age.pl - Performance data output added (hggh)
	check_mailq.pl - Now supports sudo (Christopher Schultz, weiss)
	check_log.sh - Added a new option (-w) defining upper value to return a warning code (arvanus)

	FIXES
	check_by_ssh.c - Added --hostname support (sni)
	check_dbi.c - Spelling corrections (sreinhardt)
	check_dig.c - Fixed to work with dig/drill tools and ip version switch is now respected (abgandar)
	check_disk.c - Fix for hanging filesystems (Gerhard Lausser)
	check_disk.c - Partitions in problem state now reported in verbose mode (waja)
	check_disk.c - Prevent large tide values from truncation (JesperForsberg)
	check_dns.c - Server specific fixes and other cleanup (sreinhardt)
	check_http.c - Some small changes for readability (koenwtje)
	check_mrtgtraf.c - Added verbose output (sreinhardt)
	check_mrtgtraf.c - Perfdata now complies with UOM definition (Bobzikwick)
	check_ntp_peer.c - No longer uses uninitialized results for max state (sni)
	check_procs.c - Rare race condition fixed (Mikael Falkvidd)
	check_ssh.c - Now exits with CRITICAL when version/protocol string check fails to match (sni)
	check_tcp.c - Help description of escape characters now correct (Sebastian Herbszt)
	check_tcp.c - Fix to support Openfire servers with check_jabber (weiss)
	check_ups.c - Spelling corrections (sreinhardt)
	pst3.c - Fix for unclosed file handle in pst3 on Solaris (jwinkle01)
	plugins-scripts/*.sh - Trusted path fixes (waja)
	netutils.h - Decreased max path to 104 bytes to compensate for BSD paths (sreinhardt)
	configure.ac - Fix for HP-UX ps command (Tontonitch)
	lib/utils_cmd.c - Fix for potential segfault when ulimits are set to unlimited (nafets)
	lib/parse_ini.c - Many small fixes from coverity scans and the community (sreinhardt, weiss)
	lib/util_base.c - Code cleanup (sreinhardt)
	lib/utils_base.c - Add EIUD to state retention path for multi-user permissions support (sreinhardt)
	po/* - Spelling corrections (sreinhardt)
	Multiple resource leaks fixed (sreinhardt)
	Many other small fixes and cleanup caught by coverity (multiple contributors)

	TESTS
	Many small fixes to tests (multiple contributors)

	LOCALIZATION
	Many small fixes for locales and localizations (multiple contributors)
This commit is contained in:
jperkin 2017-07-04 19:45:18 +00:00
parent ca2b8ac385
commit 8e9f873c23
16 changed files with 191 additions and 164 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.44 2016/10/01 18:23:18 bouyer Exp $
# $NetBSD: Makefile,v 1.45 2017/07/04 19:45:18 jperkin Exp $
#
PKGREVISION= 4
CATEGORIES= net sysutils
MAINTAINER= pkgsrc-users@NetBSD.org
@ -13,12 +12,9 @@ PKG_DESTDIR_SUPPORT= user-destdir
.include "../../net/nagios-plugins/Makefile.common"
.include "../../mk/bsd.prefs.mk"
USE_TOOLS+= msgfmt msgmerge intltool perl:run xgettext
PKG_GROUPS+= ${NAGIOS_GROUP}
BUILD_DEFS+= ${NAGIOS_GROUP}
CONFIGURE_ARGS+= --without-pgsql --without-mysql \
--without-smbclient-command --without-snmpget-command \
@ -28,13 +24,14 @@ CONFIGURE_ARGS+= --without-pgsql --without-mysql \
SPECIAL_PERMS+= ${PREFIX}/libexec/nagios/check_icmp ${SETUID_ROOT_PERMS}
SPECIAL_PERMS+= ${PREFIX}/libexec/nagios/check_dhcp ${SETUID_ROOT_PERMS}
PLIST_VARS+= linux sunos NetBSD
.if ${OPSYS} == "Linux"
PLIST.linux= yes
.elif ${OPSYS} == "SunOS"
PLIST.sunos= yes
.elif ${OPSYS} == "NetBSD"
PLIST.NetBSD= yes
PLIST_VARS+= ide swap
.if ${OPSYS} == "Linux" || ${OPSYS} == "NetBSD"
PLIST.ide= yes
.endif
.if ${OPSYS} != "Darwin"
PLIST.swap= yes
.endif
.if ${OPSYS} == "NetBSD"

View file

@ -1,17 +1,22 @@
# $NetBSD: Makefile.common,v 1.12 2016/02/25 16:20:51 jperkin Exp $
# $NetBSD: Makefile.common,v 1.13 2017/07/04 19:45:18 jperkin Exp $
#
# used by net/nagios-plugin-ldap/Makefile
# used by net/nagios-plugin-mysql/Makefile
# used by net/nagios-plugin-pgsql/Makefile
# used by net/nagios-plugin-radius/Makefile
# used by net/nagios-plugin-snmp/Makefile
# used by net/nagios-plugins/Makefile
PLUGINSVERSION= 2.0.3
PLUGINSVERSION= 2.2.1
DISTNAME= nagios-plugins-${PLUGINSVERSION}
MASTER_SITES?= http://nagios-plugins.org/download/
.include "../../net/nagios-base/Makefile.common"
.include "../../mk/bsd.prefs.mk"
DISTINFO_FILE?= ${.CURDIR}/../../net/nagios-plugins/distinfo
PATCHDIR?= ${.CURDIR}/../../net/nagios-plugins/patches
BUILD_DEFS+= NAGIOS_USER NAGIOS_GROUP
CONFIGURE_ARGS.DragonFly+= fu_cv_sys_stat_statvfs=no

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.10 2015/04/03 17:50:27 rodent Exp $
@comment $NetBSD: PLIST,v 1.11 2017/07/04 19:45:18 jperkin Exp $
libexec/nagios/check_by_ssh
libexec/nagios/check_clamd
libexec/nagios/check_dhcp
@ -11,8 +11,7 @@ libexec/nagios/check_fping
libexec/nagios/check_ftp
libexec/nagios/check_http
libexec/nagios/check_icmp
${PLIST.linux}libexec/nagios/check_ide_smart
${PLIST.NetBSD}libexec/nagios/check_ide_smart
${PLIST.ide}libexec/nagios/check_ide_smart
libexec/nagios/check_imap
libexec/nagios/check_ircd
libexec/nagios/check_jabber
@ -40,14 +39,13 @@ libexec/nagios/check_smtp
libexec/nagios/check_spop
libexec/nagios/check_ssh
libexec/nagios/check_ssmtp
libexec/nagios/check_swap
${PLIST.swap}libexec/nagios/check_swap
libexec/nagios/check_tcp
libexec/nagios/check_time
libexec/nagios/check_udp
libexec/nagios/check_ups
libexec/nagios/check_users
libexec/nagios/negate
${PLIST.sunos}libexec/nagios/pst3
libexec/nagios/urlize
libexec/nagios/utils.pm
libexec/nagios/utils.sh

View file

@ -1,15 +1,16 @@
$NetBSD: distinfo,v 1.20 2016/10/01 18:23:18 bouyer Exp $
$NetBSD: distinfo,v 1.21 2017/07/04 19:45:18 jperkin Exp $
SHA1 (nagios-plugins-2.0.3.tar.gz) = 29b6183ab9d796299dc17c395eef493415d1e9d6
RMD160 (nagios-plugins-2.0.3.tar.gz) = b682b126c78df51f64d9cb8599d2f9dfd411d5f4
SHA512 (nagios-plugins-2.0.3.tar.gz) = 2753e6f3fc7433a5583fee01e63a65b9ea74155964f2b6e6bf3458e56cb29ea5dbd020f83816044a717b66d6548d203b3a082fba0faedcd629c7a8457bc19b36
Size (nagios-plugins-2.0.3.tar.gz) = 2659772 bytes
SHA1 (patch-ad) = 04115d0c41419fccfc2735745dc349f81061fff9
SHA1 (patch-af) = 8fd2e50ca63f014f88195552884913c7383cb6a1
SHA1 (patch-ah) = f884e80c1e09fefd5e37f087d95d3b76b9d44ab6
SHA1 (patch-ai) = 645ebd4ac16a71bd5944fe3850c809cb45bf6a4c
SHA1 (patch-ak) = 093638669dd5b524d8a9b31d452f1ba737e684b3
SHA1 (patch-an) = 6ba8dec0eb62cd0097809daf8075248afd448695
SHA1 (patch-configure) = 8a06bbd0fa0649625ffb1c8e2f4b667714a40fe4
SHA1 (patch-plugins-root_Makefile.in) = e4352f38bd0085f5c0acd9d058f1aa5d76676fff
SHA1 (patch-plugins__check_swap.c) = 4a32398b3e8e596b9f67b3ea95a3acce37287b0b
SHA1 (nagios-plugins-2.2.1.tar.gz) = 0d3fc8876343a906f0dcc2c00850e4ad956a150a
RMD160 (nagios-plugins-2.2.1.tar.gz) = 39c364ac08854a1829d47562d4add1ae58a49334
SHA512 (nagios-plugins-2.2.1.tar.gz) = 6ffe313a56a305b382f62abc0f0958d7078f9050e1340f30721d6e6f71944b57b1650e90e6835c35dd7c9f3f4b4cee9f235b8382b0811db30b3729daaafc9bc3
Size (nagios-plugins-2.2.1.tar.gz) = 2728818 bytes
SHA1 (patch-ad) = cad52f9d8c5a6b53a1b512238df1590c0fa2177d
SHA1 (patch-af) = 12ea1194eee95ea15ecc6d7daedd10eb9541ee6e
SHA1 (patch-ah) = 99b5eb4896262f5aa1de60e9f42c395a59794a6b
SHA1 (patch-an) = a6adf179db754f98b2da118a8c1101edda026fbc
SHA1 (patch-configure) = d418b81f06e22b769cd187a77f45f0add605698e
SHA1 (patch-plugins-root_Makefile.in) = 46e8968df375ca35d453e36c277d4052f125897b
SHA1 (patch-plugins-scripts_check__breeze.pl) = 57ffda78989fd0d0c0fa26c74b7f53bd083dab4f
SHA1 (patch-plugins-scripts_check__wave.pl) = 535b008877cad780afa2ed3429ffb84e7da3ec28
SHA1 (patch-plugins__check_swap.c) = b822de3488ecace977a739ebcfc56229763cd945
SHA1 (patch-plugins_check__radius.c) = 3f86bac4f7aa52931bad46d9ee4a421c2ee744f3

View file

@ -1,10 +1,11 @@
$NetBSD: patch-ad,v 1.6 2016/10/01 18:23:18 bouyer Exp $
$NetBSD: patch-ad,v 1.7 2017/07/04 19:45:18 jperkin Exp $
Exclude plugins that would require extra dependancies.
Some can be found in specific nagios plugin packages.
--- plugins-scripts/Makefile.in.orig 2014-06-26 16:17:33.000000000 +0000
--- plugins-scripts/Makefile.in.orig 2017-04-19 16:03:25.000000000 +0000
+++ plugins-scripts/Makefile.in
@@ -1288,15 +1288,11 @@ top_srcdir = @top_srcdir@
@@ -1300,15 +1300,11 @@ top_srcdir = @top_srcdir@
with_trusted_path = @with_trusted_path@
@RELEASE_PRESENT_TRUE@NP_VERSION = @NP_RELEASE@
SUFFIXES = .pl .sh
@ -17,11 +18,11 @@ Some can be found in specific nagios plugin packages.
- check_log.sh check_ntp.pl check_oracle.sh check_rpc.pl check_sensors.sh \
- check_ifstatus.pl check_ifoperstatus.pl check_wave.pl check_mailq.pl check_file_age.pl \
- utils.sh.in utils.pm.in t
+libexec_SCRIPTS = check_ircd check_log check_ntp check_rpc check_mailq \
+ check_file_age utils.sh utils.pm
+
+libexec_SCRIPTS = check_ircd check_log check_ntp check_rpc \
+ check_mailq check_file_age utils.sh utils.pm
+
+EXTRA_DIST = check_ircd.pl check_log.sh check_ntp.pl check_rpc.pl \
+ check_mailq.pl check_file_age.pl utils.sh.in utils.pm.in t
+ check_mailq.pl check_file_age.pl utils.sh.in utils.pm.in t
TESTS_ENVIRONMENT = perl -I $(top_builddir) -I $(top_srcdir)
TESTS = @SCRIPT_TEST@
EDIT = sed \
-e 's|[@]NP_VERSION[@]|$(NP_VERSION)|g' \

View file

@ -1,4 +1,6 @@
$NetBSD: patch-af,v 1.6 2015/04/03 17:50:27 rodent Exp $
$NetBSD: patch-af,v 1.7 2017/07/04 19:45:18 jperkin Exp $
Exclude specific plugins.
--- plugins/Makefile.in.orig 2014-06-26 16:17:33.000000000 +0000
+++ plugins/Makefile.in

View file

@ -1,4 +1,6 @@
$NetBSD: patch-ah,v 1.4 2015/04/03 17:50:27 rodent Exp $
$NetBSD: patch-ah,v 1.5 2017/07/04 19:45:18 jperkin Exp $
Unknown patch, please document.
--- plugins-scripts/check_ntp.pl.orig 2014-03-04 21:41:57.000000000 +0000
+++ plugins-scripts/check_ntp.pl

View file

@ -1,21 +0,0 @@
$NetBSD: patch-ai,v 1.3 2015/04/03 17:50:27 rodent Exp $
--- plugins-scripts/subst.in.orig 2014-03-04 21:41:57.000000000 +0000
+++ plugins-scripts/subst.in
@@ -9,13 +9,14 @@ function which(c,path) {
sub(/\/.*\//,"",c);
for (dir in path) {
+ if (match(path[dir], /.tools/ ) != 0 ) {
+ continue;
+ }
cmd = "test -x " path[dir] "/" c;
if (system(cmd)==0) {
return path[dir] "/" c;
}
}
-
-
return c;
}

View file

@ -1,76 +0,0 @@
$NetBSD: patch-ak,v 1.7 2015/04/13 03:59:41 rodent Exp $
--- gl/mountlist.c.orig 2014-03-04 21:41:56.000000000 +0000
+++ gl/mountlist.c
@@ -52,7 +52,11 @@
# if HAVE_STRUCT_FSSTAT_F_FSTYPENAME
# define FS_TYPE(Ent) ((Ent).f_fstypename)
# else
-# define FS_TYPE(Ent) mnt_names[(Ent).f_type]
+# if defined(STAT_STATVFS)
+# define FS_TYPE(Ent) mnt_names[(Ent).f_fsid]
+# else
+# define FS_TYPE(Ent) mnt_names[(Ent).f_type]
+# endif
# endif
#endif /* MOUNTED_GETFSSTAT */
@@ -99,6 +103,10 @@
# include <sys/statfs.h>
#endif
+#if defined(HAVE_SYS_STATVFS_H)
+#include <sys/statvfs.h>
+#endif
+
#ifdef MOUNTED_LISTMNTENT
# include <mntent.h>
#endif
@@ -223,7 +231,7 @@ me_remote (char const *fs_name, char con
#if MOUNTED_GETMNTINFO
-# if ! HAVE_STRUCT_STATFS_F_FSTYPENAME
+# if ! HAVE_STRUCT_STATFS_F_FSTYPENAME && ! STAT_STATVFS
static char *
fstype_to_string (short int t)
{
@@ -320,9 +328,13 @@ fstype_to_string (short int t)
# endif
static char *
+#if defined(STAT_STATVFS) && !defined(__FreeBSD__)
+fsp_to_string (const struct statvfs *fsp)
+#else
fsp_to_string (const struct statfs *fsp)
+#endif
{
-# if HAVE_STRUCT_STATFS_F_FSTYPENAME
+# if defined(HAVE_STRUCT_STATFS_F_FSTYPENAME) || defined(STAT_STATVFS)
return (char *) (fsp->f_fstypename);
# else
return fstype_to_string (fsp->f_type);
@@ -648,7 +660,11 @@ read_file_system_list (bool need_fs_type
{
int numsys, counter;
size_t bufsize;
+#if defined(STAT_STATVFS) && !defined(__FreeBSD__)
+ struct statvfs *stats;
+#else
struct statfs *stats;
+#endif
numsys = getfsstat (NULL, 0L, MNT_NOWAIT);
if (numsys < 0)
@@ -658,7 +674,11 @@ read_file_system_list (bool need_fs_type
bufsize = (1 + numsys) * sizeof *stats;
stats = xmalloc (bufsize);
+#if defined(STAT_STATVFS)
+ numsys = getfsstat ((struct statvfs *)stats, bufsize, MNT_NOWAIT);
+#else
numsys = getfsstat (stats, bufsize, MNT_NOWAIT);
+#endif
if (numsys < 0)
{

View file

@ -1,4 +1,6 @@
$NetBSD: patch-an,v 1.5 2015/04/03 17:50:27 rodent Exp $
$NetBSD: patch-an,v 1.6 2017/07/04 19:45:18 jperkin Exp $
Pull in CPPFLAGS_LFS.
--- lib/Makefile.in.orig 2014-06-26 16:17:32.000000000 +0000
+++ lib/Makefile.in

View file

@ -1,19 +1,19 @@
$NetBSD: patch-configure,v 1.2 2015/04/03 17:50:27 rodent Exp $
$NetBSD: patch-configure,v 1.3 2017/07/04 19:45:18 jperkin Exp $
Disable all the plugins which are installed by the nagios-plugin-* packages.
--- configure.orig 2014-06-26 16:17:37.000000000 +0000
--- configure.orig 2017-04-19 16:03:27.000000000 +0000
+++ configure
@@ -17188,7 +17188,7 @@ _ACEOF
@@ -17422,7 +17422,7 @@ _ACEOF
fi
- if test "$ac_cv_lib_radiusclient_rc_read_config" = "yes"; then
+ if false; then
EXTRAS="$EXTRAS check_radius\$(EXEEXT)"
RADIUSLIBS="-lradiusclient"
- if test "$ac_cv_lib_radiusclient_rc_read_config" = "yes"; then
+ if false; then
EXTRAS="$EXTRAS check_radius\$(EXEEXT)"
RADIUSLIBS="-lradiusclient"
@@ -17363,7 +17363,7 @@ _ACEOF
@@ -17518,7 +17518,7 @@ _ACEOF
fi
@ -22,7 +22,7 @@ Disable all the plugins which are installed by the nagios-plugin-* packages.
LDAPLIBS="-lldap -llber"\
LDAPINCLUDE="-I/usr/include/ldap"
@@ -18791,6 +18791,9 @@ cat confdefs.h >>conftest.$ac_ext
@@ -18947,6 +18947,9 @@ cat confdefs.h >>conftest.$ac_ext
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
#ifdef HAVE_UNISTD_H
@ -32,7 +32,7 @@ Disable all the plugins which are installed by the nagios-plugin-* packages.
#include <unistd.h>
#endif
#include <netinet/in.h>
@@ -21524,7 +21527,7 @@ elif test "$ac_cv_uname_s" = "SunOS"; th
@@ -21721,7 +21724,7 @@ elif test "$ac_cv_uname_s" = "SunOS"; th
ac_cv_ps_cols=9
{ $as_echo "$as_me:$LINENO: result: using nagios-plugins internal ps command (pst3) for solaris" >&5
$as_echo "using nagios-plugins internal ps command (pst3) for solaris" >&6; }
@ -41,7 +41,7 @@ Disable all the plugins which are installed by the nagios-plugin-* packages.
pst3_use_64bit=1
{ $as_echo "$as_me:$LINENO: using 64bit pst3" >&5
$as_echo "$as_me: using 64bit pst3" >&6;}
@@ -22521,7 +22524,7 @@ fi
@@ -22748,7 +22751,7 @@ fi
then
{ $as_echo "$as_me:$LINENO: checking for nslookup syntax" >&5
$as_echo_n "checking for nslookup syntax... " >&6; }
@ -50,7 +50,7 @@ Disable all the plugins which are installed by the nagios-plugin-* packages.
then
ac_cv_nslookup_command="$PATH_TO_NSLOOKUP"
{ $as_echo "$as_me:$LINENO: result: $ac_cv_nslookup_command" >&5
@@ -22910,7 +22913,7 @@ fi
@@ -23137,7 +23140,7 @@ fi
# Check whether --with-snmpget_command was given.
@ -59,7 +59,7 @@ Disable all the plugins which are installed by the nagios-plugin-* packages.
withval=$with_snmpget_command; PATH_TO_SNMPGET=$withval
fi
@@ -22921,7 +22924,7 @@ cat >>confdefs.h <<_ACEOF
@@ -23148,7 +23151,7 @@ cat >>confdefs.h <<_ACEOF
#define PATH_TO_SNMPGET "$PATH_TO_SNMPGET"
_ACEOF
@ -68,7 +68,7 @@ Disable all the plugins which are installed by the nagios-plugin-* packages.
else
{ $as_echo "$as_me:$LINENO: WARNING: Get snmpget from http://net-snmp.sourceforge.net to make check_hpjd and check_snmp plugins" >&5
$as_echo "$as_me: WARNING: Get snmpget from http://net-snmp.sourceforge.net to make check_hpjd and check_snmp plugins" >&2;}
@@ -22982,7 +22985,7 @@ _ACEOF
@@ -23209,7 +23212,7 @@ _ACEOF
fi
@ -77,7 +77,7 @@ Disable all the plugins which are installed by the nagios-plugin-* packages.
then
{ $as_echo "$as_me:$LINENO: checking for Net::SNMP perl module" >&5
$as_echo_n "checking for Net::SNMP perl module... " >&6; }
@@ -23134,7 +23137,7 @@ IFS=$as_save_IFS
@@ -23361,7 +23364,7 @@ IFS=$as_save_IFS
esac
fi
PATH_TO_FPING=$ac_cv_path_PATH_TO_FPING
@ -86,7 +86,7 @@ Disable all the plugins which are installed by the nagios-plugin-* packages.
{ $as_echo "$as_me:$LINENO: result: $PATH_TO_FPING" >&5
$as_echo "$PATH_TO_FPING" >&6; }
else
@@ -23174,7 +23177,7 @@ IFS=$as_save_IFS
@@ -23401,7 +23404,7 @@ IFS=$as_save_IFS
esac
fi
PATH_TO_FPING6=$ac_cv_path_PATH_TO_FPING6
@ -95,7 +95,7 @@ Disable all the plugins which are installed by the nagios-plugin-* packages.
{ $as_echo "$as_me:$LINENO: result: $PATH_TO_FPING6" >&5
$as_echo "$PATH_TO_FPING6" >&6; }
else
@@ -23750,6 +23753,10 @@ cat confdefs.h >>conftest.$ac_ext
@@ -24034,6 +24037,10 @@ cat confdefs.h >>conftest.$ac_ext
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
@ -106,7 +106,7 @@ Disable all the plugins which are installed by the nagios-plugin-* packages.
#ifdef HAVE_SYS_PARAM_H
#include <sys/param.h>
#endif
@@ -23812,6 +23819,10 @@ cat confdefs.h >>conftest.$ac_ext
@@ -24096,6 +24103,10 @@ cat confdefs.h >>conftest.$ac_ext
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
@ -117,7 +117,7 @@ Disable all the plugins which are installed by the nagios-plugin-* packages.
#include <unistd.h>
#include <sys/types.h>
#include <sys/param.h>
@@ -24003,6 +24014,10 @@ cat confdefs.h >>conftest.$ac_ext
@@ -24213,6 +24224,10 @@ cat confdefs.h >>conftest.$ac_ext
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */

View file

@ -1,4 +1,5 @@
$NetBSD: patch-plugins-root_Makefile.in,v 1.1 2016/02/09 10:13:17 bouyer Exp $
$NetBSD: patch-plugins-root_Makefile.in,v 1.2 2017/07/04 19:45:18 jperkin Exp $
user-destdir install fixes.
--- plugins-root/Makefile.in.orig 2016-02-08 13:26:51.000000000 +0100

View file

@ -0,0 +1,15 @@
$NetBSD: patch-plugins-scripts_check__breeze.pl,v 1.1 2017/07/04 19:45:18 jperkin Exp $
Fix path to snmpget.
--- plugins-scripts/check_breeze.pl.orig 2017-01-16 17:24:03.000000000 +0000
+++ plugins-scripts/check_breeze.pl
@@ -49,7 +49,7 @@ my $critical = $1 if ($opt_c =~ /([0-9]{
($opt_C) || ($opt_C = "public") ;
my $sig=0;
-$sig = `/usr/bin/snmpget $host $opt_C .1.3.6.1.4.1.710.3.2.3.1.3.0`;
+$sig = `$utils::PATH_TO_SNMPGET -c $opt_C $host .1.3.6.1.4.1.710.3.2.3.1.3.0`;
my @test=split(/ /,$sig);
$sig=$test[2];
$sig=int($sig);

View file

@ -0,0 +1,84 @@
$NetBSD: patch-plugins-scripts_check__wave.pl,v 1.1 2017/07/04 19:45:18 jperkin Exp $
Fix path to snmpget.
--- plugins-scripts/check_wave.pl.orig 2017-01-16 17:24:03.000000000 +0000
+++ plugins-scripts/check_wave.pl
@@ -9,7 +9,7 @@ use lib '@libexecdir@';
use utils qw($TIMEOUT %ERRORS &print_revision &support);
use vars qw($PROGNAME);
use Getopt::Long;
-use vars qw($opt_V $opt_h $verbose $opt_w $opt_c $opt_H);
+use vars qw($opt_V $opt_h $verbose $opt_w $opt_c $opt_H $opt_C);
my (@test, $low1, $med1, $high1, $snr, $low2, $med2, $high2);
my ($low, $med, $high, $lowavg, $medavg, $highavg, $tot, $ss);
@@ -28,7 +28,8 @@ GetOptions
"v" => \$verbose, "verbose" => \$verbose,
"w=s" => \$opt_w, "warning=s" => \$opt_w,
"c=s" => \$opt_c, "critical=s" => \$opt_c,
- "H=s" => \$opt_H, "hostname=s" => \$opt_H);
+ "H=s" => \$opt_H, "hostname=s" => \$opt_H,
+ "C=s" => \$opt_C, "community=s" => \$opt_C);
if ($opt_V) {
print_revision($PROGNAME,'@NP_VERSION@'); #'
@@ -41,6 +42,7 @@ if ($opt_h) {
}
$opt_H = shift unless ($opt_H);
+$opt_C = "public" unless ($opt_C);
print_usage() unless ($opt_H);
my $host = $1 if ($opt_H =~ m/^([0-9]+\.[0-9]+\.[0-9]+\.[0-9]+|[a-zA-Z][-a-zA-Z0]+(\.[a-zA-Z][-a-zA-Z0]+)*)$/);
print_usage() unless ($host);
@@ -51,34 +53,34 @@ my $critical = $1 if ($opt_c =~ /([0-9]+
($opt_w) || ($opt_w = shift) || ($opt_w = 60);
my $warning = $1 if ($opt_w =~ /([0-9]+)/);
-$low1 = `snmpget $host public .1.3.6.1.4.1.74.2.21.1.2.1.8.1`;
+$low1 = `$utils::PATH_TO_SNMPGET -c $opt_C $host .1.3.6.1.4.1.74.2.21.1.2.1.8.1`;
@test = split(/ /,$low1);
$low1 = $test[2];
-$med1 = `snmpget $host public .1.3.6.1.4.1.74.2.21.1.2.1.9.1`;
+$med1 = `$utils::PATH_TO_SNMPGET -c $opt_C $host .1.3.6.1.4.1.74.2.21.1.2.1.9.1`;
@test = split(/ /,$med1);
$med1 = $test[2];
-$high1 = `snmpget $host public .1.3.6.1.4.1.74.2.21.1.2.1.10.1`;
+$high1 = `$utils::PATH_TO_SNMPGET -c $opt_C $host .1.3.6.1.4.1.74.2.21.1.2.1.10.1`;
@test = split(/ /,$high1);
$high1 = $test[2];
sleep(2);
-$snr = `snmpget $host public .1.3.6.1.4.1.762.2.5.2.1.17.1`;
+$snr = `$utils::PATH_TO_SNMPGET -c $opt_C $host .1.3.6.1.4.1.762.2.5.2.1.17.1`;
@test = split(/ /,$snr);
$snr = $test[2];
$snr = int($snr*25);
-$low2 = `snmpget $host public .1.3.6.1.4.1.74.2.21.1.2.1.8.1`;
+$low2 = `$utils::PATH_TO_SNMPGET -c $opt_C $host .1.3.6.1.4.1.74.2.21.1.2.1.8.1`;
@test = split(/ /,$low2);
$low2 = $test[2];
-$med2 = `snmpget $host public .1.3.6.1.4.1.74.2.21.1.2.1.9.1`;
+$med2 = `$utils::PATH_TO_SNMPGET -c $opt_C $host .1.3.6.1.4.1.74.2.21.1.2.1.9.1`;
@test = split(/ /,$med2);
$med2 = $test[2];
-$high2 = `snmpget $host public .1.3.6.1.4.1.74.2.21.1.2.1.10.1`;
+$high2 = `$utils::PATH_TO_SNMPGET -c $opt_C $host .1.3.6.1.4.1.74.2.21.1.2.1.10.1`;
@test = split(/ /,$high2);
$high2 = $test[2];
@@ -109,7 +111,7 @@ if ($ss<$critical) {
sub print_usage () {
- print "Usage: $PROGNAME -H <host> [-w <warn>] [-c <crit>]\n";
+ print "Usage: $PROGNAME -H <host> [-C <community>] [-w <warn>] [-c <crit>]\n";
}
sub print_help () {

View file

@ -1,6 +1,7 @@
$NetBSD: patch-plugins__check_swap.c,v 1.2 2015/04/03 17:50:27 rodent Exp $
$NetBSD: patch-plugins__check_swap.c,v 1.3 2017/07/04 19:45:18 jperkin Exp $
Disable large file support when building 32bit on SunOS.
--- plugins/check_swap.c.orig 2014-04-15 22:19:03.000000000 +0000
+++ plugins/check_swap.c
@@ -35,6 +35,10 @@ const char *email = "devel@nagios-plugin

View file

@ -0,0 +1,15 @@
$NetBSD: patch-plugins_check__radius.c,v 1.1 2017/07/04 19:45:18 jperkin Exp $
Support radius config.
--- plugins/check_radius.c.orig 2017-01-16 17:24:03.000000000 +0000
+++ plugins/check_radius.c
@@ -86,7 +86,7 @@ char *password = NULL;
char *nasid = NULL;
char *nasipaddress = NULL;
char *expect = NULL;
-char *config_file = NULL;
+char *config_file = "@SYSCONFDIR@/radiusclient-ng/radiusclient.conf";
unsigned short port = PW_AUTH_UDP_PORT;
int retries = 1;
int verbose = FALSE;