Update to 1.0.29

No user visible changes - basically, half a patch we had is now in the
upstream sources (no more statical initializers using stderr).
This commit is contained in:
is 2011-11-23 16:25:07 +00:00
parent 32c9f50c1b
commit 8f0ceb526c
5 changed files with 46 additions and 63 deletions

View file

@ -1,9 +1,10 @@
# $NetBSD: Makefile,v 1.20 2011/11/22 09:44:18 is Exp $
# $NetBSD: Makefile,v 1.21 2011/11/23 16:25:07 is Exp $
#
DISTNAME= icsi-finger-1.0.28
DISTNAME= icsi-finger-1.0.29
CATEGORIES= net
MASTER_SITES= ftp://ftp.icsi.berkeley.edu/pub/ai/stolcke/software/
MASTER_SITES+= http://ftp.sunet.se/pub/nir/finger/icsi-finger/
EXTRACT_SUFX= .tar.Z
MAINTAINER= is@NetBSD.org

View file

@ -1,15 +1,14 @@
$NetBSD: distinfo,v 1.15 2011/11/22 15:10:15 is Exp $
$NetBSD: distinfo,v 1.16 2011/11/23 16:25:07 is Exp $
SHA1 (icsi-finger-1.0.28.tar.Z) = b9708e1d4c6ec645ffcbb17ddabb96b400b53d92
RMD160 (icsi-finger-1.0.28.tar.Z) = c7f4e745f85e7e9a5320b625288b595c3a093391
Size (icsi-finger-1.0.28.tar.Z) = 312479 bytes
SHA1 (patch-aa) = 33d58b9375358e030e03e95ca504d8f6787134cd
SHA1 (icsi-finger-1.0.29.tar.Z) = 7c61ce8c847ff6e40ecc3de909c3db1a4b996d04
RMD160 (icsi-finger-1.0.29.tar.Z) = 5047e636538ae66cf0ba3e170dc3a3edb31f317a
Size (icsi-finger-1.0.29.tar.Z) = 302729 bytes
SHA1 (patch-aa) = d68de6daa5a9ebaeb57cd5afd723f502a72d7dc5
SHA1 (patch-ab) = d8a719d78288aad8ab3a7159f332afdd59231ebb
SHA1 (patch-ac) = e3759d714eafae1cc6a8e974d8a79f065f7efe24
SHA1 (patch-ad) = de1489cf9860bd412a43a875a43eae69dd559606
SHA1 (patch-ae) = 7613ee307bb047d5e5c794b829dcd1cb1c8edb81
SHA1 (patch-af) = 96d691992eecbf08118a924218570325a52603b1
SHA1 (patch-ah) = d61e893ce11a3957bbe138abc9a247b0d4b51a0e
SHA1 (patch-ah) = 9e3b5dc141395d36140f4b1166bad7429f3a0977
SHA1 (patch-ai) = 01b48ecef2c1fe191780c9a8dee61f2951ee9c10
SHA1 (patch-aj) = 53adee387e703fcff2b8f5dba4ae593712acb2ad
SHA1 (patch-ak) = 0f60d2813cda99a040bc3637ebe86d99297e40ba

View file

@ -1,25 +1,7 @@
$NetBSD: patch-aa,v 1.5 2008/12/15 15:37:56 is Exp $
$NetBSD: patch-aa,v 1.6 2011/11/23 16:25:07 is Exp $
--- lib/error.c.orig 1998-04-04 22:38:04.000000000 +0000
+++ lib/error.c
@@ -44,7 +44,7 @@ char *progname = NULL;
jmp_buf top_level;
-static FILE *errlog = stderr;
+static FILE *errlog = NULL;
/* **************************************************************** */
/* */
@@ -93,6 +93,8 @@ handle_error (severity, format, arg1, ar
int severity;
char *format, *arg1, *arg2, *arg3;
{
+ if (errlog == NULL)
+ errlog = stderr;
#ifdef USE_SYSLOG
if (errlog == LOG_SYS)
{
@@ -143,13 +145,16 @@ file_error (severity, filename)
int severity;
char *filename;

View file

@ -1,21 +0,0 @@
$NetBSD: patch-af,v 1.1 2006/06/08 14:29:26 joerg Exp $
--- src/fingerd.c.orig 2006-06-08 14:23:22.000000000 +0000
+++ src/fingerd.c
@@ -116,7 +116,7 @@ int debugging = 0;
int poll_debugging = 0;
/* The output stream for debugging. */
-FILE *debug_output = stderr;
+FILE *debug_output;
/* The hostdata file descriptor */
int host_file = -1;
@@ -158,6 +158,7 @@ main (argc, argv)
allow_time_outs = 1;
connect_timeout = DEFAULT_CONNECT_TIMEOUT;
read_timeout = DEFAULT_POLL_TIMEOUT;
+ debug_output = stderr;
/* Parse arguments. */
for (arg_index = 1; arg_index != argc; arg_index++)

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ah,v 1.2 2011/02/11 17:16:03 is Exp $
$NetBSD: patch-ah,v 1.3 2011/11/23 16:25:08 is Exp $
--- config.h.orig 1997-10-27 20:44:06.000000000 +0100
--- config.h.orig 2000-12-05 04:13:42.000000000 +0000
+++ config.h
@@ -12,38 +12,35 @@
@@ -12,52 +12,53 @@
*
*/
@ -13,28 +13,40 @@ $NetBSD: patch-ah,v 1.2 2011/02/11 17:16:03 is Exp $
-#undef X11Dir /* use own X11R6 on old SunOS */
-#endif
-
#if defined(__linux__)
#undef __WCHAR_TYPE__
#define __WCHAR_TYPE__ unsigned long
+#endif
#undef FingerDir
#define FingerDir /var/spool/fingerdir/
-#undef X11Dir
-#define X11Dir /usr/X11R6
+#undef MugShotPath
+#define MugShotPath "/usr/pkg/images/finger"
#undef InstallCmd
#define InstallCmd /usr/bin/install -c
-#endif
-#ifndef X11Dir
-#ifndef sgi
-#define X11Dir /usr/local/X11R6
-#endif
-#endif
-
+#undef BinDir
+#define BinDir /usr/pkg/bin
-#ifdef bsdi
-#undef X11Dir
-#define X11Dir /usr/X11
#undef FingerDir
-#undef FingerDir
-#define FingerDir /var/spool/fingerdir
-#endif
+#define FingerDir /var/spool/fingerdir
+
+#undef MugShotPath
+#define MugShotPath "/usr/pkg/images/finger"
+
+#undef BinDir
+#define BinDir /usr/pkg/bin
+
+#undef EtcDir
+#define EtcDir /usr/pkg/sbin
+
-#ifdef ultrix
-/*
@ -49,7 +61,7 @@ $NetBSD: patch-ah,v 1.2 2011/02/11 17:16:03 is Exp $
-#define Man5Ext l
-#define Man8Ext l
-#endif /* ultrix */
-
-/* #define USE_DBMALLOC */
+#define ManExt 1
+#define Man5Ext 5
@ -66,3 +78,13 @@ $NetBSD: patch-ah,v 1.2 2011/02/11 17:16:03 is Exp $
+
+#undef MAILDIR
+#define MAILDIR "/var/mail"
+#define ManDir /usr/pkg/man
+#define TARGETDIR "/usr/pkg/etc/fingerdir/targets"
+#define TargetDir /usr/pkg/etc/fingerdir/targets
+#define TTYLOCFILE "/usr/pkg/etc/fingerdir/ttylocs"
+#define HOSTCONFIGFILE "/usr/pkg/etc/fingerdir/hostconfig"
+#define ManDir /usr/pkg/man
+#define TARGETDIR "/usr/pkg/etc/fingerdir/targets"
+#define TargetDir /usr/pkg/etc/fingerdir/targets
+#define TTYLOCFILE "/usr/pkg/etc/fingerdir/ttylocs"
+#define HOSTCONFIGFILE "/usr/pkg/etc/fingerdir/hostconfig"