rman: Honor CPPFLAGS and LDFLAGS. Bump.

- CPPFLAGS/LDFLAGS patch for rman Makefile added
- HOMEPAGE in package Makefile updated
- LICENSE added to package Makefile (Artistic 1.0)
- DESCR updated (program is now called PolyglotMan)
This commit is contained in:
micha 2019-10-16 16:30:17 +00:00
parent 4293880f04
commit 8f1e4dd372
5 changed files with 26 additions and 8 deletions

View file

@ -1,4 +1,4 @@
RosettaMan takes man pages from most of the popular flavours of unix and
transforms them into any of a number of source formats. It can produce
ASCII-only, section headers-only, TkMan, [tn]roff, Ensemble, SGML, HTML,
LaTeX, LaTeX 2e, RTF, and Perl 5 POD.
PolyglotMan parses formatted man pages and man page source from most flavors
of UNIX. It converts to HTML, ASCII, TkMan, DocBook, and other formats.
This program was formerly called RosettaMan.

View file

@ -1,12 +1,14 @@
# $NetBSD: Makefile,v 1.30 2012/10/25 06:56:54 asau Exp $
# $NetBSD: Makefile,v 1.31 2019/10/16 16:30:17 micha Exp $
DISTNAME= rman-3.2
PKGREVISION= 1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=polyglotman/}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://polyglotman.sourceforge.net/
HOMEPAGE= https://sourceforge.net/projects/polyglotman/
COMMENT= Produces HTML from formatted and unformatted man pages
LICENSE= artistic
INSTALLATION_DIRS= bin ${PKGMANDIR}/man1

View file

@ -1,3 +1,3 @@
@comment $NetBSD: PLIST,v 1.1 2001/10/31 22:58:30 zuntum Exp $
@comment $NetBSD: PLIST,v 1.2 2019/10/16 16:30:17 micha Exp $
bin/rman
man/man1/rman.1

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.5 2015/11/04 02:00:07 agc Exp $
$NetBSD: distinfo,v 1.6 2019/10/16 16:30:17 micha Exp $
SHA1 (rman-3.2.tar.gz) = d3b2889b5feabb78a0422a1f5d3ae9fdf0333b79
RMD160 (rman-3.2.tar.gz) = 5ec8830466ec478e4470fbda8635d06b8cf967b7
SHA512 (rman-3.2.tar.gz) = a70aea0af1510088fd88a736e63a6dab9200040be5eb89912ede4f50e3de97d423574841bbb66e90fb12934f3834dac0acefe78ff1c73a78a79c95c3dd6fa5ae
Size (rman-3.2.tar.gz) = 79397 bytes
SHA1 (patch-Makefile) = 37828f90affb7e5b270adfb3c6cfba236ea18db3

View file

@ -0,0 +1,15 @@
$NetBSD: patch-Makefile,v 1.1 2019/10/16 16:30:18 micha Exp $
Honor CPPFLAGS and LDFLAGS.
--- Makefile.orig 2003-07-26 19:15:00.000000000 +0000
+++ Makefile
@@ -102,7 +102,7 @@ all: rman
# everyone but me zaps assertions with the -DNDEBUG flag
rman: rman.c Makefile
- $(CC) -DNDEBUG $(defs) -DPOLYGLOTMANVERSION=\"$(version)\" $(CFLAGS) -o rman rman.c
+ $(CC) -DNDEBUG $(defs) -DPOLYGLOTMANVERSION=\"$(version)\" $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -o rman rman.c
debug: