Initial import of aspell:

Aspell is an Open Source spell checker designed to eventually replace
Ispell. Its main feature is that it does a much better job of coming up
with possible suggestions than Ispell does. In fact recent tests shows
that it even does better than Microsoft Word 97's spell checker in some
cases. In addition it has both compile time and run time support for other
non English languages. Aspell is also a library however the recommend way
to use aspell is through the Pspell library as the actual interface to the
aspell library is constantly changing.
This commit is contained in:
wiz 2002-01-15 01:07:24 +00:00
parent c6a6a226a8
commit 8f693822f2
9 changed files with 334 additions and 0 deletions

8
textproc/aspell/DESCR Normal file
View file

@ -0,0 +1,8 @@
Aspell is an Open Source spell checker designed to eventually replace
Ispell. Its main feature is that it does a much better job of coming up
with possible suggestions than Ispell does. In fact recent tests shows
that it even does better than Microsoft Word 97's spell checker in some
cases. In addition it has both compile time and run time support for other
non English languages. Aspell is also a library however the recommend way
to use aspell is through the Pspell library as the actual interface to the
aspell library is constantly changing.

27
textproc/aspell/Makefile Normal file
View file

@ -0,0 +1,27 @@
# $NetBSD: Makefile,v 1.1.1.1 2002/01/15 01:07:25 wiz Exp $
#
DISTNAME= aspell-.33.7.1
PKGNAME= ${DISTNAME:S/-./-0./}
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=aspell/}
MAINTAINER= wiz@netbsd.org
HOMEPAGE= http://aspell.sourceforge.net/
COMMENT= spell checker with good multi-language support
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
LIBTOOL_OVERRIDE= ${WRKSRC}/libtool
USE_BUILDLINK_ONLY= yes
# halfdelay()
USE_NCURSES= yes
CONFIGURE_ARGS+= --enable-doc-dir=${PREFIX}/share/doc/aspell
CONFIGURE_ARGS+= --enable-curses=ncurses
.include "../../devel/ncurses/buildlink.mk"
.include "../../textproc/libpspell/buildlink.mk"
.include "../../mk/bsd.pkg.mk"

210
textproc/aspell/PLIST Normal file
View file

@ -0,0 +1,210 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2002/01/15 01:07:24 wiz Exp $
bin/aspell
bin/run-with-aspell
bin/word-list-compress
include/aspell/amanager.hh
include/aspell/app_string.hh
include/aspell/as_config.h
include/aspell/asuggest.hh
include/aspell/bad_value.hh
include/aspell/basic_list.hh
include/aspell/block_slist-t.hh
include/aspell/block_slist.hh
include/aspell/block_vector.hh
include/aspell/bskip-t.hh
include/aspell/bskip.hh
include/aspell/check.hh
include/aspell/clone_ptr-t.hh
include/aspell/clone_ptr.hh
include/aspell/config.hh
include/aspell/config_data.hh
include/aspell/const_string.hh
include/aspell/copy_ptr-t.hh
include/aspell/copy_ptr.hh
include/aspell/data.hh
include/aspell/editdist.hh
include/aspell/editdist2.hh
include/aspell/email-t.hh
include/aspell/email.hh
include/aspell/emulation.hh
include/aspell/exception.hh
include/aspell/file_exceps.hh
include/aspell/file_util.hh
include/aspell/filter.hh
include/aspell/generic_copy_ptr-t.hh
include/aspell/generic_copy_ptr.hh
include/aspell/hash-t.hh
include/aspell/hash.hh
include/aspell/hash_const_string.hh
include/aspell/hash_repl-p.hh
include/aspell/hash_repl-t.hh
include/aspell/hash_repl.hh
include/aspell/hash_simple_string.hh
include/aspell/hash_string.hh
include/aspell/hash_string_s.hh
include/aspell/invalid_flag.hh
include/aspell/invalid_word.hh
include/aspell/itr_equal.hh
include/aspell/language.hh
include/aspell/language_exceps.hh
include/aspell/leditdist.hh
include/aspell/manager.hh
include/aspell/map_repl.hh
include/aspell/map_repl_read.hh
include/aspell/matrix.hh
include/aspell/object.hh
include/aspell/phonet.hh
include/aspell/phonetic.hh
include/aspell/primes.hh
include/aspell/refcount.hh
include/aspell/repl-t.hh
include/aspell/repl.hh
include/aspell/repl_func.hh
include/aspell/repl_util.hh
include/aspell/sgml-t.hh
include/aspell/sgml.hh
include/aspell/simple_fstream.hh
include/aspell/simple_string.hh
include/aspell/single_repl.hh
include/aspell/skip-t.hh
include/aspell/skip.hh
include/aspell/split.hh
include/aspell/str_repl.hh
include/aspell/string_buffer.hh
include/aspell/string_map.hh
include/aspell/substr_repl-t.hh
include/aspell/substr_repl.hh
include/aspell/suggest.hh
include/aspell/tex-t.hh
include/aspell/tex.hh
include/aspell/tl_string_map.hh
include/aspell/token.hh
include/aspell/trim_space.hh
include/aspell/try_hard.hh
include/aspell/typo_editdist.hh
include/aspell/urlskip-t.hh
include/aspell/urlskip.hh
include/aspell/utf8-t.hh
include/aspell/utf8.hh
include/aspell/vector_hash-t.hh
include/aspell/vector_hash.hh
include/aspell/weights.hh
lib/aspell/american-med-only
lib/aspell/american-med.multi
lib/aspell/american.multi
lib/aspell/british-med-only
lib/aspell/british-med.multi
lib/aspell/british.multi
lib/aspell/canadian-med-only
lib/aspell/canadian-med.multi
lib/aspell/canadian.multi
lib/aspell/english-med-only
lib/aspell/english-variant-0
lib/aspell/english-variant-1
lib/aspell/english-variant-2
lib/aspell/english.multi
lib/libaspell.a
lib/libaspell.la
lib/libaspell.so
lib/libaspell.so.11
lib/libaspell.so.11.1
lib/libpspell_aspell.a
lib/libpspell_aspell.la
lib/libpspell_aspell.so
lib/libpspell_aspell.so.2
lib/libpspell_aspell.so.2.1
share/aspell/ASCII.dat
share/aspell/ASCII.map
share/aspell/SGML.map
share/aspell/english.dat
share/aspell/english_phonet.dat
share/aspell/iso8859-1.dat
share/aspell/iso8859-1.map
share/aspell/iso8859-10.dat
share/aspell/iso8859-10.map
share/aspell/iso8859-2.dat
share/aspell/iso8859-2.map
share/aspell/iso8859-3.dat
share/aspell/iso8859-3.map
share/aspell/iso8859-4.dat
share/aspell/iso8859-4.map
share/aspell/iso8859-5.dat
share/aspell/iso8859-5.map
share/aspell/iso8859-6.dat
share/aspell/iso8859-6.map
share/aspell/iso8859-7.dat
share/aspell/iso8859-7.map
share/aspell/iso8859-8.dat
share/aspell/iso8859-8.map
share/aspell/iso8859-9.dat
share/aspell/iso8859-9.map
share/aspell/ispell
share/aspell/koi8-f.dat
share/aspell/koi8-r.dat
share/aspell/spell
share/aspell/standard.kbd
share/aspell/unicode.dat
share/aspell/viscii.dat
share/aspell/viscii.map
share/doc/aspell/man-html/1_Introduction.html
share/doc/aspell/man-html/2_Getting.html
share/doc/aspell/man-html/3_Basic.html
share/doc/aspell/man-html/4_Managing.html
share/doc/aspell/man-html/5_Customizing.html
share/doc/aspell/man-html/6_Writing.html
share/doc/aspell/man-html/7_Adding.html
share/doc/aspell/man-html/8_How.html
share/doc/aspell/man-html/A_Changelog.html
share/doc/aspell/man-html/About_this.html
share/doc/aspell/man-html/B_Do.html
share/doc/aspell/man-html/C_Support.html
share/doc/aspell/man-html/Contents.html
share/doc/aspell/man-html/D_Credits.html
share/doc/aspell/man-html/E_Glossary.html
share/doc/aspell/man-html/F_Copyright.html
share/doc/aspell/man-html/contents.png
share/doc/aspell/man-html/crossref.png
share/doc/aspell/man-html/index.html
share/doc/aspell/man-html/manual.css
share/doc/aspell/man-html/manual.html
share/doc/aspell/man-html/next.png
share/doc/aspell/man-html/next_g.png
share/doc/aspell/man-html/prev.png
share/doc/aspell/man-html/prev_g.png
share/doc/aspell/man-html/up.png
share/doc/aspell/man-html/up_g.png
share/doc/aspell/man-text/1_Introduction.txt
share/doc/aspell/man-text/2_Getting.txt
share/doc/aspell/man-text/3_Basic.txt
share/doc/aspell/man-text/4_Managing.txt
share/doc/aspell/man-text/5_Customizing.txt
share/doc/aspell/man-text/6_Writing.txt
share/doc/aspell/man-text/7_Adding.txt
share/doc/aspell/man-text/8_How.txt
share/doc/aspell/man-text/A_Changelog.txt
share/doc/aspell/man-text/About_this.txt
share/doc/aspell/man-text/B_Do.txt
share/doc/aspell/man-text/C_Support.txt
share/doc/aspell/man-text/Contents.txt
share/doc/aspell/man-text/D_Credits.txt
share/doc/aspell/man-text/E_Glossary.txt
share/doc/aspell/man-text/F_Copyright.txt
share/doc/aspell/man-text/index.txt
share/doc/aspell/man-text/manual.txt
share/doc/aspell/manual.aux
share/doc/aspell/manual.dvi
share/doc/aspell/manual.tex
share/doc/aspell/manual2.lyx
share/pspell/en-american-aspell.pwli
share/pspell/en-american-med-aspell.pwli
share/pspell/en-aspell.pwli
share/pspell/en-british-aspell.pwli
share/pspell/en-british-med-aspell.pwli
share/pspell/en-canadian-aspell.pwli
share/pspell/en-canadian-med-aspell.pwli
@dirrm share/doc/aspell/man-text
@dirrm share/doc/aspell/man-html
@dirrm share/doc/aspell
@dirrm share/aspell
@dirrm lib/aspell
@dirrm include/aspell

9
textproc/aspell/distinfo Normal file
View file

@ -0,0 +1,9 @@
$NetBSD: distinfo,v 1.1.1.1 2002/01/15 01:07:25 wiz Exp $
SHA1 (aspell-.33.7.1.tar.gz) = 050f7736b5a162fc717d203905ecee9981666aff
Size (aspell-.33.7.1.tar.gz) = 1647417 bytes
SHA1 (patch-aa) = 5cc046330c13421d7b43c9db6ee64aa87123eafe
SHA1 (patch-ab) = e05452fc4a329165f0dc75bf63bb74e74f5ed545
SHA1 (patch-ac) = 745dd2431829ead23ee5c40b5acc5ebf895265a7
SHA1 (patch-ad) = 07aea7fa9fb6b435ccae5280607dae6b597e474b
SHA1 (patch-ae) = a5656c8b024760452d365bd951fcc58e7cd228d9

View file

@ -0,0 +1,13 @@
$NetBSD: patch-aa,v 1.1.1.1 2002/01/15 01:07:25 wiz Exp $
--- filter/Makefile.in.orig Mon Aug 20 05:44:49 2001
+++ filter/Makefile.in
@@ -90,7 +90,7 @@
pkginclude_HEADERS = *.hh
-INCLUDES = -I../util -I$(includedir)
+INCLUDES = -I../util
libaspell_filter_la_SOURCES = filter.cc map_repl_read.cc single_repl.cc hash_repl.cc repl.cc substr_repl.cc urlskip.cc map_repl.cc sgml.cc email.cc tex.cc

View file

@ -0,0 +1,21 @@
$NetBSD: patch-ab,v 1.1.1.1 2002/01/15 01:07:25 wiz Exp $
--- lib/Makefile.in.orig Mon Aug 20 05:44:55 2001
+++ lib/Makefile.in
@@ -92,14 +92,14 @@
CLEANFILES = dirs.h
-INCLUDES = -I./inc -I../ -I../util -I../filter -I$(includedir)
+INCLUDES = -I./inc -I../ -I../util -I../filter
lib_LTLIBRARIES = libaspell.la
libaspell_la_SOURCES = config.cc language.cc phonetic.cc writable_repl.cc data.cc language_exceps.cc readonly_ws.cc writable_ws.cc manager.cc suggest.cc writable_base.cc token.cc check.cc invalid_word.cc invalid_flag.cc multi_ws.cc file_data_util.cc
-libaspell_la_LIBADD = ../util/libaspell-util.la ../filter/libaspell-filter.la -L$(libdir) -lpspell -lpspell-impl
+libaspell_la_LIBADD = ../util/libaspell-util.la ../filter/libaspell-filter.la -lpspell -lpspell-impl
libaspell_la_LDFLAGS = ${extra_ldflags} -version-info 11:1:1

View file

@ -0,0 +1,20 @@
$NetBSD: patch-ac,v 1.1.1.1 2002/01/15 01:07:25 wiz Exp $
--- pspell-module/Makefile.in.orig Mon Aug 20 05:45:14 2001
+++ pspell-module/Makefile.in
@@ -86,13 +86,13 @@
pkgdatadir = @pkgdatadir@
pkgdocdir = @pkgdocdir@
-INCLUDES = -I../ -I../util -I../lib/inc -I../filter -I$(includedir)
+INCLUDES = -I../ -I../util -I../lib/inc -I../filter
lib_LTLIBRARIES = libpspell_aspell.la
libpspell_aspell_la_SOURCES = manager.cc
-libpspell_aspell_la_LIBADD = -L$(libdir) -lpspell-impl -L../lib/.libs ../lib/libaspell.la
+libpspell_aspell_la_LIBADD = -lpspell-impl -L../lib/.libs ../lib/libaspell.la
libpspell_aspell_la_LDFLAGS = ${extra_ldflags} -module -version-info 2:1:0
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ad,v 1.1.1.1 2002/01/15 01:07:25 wiz Exp $
--- src/Makefile.in.orig Mon Aug 20 05:45:00 2001
+++ src/Makefile.in
@@ -88,7 +88,7 @@
bin_PROGRAMS = aspell word-list-compress
-INCLUDES = -I../ -I../util -I../lib/inc -I../filter $(CURSES_INCLUDE) -I$(includedir)
+INCLUDES = -I../ -I../util -I../lib/inc -I../filter $(CURSES_INCLUDE)
aspell_SOURCES = aspell.cc termios.cc text_chain.cc
aspell_LDADD = ../lib/libaspell.la $(CURSES_LIB)

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ae,v 1.1.1.1 2002/01/15 01:07:25 wiz Exp $
--- util/Makefile.in.orig Mon Aug 20 05:44:46 2001
+++ util/Makefile.in
@@ -86,7 +86,7 @@
pkgdatadir = @pkgdatadir@
pkgdocdir = @pkgdocdir@
-INCLUDES = -I$(includedir)
+INCLUDES =
noinst_LTLIBRARIES = libaspell-util.la