update to 2.3.20

change: a fix including art_misc.h from C++ (which pkgsrc had a patch
for) was included upstream
This commit is contained in:
drochner 2008-02-03 12:17:09 +00:00
parent e6b9b891cb
commit 8faa98f235
3 changed files with 6 additions and 31 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.2 2007/09/23 17:16:38 wiz Exp $
# $NetBSD: Makefile,v 1.3 2008/02/03 12:17:09 drochner Exp $
DISTNAME= libart_lgpl-2.3.19
DISTNAME= libart_lgpl-2.3.20
PKGNAME= ${DISTNAME:S/_lgpl//}
PKGREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/libart_lgpl/2.3/}
EXTRACT_SUFX= .tar.bz2

View file

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.1 2007/09/21 13:00:18 wiz Exp $
$NetBSD: distinfo,v 1.2 2008/02/03 12:17:09 drochner Exp $
SHA1 (libart_lgpl-2.3.19.tar.bz2) = 7f1ff36c91cdc8f14b62acb50836f52a0c735b9e
RMD160 (libart_lgpl-2.3.19.tar.bz2) = 36dca48e3ddcd7e9d11f79e54dd7007cf97ac079
Size (libart_lgpl-2.3.19.tar.bz2) = 302540 bytes
SHA1 (patch-aa) = 2576a37874eaafe933825ebd1ac7fc8d05cb9ee4
SHA1 (libart_lgpl-2.3.20.tar.bz2) = 40aa6c6c5fb27a8a45cd7aaa302a835ff374d13a
RMD160 (libart_lgpl-2.3.20.tar.bz2) = 184cd3dd96e9cfadcba327644bc8c9dd32da26fa
Size (libart_lgpl-2.3.20.tar.bz2) = 302903 bytes

View file

@ -1,23 +0,0 @@
$NetBSD: patch-aa,v 1.1 2007/09/21 13:00:18 wiz Exp $
--- art_misc.h.orig 2007-03-01 18:50:10.000000000 +0100
+++ art_misc.h
@@ -34,10 +34,18 @@
#include <libart_lgpl/art_config.h>
#endif
+#ifdef __cplusplus
+extern "C" {
+#endif /* __cplusplus */
+
void *art_alloc(size_t size);
void art_free(void *ptr);
void *art_realloc(void *ptr, size_t size);
+#ifdef __cplusplus
+}
+#endif /* __cplusplus */
+
/* These aren't, strictly speaking, configuration macros, but they're
damn handy to have around, and may be worth playing with for
debugging. */