Changes 2.3.6:

Bug fixes and Django 1.5 compatibility.
This commit is contained in:
adam 2013-04-08 20:39:16 +00:00
parent 80e15c8ec3
commit 8fae029d1c
3 changed files with 6 additions and 28 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.13 2012/12/09 20:32:37 adam Exp $
# $NetBSD: Makefile,v 1.14 2013/04/08 20:39:16 adam Exp $
DISTNAME= django-cms-2.3.5
DISTNAME= django-cms-2.3.6
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= www python
MASTER_SITES= http://pypi.python.org/packages/source/d/django-cms/

View file

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.9 2013/04/01 12:31:23 joerg Exp $
$NetBSD: distinfo,v 1.10 2013/04/08 20:39:16 adam Exp $
SHA1 (django-cms-2.3.5.tar.gz) = 6f8326cbc024b721d5ae3b95cbecd0cad90163eb
RMD160 (django-cms-2.3.5.tar.gz) = 8a5a38105307c6dee8d8d076bd0b98a597893328
Size (django-cms-2.3.5.tar.gz) = 3696175 bytes
SHA1 (patch-cms_____init____.py) = 52b93489fc15272edc8256e9682de1642baab14c
SHA1 (django-cms-2.3.6.tar.gz) = 1e8f8c0fca91b1d90e1b773eced3f7f768ef1341
RMD160 (django-cms-2.3.6.tar.gz) = 442b8b0bb7ae5e05ec635d4fbe609ee02ee7b923
Size (django-cms-2.3.6.tar.gz) = 3753134 bytes

View file

@ -1,21 +0,0 @@
$NetBSD: patch-cms_____init____.py,v 1.1 2013/04/01 12:31:23 joerg Exp $
--- cms/__init__.py.orig 2013-03-31 16:23:04.000000000 +0000
+++ cms/__init__.py
@@ -1,12 +1,16 @@
# -*- coding: utf-8 -*-
__version__ = '2.3.5'
+import django.core.exceptions
+
# patch settings
try:
from django.conf import settings
if 'cms' in settings.INSTALLED_APPS:
from conf import patch_settings
patch_settings()
+except django.core.exceptions.ImproperlyConfigured:
+ pass
except ImportError: # pragma: no cover
"""
This exception means that either the application is being built, or is