Add DragonFly and try to fix the reliance on zeroness of undefined

symbols. Feature tests should be done with defined() after all.
This commit is contained in:
joerg 2006-02-24 19:25:33 +00:00
parent 47523967be
commit 8fe5b9357d
4 changed files with 171 additions and 1 deletions

View file

@ -1,5 +1,8 @@
$NetBSD: distinfo,v 1.4 2005/02/24 12:14:04 agc Exp $
$NetBSD: distinfo,v 1.5 2006/02/24 19:25:33 joerg Exp $
SHA1 (slurm-0.3.3.tar.gz) = 232a7f28ec3457b2e9d554ed844a45642dea1cc5
RMD160 (slurm-0.3.3.tar.gz) = 6f154e5e6be0ac746dc67e152cf9caf1580c14fe
Size (slurm-0.3.3.tar.gz) = 122839 bytes
SHA1 (patch-aa) = dea71ac2aac554b9429de937b92da094bbfca3f4
SHA1 (patch-ab) = e2729a07db3f907d6a7772299106b5bd5b92a461
SHA1 (patch-ac) = b3312f7f809dd96ab7edfd4f0743f5ec7b6905a6

View file

@ -0,0 +1,69 @@
$NetBSD: patch-aa,v 1.3 2006/02/24 19:25:33 joerg Exp $
--- os.h.orig 2006-02-24 19:13:28.000000000 +0000
+++ os.h
@@ -33,8 +33,8 @@
# endif
#endif
-#if defined (__FreeBSD__) || (__OpenBSD__) || (__NetBSD__) \
- || (__MicroBSD__) || (__APPLE__) || (__DragonFly__)
+#if defined (__FreeBSD__) || defined(__OpenBSD__) || defined(__NetBSD__) \
+ || defined(__MicroBSD__) || defined(__APPLE__) || defined(__DragonFly__)
#define _HAVE_BSD
#define _HAVE_CHECKINTERFACE
#elif __HPUX__
@@ -69,7 +69,7 @@
#include <sys/mib.h>
#include <arpa/inet.h>
#include <net/if.h>
-#elif __FreeBSD__ /* F R E E B S D */
+#elif defined(__FreeBSD__) || defined(__DragonFly__) /* F R E E B S D */
#include <stdio.h>
#include <stdlib.h>
#include <stdarg.h>
@@ -96,7 +96,7 @@
#include <net/ppp_defs.h>
#include <net/if_ppp.h>
#endif
-#elif __NetBSD__ /* N E T B S D */
+#elif defined(__NetBSD__) /* N E T B S D */
#include <stdio.h>
#include <sys/param.h>
#include <sys/sysctl.h>
@@ -123,7 +123,7 @@
#include <net/ppp_defs.h>
#include <net/if_ppp.h>
#include <net/if.h>
-#elif __OpenBSD__ || __MicroBSD__ /* O P E N B S D */
+#elif defined(__OpenBSD__) || defined(__MicroBSD__) /* O P E N B S D */
#include <stdio.h>
#include <sys/param.h>
#include <sys/sysctl.h>
@@ -149,7 +149,7 @@
#include <arpa/inet.h>
#include <net/ppp_defs.h>
#include <net/if_ppp.h>
-#elif __APPLE__ /* Mac OS X */
+#elif defined(__APPLE__) /* Mac OS X */
#include <stdio.h>
#include <stdlib.h>
#include <stdarg.h>
@@ -175,7 +175,7 @@
#include <net/if_media.h>
#include <net/if_mib.h>
#include <arpa/inet.h>
-#elif __linux__ /* L I N U X */
+#elif defined(__linux__) /* L I N U X */
#include <stdio.h>
#include <sys/param.h>
#include <sys/sysctl.h>
@@ -198,7 +198,7 @@
#include <arpa/inet.h>
#include <net/ppp_defs.h>
#include <net/if_ppp.h>
-#elif __Solaris__ /* S O L A R I S */
+#elif defined(__Solaris__) /* S O L A R I S */
#include <stdio.h>
#define NO_CURSES_E 1
#define _WIDEC_H

View file

@ -0,0 +1,37 @@
$NetBSD: patch-ab,v 1.3 2006/02/24 19:25:33 joerg Exp $
--- slurm.c.orig 2006-02-24 19:15:46.000000000 +0000
+++ slurm.c
@@ -50,25 +50,25 @@
#ifdef __HPUX__
#include "src/hpux.h"
#include "src/hpux.c"
-#elif __FreeBSD__
+#elif defined(__FreeBSD__)
#include "src/freebsd.h"
#include "src/freebsd.c"
-#elif __linux__
+#elif defined(__linux__)
#include "src/linux.h"
#include "src/linux.c"
-#elif __OpenBSD__ || __MicroBSD__
+#elif defined(__OpenBSD__) || defined(__MicroBSD__)
#include "src/openbsd.h"
#include "src/openbsd.c"
-#elif __NetBSD__
+#elif defined(__NetBSD__)
#include "src/netbsd.h"
#include "src/netbsd.c"
-#elif __Solaris__
+#elif defined(__Solaris__)
#include "src/solaris.h"
#include "src/solaris.c"
-#elif __APPLE__
+#elif defined(__APPLE__)
#include "src/macos.h"
#include "src/macos.c"
-#elif __DragonFly__
+#elif defined(__DragonFly__)
#include "src/freebsd.h"
#include "src/freebsd.c"
#else

View file

@ -0,0 +1,61 @@
$NetBSD: patch-ac,v 1.3 2006/02/24 19:25:33 joerg Exp $
--- src/if_media.c.orig 2006-02-24 19:16:35.000000000 +0000
+++ src/if_media.c
@@ -10,9 +10,9 @@
*****************************************************************************/
-#if defined (__FreeBSD__) || (__OpenBSD__) || (__NetBSD__) || (__MicroBSD__) || (__APPLE__)
+#if defined (__FreeBSD__) || defined(__OpenBSD__) || defined(__NetBSD__) || defined(__MicroBSD__) || defined(__APPLE__) || defined(__DragonFly__)
# define MEDIA_H_SUPPORTED
#endif
-#if defined (__OpenBSD__) || (__NetBSD__) || (__MicroBSD__) || (__APPLE__)
+#if defined (__OpenBSD__) || defined(__NetBSD__) || defined(__MicroBSD__) || defined(__APPLE__)
# define NON_FreeBSD 1
# define WIRELESS 1
@@ -22,4 +22,6 @@
# define WIRELESS 1
# endif
+# elif defined(__DragonFly__)
+# define WIRELESS 1
# else
# define WIRELESS 0
@@ -119,10 +121,8 @@ int get_if_speed (char *ifstring)
switch (physical)
{
-#ifdef __FreeBSD__
-#if __FreeBSD__ <= 4
+#if (defined(__FreeBSD__) && __FreeBSD__ <= 4)
case IFM_1000_FX:
case IFM_1000_TX:
#endif
-#endif
case IFM_1000_SX:
case IFM_1000_LX:
@@ -147,8 +147,8 @@ int get_if_speed (char *ifstring)
speed = 10 * 1000;
break;
-#if defined(__OpenBSD__) || (__MicroBSD__) || (__NetBSD__) || (__APPLE__)
+#if defined(__OpenBSD__) || defined(__MicroBSD__) || defined(__NetBSD__) || defined(__APPLE__) || defined(__DragonFly__)
case IFM_HPNA_1:
#else
-#if __FreeBSD__ <= 4
+#if (defined(__FreeBSD__) && __FreeBSD__ <= 4)
case IFM_homePNA:
#endif
@@ -196,5 +196,5 @@ int get_if_speed (char *ifstring)
speed = 11 * 1000;
break;
-#if WIRELESS && defined(__FreeBSD__) && (__FreeBSD_version >= 460102)
+#if WIRELESS && ((defined(__FreeBSD__) && (__FreeBSD_version >= 460102)) || defined(__DragonFly__))
case IFM_IEEE80211_DS22:
speed = 22 * 1000;
@@ -203,5 +203,6 @@ int get_if_speed (char *ifstring)
#if WIRELESS && \
(defined(__FreeBSD__) && (__FreeBSD_version >= 500111)) || \
- (defined(__NetBSD__) && (__NetBSD_Version_ > 106020000))
+ (defined(__NetBSD__) && (__NetBSD_Version_ > 106020000)) || \
+ defined(__DragonFly__)
case IFM_IEEE80211_OFDM6:
speed = 6 * 1000;