Add build fix for cases where assert() is not a no-op. See also CPAN bug

#40356 which confirms this.
This commit is contained in:
tonnerre 2008-12-09 07:24:14 +00:00
parent 57b1125a85
commit 8fe81c0066
2 changed files with 15 additions and 1 deletions

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.3 2008/11/17 22:08:17 he Exp $
$NetBSD: distinfo,v 1.4 2008/12/09 07:24:14 tonnerre Exp $
SHA1 (Set-Object-1.26.tar.gz) = 3bbbb2a5889cdfc148b20343e90316a9969005ee
RMD160 (Set-Object-1.26.tar.gz) = 5ee47e73fcba2767d8bd37f81d53eb266669de1c
Size (Set-Object-1.26.tar.gz) = 72924 bytes
SHA1 (patch-aa) = 499aa9c7e91b2761fc415b279c1a95b36fb096b6

View file

@ -0,0 +1,13 @@
$NetBSD: patch-aa,v 1.1 2008/12/09 07:24:14 tonnerre Exp $
--- Object.xs.orig 2008-10-12 23:06:28.000000000 +0200
+++ Object.xs
@@ -342,7 +342,7 @@ _dispel_magic(ISET* s, SV* sv) {
I32 i = AvFILLp(wand);
int c = 0;
- assert( SvTYPE(want) == SVt_PVAV );
+ assert( SvTYPE(wand) == SVt_PVAV );
while (i >= 0) {
if (svp[i] && SvIV(svp[i])) {