qbittorrent: updated to 4.4.3.1
v4.4.3.1 - BUGFIX: Fix broken translations (sledgehammer999) v4.4.3 - BUGFIX: Correctly handle changing of temp save path (glassez) - BUGFIX: Fix storage in SQLite (glassez) - BUGFIX: Correctly apply content layout when "Skip hash check" is enabled (glassez) - BUGFIX: Don't corrupt IDs of v2 torrents (glassez) - BUGFIX: Reduce the number of hashing threads by default (improves hashing speed on HDDs) (summer) - BUGFIX: Prevent the "update dialog" from blocking input on other windows (summer) - BUGFIX: Add trackers in exported .torrent files (glassez) - BUGFIX: Fix wrong GUI behavior in "Optional IP address to bind to" setting (Chocobo1) - WEBUI: Fix WebUI crash due to missing tags from config (An0n) - WEBUI: Show correct location path (Chocobo1) - MACOS: Fix main window freezing after opening a files dialog (glassez) v4.4.2 - FEATURE: Allow to limit max memory working set size (glassez) - BUGFIX: Fix UI crash when torrent is in a non-existent category (Kevin Cox) - BUGFIX: Correctly handle changing of global save paths (glassez) - BUGFIX: Disable performance alert (Chocobo1) - BUGFIX: Prevent loading resume data with inconsistent ID (glassez) - BUGFIX: Properly handle metadata download for an existing torrent (glassez) - BUGFIX: Prevent crash when open torrent destination folder (glassez) - WINDOWS: NSIS: Update Spanish, Spanish International and French translations(Juanjo Jiménez, RqndomHax) v4.4.1 - FEATURE: Restore all torrent settings to the torrent's main context menu (thalieht) - FEATURE: Add confirmation for enabling Auto TMM from context menu (thalieht) - FEATURE: Add tooltip to Automatic Torrent Management context menu action (thalieht) - FEATURE: Add Select All/None buttons in new torrent dialog (thalieht) - BUGFIX: Keep "torrent info" alive while generate .torrent file (glassez) - BUGFIX: Correctly handle Auto TMM in Torrent Files Watcher (glassez) - BUGFIX: Correctly track the root folder name change (glassez) - BUGFIX: Various fixes to the moving torrent code (glassez) - BUGFIX: Update the torrent's download path field when changing category (thalieht) - BUGFIX: Correctly handle received metadata (glassez) - BUGFIX: Store hybrid torrents using legacy filenames (glassez) - BUGFIX: Open correct directory when clicked on Browse button (glassez) - BUGFIX: Fix crash when shutting down and clicing on system tray icon (Chocobo1) - BUGFIX: Fix "Free space on disk" in new torrent dialog (thalieht) - BUGFIX: Optimize completed files handling (Prince Gupta) - BUGFIX: Migrate proxy settings (sledgehammer999) - BUGFIX: Try to recover missing categories (glassez) - WEBUI: WebAPI: fix wrong key used for categories (Chocobo1) - WEBUI: Remove hack for outdated IE 6 browser (Chocobo1) - RSS: Correctly handle XML parsing errors (glassez)
This commit is contained in:
parent
c03f28dd62
commit
8ffb85c787
3 changed files with 16 additions and 16 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.40 2022/04/19 16:37:16 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.41 2022/07/15 10:48:53 adam Exp $
|
||||
|
||||
DISTNAME= qbittorrent-4.4.2
|
||||
DISTNAME= qbittorrent-4.4.3.1
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ${MASTER_SITE_GITHUB:=qbittorrent/}
|
||||
GITHUB_PROJECT= qBittorrent
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.19 2022/04/19 16:37:16 adam Exp $
|
||||
$NetBSD: distinfo,v 1.20 2022/07/15 10:48:53 adam Exp $
|
||||
|
||||
BLAKE2s (qbittorrent-4.4.2.tar.gz) = 64949c1960b9735c6ee95ddef0e82d6d449ea46e5527820e6ea973b7e4c513c9
|
||||
SHA512 (qbittorrent-4.4.2.tar.gz) = 55656fb5fd282a3ed0e703b9b47ec9733a70cf6242cae956a5b2487ef2aeb88a04bf5d37c8fa88554edf95ab0821b76ebebb53e8fc43dc5889f8c730075d6e26
|
||||
Size (qbittorrent-4.4.2.tar.gz) = 9197188 bytes
|
||||
BLAKE2s (qbittorrent-4.4.3.1.tar.gz) = dc1520d5ac078ed7eb33ff933134418a4a80d8a5e0d551d2057f1e499a5d6d37
|
||||
SHA512 (qbittorrent-4.4.3.1.tar.gz) = e3d63c4090e27387f4a5524d0daab26eab70f70ef81ad607e9661e128ccccbf33f2d240cd219bbb1fb138d6e78493ce73055d5128bf888e0ad3949922774efba
|
||||
Size (qbittorrent-4.4.3.1.tar.gz) = 7736308 bytes
|
||||
SHA1 (patch-dist_CMakeLists.txt) = 2c426222aa168c24a2e39a665f3152eca848e4a8
|
||||
SHA1 (patch-src_CMakeLists.txt) = 2359af057f1d4913c2126cbd3564ebf25d1a7879
|
||||
SHA1 (patch-src_app_CMakeLists.txt) = 2f609b9cb173d825f0207e3267e51dce0be9b4fa
|
||||
SHA1 (patch-src_app_CMakeLists.txt) = 6ef5c2fd194607a5f2ab05a60b909e0c2998892c
|
||||
SHA1 (patch-src_base_utils_fs.cpp) = 7a3ba8533682373e7dc202200f98a7f7da88d5c5
|
||||
|
|
|
@ -1,15 +1,15 @@
|
|||
$NetBSD: patch-src_app_CMakeLists.txt,v 1.3 2021/05/04 18:48:03 adam Exp $
|
||||
$NetBSD: patch-src_app_CMakeLists.txt,v 1.4 2022/07/15 10:48:53 adam Exp $
|
||||
|
||||
Disable app bundle on Darwin.
|
||||
|
||||
--- src/app/CMakeLists.txt.orig 2021-05-02 15:59:11.000000000 +0000
|
||||
--- src/app/CMakeLists.txt.orig 2022-05-24 20:10:49.000000000 +0000
|
||||
+++ src/app/CMakeLists.txt
|
||||
@@ -82,7 +82,7 @@ set_source_files_properties(
|
||||
MACOSX_PACKAGE_LOCATION Resources
|
||||
)
|
||||
|
||||
@@ -60,7 +60,7 @@ endif()
|
||||
# Additional platform specific configuration
|
||||
# -----------------------------------------------------------------------------
|
||||
# -----------------------------------------------------------------------------
|
||||
-if (CMAKE_SYSTEM_NAME STREQUAL "Darwin")
|
||||
+if (FALSE)
|
||||
# provide variables for substitution in dist/mac/Info.plist
|
||||
get_target_property(EXECUTABLE_NAME qbt_app OUTPUT_NAME)
|
||||
# This variable name should be changed once qmake is no longer used. Refer to the discussion in PR #14813
|
||||
include(FindQtTranslations)
|
||||
qbt_get_qt_translations(QT_TRANSLATIONS)
|
||||
set_source_files_properties(${QT_TRANSLATIONS} PROPERTIES MACOSX_PACKAGE_LOCATION translations)
|
||||
|
|
Loading…
Reference in a new issue