Update to 0.16:

0.16
Features
    Enhancements to Cython's function type (support for weak
    references, default arguments, code objects, dynamic attributes,
    classmethods, staticmethods, and more)
    Fused Types - Template-like support for functions and methods
    CEP 522 (docs)
    Typed views on memory - Support for efficient direct and indirect
    buffers (indexing, slicing, transposing, ...) CEP 517 (docs)
    super() without arguments
    Final cdef methods (which translate into direct calls on known
    instances)
General Improvements and Bug Fixes
    support default arguments for closures
    search sys.path for pxd files
    support C++ template casting
    faster traceback building and faster generator termination
    support inplace operators on indexed buffers
    fix alignment handling for record types in buffer support
    allow nested prange sections

0.15.1
This is a bugfix-only release.

0.15
Major Features
    Generators (yield) - Cython has full support for generators,
    generator expressions and PEP 342 coroutines.
    The nonlocal keyword is supported.
    Re-acquiring the gil: with gil - works as expected within a
    nogil context.
    OpenMP support: prange.
    Control flow analysis prunes dead code and emits warnings and
    errors about uninitialised variables.
    Debugger command cy set to assign values of expressions to
    Cython variables and cy exec counterpart $cy_eval().
    Exception chaining PEP 3134.
    Relative imports PEP 328.
    Improved pure syntax including cython.cclass, cython.cfunc,
    and cython.ccall.
    The with statement has its own dedicated and faster C
    implementation.
    Support for del.
    Boundschecking directives implemented for builtin Python sequence
    types.
    Several updates and additions to the shipped standard library
    .pxd files.
    Forward declaration of types is no longer required for circular
    references.
Note: this will be the last release to support Python 2.3; Python
2.4 will be supported for at least one more release.
General improvements and bug fixes
This release contains over a thousand commits including hundreds
of bugfixes and optimizations. The bug tracker has not been as
heavily used this release cycle, but is still an interesting subset
of improvements and fixes
Incompatible changes
    Uninitialized variables are no longer initialized to None and
    accessing them has the same semantics as standard Python.
    globals() now returns a read-only dict of the Cython module's
    globals, rather than the globals
        of the first non-Cython module in the stack
    Many C++ exceptions are now special cased to give closer Python
    counterparts. This means that except+ functions that formerly
    raised generic RuntimeErrors may raise something else such as
    ArithmeticError.
Known regressions
    The inlined generator expressions (introduced in Cython 0.13)
    were disabled in favour of full generator expression support.
    This breaks code that previously used them inside of cdef
    functions (usage in def functions continues to work) and induces
    a performance regression for cases that continue to work but
    that were previously inlined. We hope to reinstate this feature
    in the near future.
    Generators (yield) - Cython has full support for generators,
    generator expressions and PEP 342 coroutines.
    The nonlocal keyword is supported.
    Re-acquiring the gil: with gil - works as expected within a
    nogil context.
    OpenMP support: prange.
    Control flow analysis prunes dead code and emits warnings and
    errors about uninitialised variables.
    Debugger command cy set to assign values of expressions to
    Cython variables and cy exec counterpart $cy_eval().
    Exception chaining PEP 3134.
    Relative imports PEP 328.
    Improved pure syntax including cython.cclass, cython.cfunc,
    and cython.ccall.
    The with statement has its own dedicated and faster C
    implementation.
    Support for del.
    Boundschecking directives implemented for builtin Python sequence
    types.
    Several updates and additions to the shipped standard library
    .pxd files.
    Forward declaration of types is no longer required for circular
    references.
Note: this will be the last release to support Python 2.3; Python
2.4 will be supported for at least one more release.
General improvements and bug fixes
This release contains over a thousand commits including hundreds
of bugfixes and optimizations. The bug tracker has not been as
heavily used this release cycle, but is still an interesting subset
of improvements and fixes
Incompatible changes
    Uninitialized variables are no longer initialized to None and
    accessing them has the same semantics as standard Python.
    globals() now returns a read-only dict of the Cython module's
    globals, rather than the globals
	of the first non-Cython module in the stack
    Many C++ exceptions are now special cased to give closer Python
    counterparts. This means that except+ functions that formerly
    raised generic RuntimeErrors may raise something else such as
    ArithmeticError.
Known regressions
    The inlined generator expressions (introduced in Cython 0.13)
    were disabled in favour of full generator expression support.
    This breaks code that previously used them inside of cdef
    functions (usage in def functions continues to work) and induces
    a performance regression for cases that continue to work but
    that were previously inlined. We hope to reinstate this feature
    in the near future.

0.14.1
New Features
    The gdb debugging support was extended to include all major
    Cython features, including closures.
    raise MemoryError() is now safe to use as Cython replaces it
    with the correct C-API call.
General improvements and bug fixes
The bug tracker has a list of the major improvements and fixes
Incompatible changes
    Decorators on special methods of cdef classes now raise a
    compile time error rather than being ignored.
    In Python 3 language level mode (-3 option), the 'str' type is
    now mapped to 'unicode', so that cdef str s declares a Unicode
    string even when running in Python 2.

0.14
New Features
    Python classes can now be nested and receive a proper closure
    at definition time.
    Redefinition is supported for Python functions, even within
    the same scope.
    Lambda expressions are supported in class bodies and at the
    module level.
    Metaclasses are supported for Python classes, both in Python
    2 and Python 3 syntax. The Python 3 syntax (using a keyword
    argument in the type declaration) is preferred and optimised
    at compile time.
    "final" extension classes prevent inheritance in Python space.
    This feature is available through the new "cython.final"
    decorator. In the future, these classes may receive further
    optimisations.
    "internal" extension classes do not show up in the module
    dictionary. This feature is available through the new
    "cython.internal" decorator.
    Extension type inheritance from builtin types, such as "cdef
    class MyUnicode(unicode)", now works without further external
    type redeclarations (which are also strongly discouraged now
    and continue to issue a warning).
    GDB support. http://docs.cython.org/src/userguide/debugging.html
    A new build system with support for inline distutils directives,
    correct dependency tracking, and parallel compilation.
    http://wiki.cython.org/enhancements/distutils_preprocessing
    Support for dynamic compilation at runtime via the new
    cython.inline function and cython.compile decorator.
    http://wiki.cython.org/enhancements/inline
General improvements and bug fixes
    In parallel assignments, the right side was evaluated in reverse
    order in 0.13. This could result in errors if it had side
    effects (e.g. function calls).
    In some cases, methods of builtin types would raise a SystemError
    instead of an AttributeError when called on None.
    Constant tuples are now cached over the lifetime of an extension
    module, just like CPython does. Constant argument tuples of
    Python function calls are also cached.
    Closures have tightened to include exactly the names used in
    the inner functions and classes. Previously, they held the
    complete locals of the defining function.
    "nogil" blocks are supported when compiling pure Python code
    by writing "with cython.nogil".
    The builtin "next()" function in Python 2.6 and later is now
    implemented internally and therefore available in all Python
    versions. This makes it the preferred and portable way of
    manually advancing an iterator.
    In addition to the previously supported inlined generator
    expressions in 0.13, "sorted(genexpr)" can now be used as well.
    Typing issues were fixed in "sum(genexpr)" that could lead to
    invalid C code being generated. Other known issues with inlined
    generator expressions were also fixed that make upgrading to
    0.14 a strong recommendation for code that uses them. Note that
    general generators and generator expressions continue to be
    not supported.
    Iterating over arbitrary pointer types is now supported, as is
    an optimized version of the in operator, e.g. x in ptr[a:b].
    Inplace arithmetic operators now respect the cdivision directive
    and are supported for complex types.
Incompatible changes
    Typing a variable as type "complex" previously gave it the
    Python object type. It now uses the appropriate C/C++ double
    complex type. A side-effect is that assignments and typed
    function parameters now accept anything that Python can coerce
    to a complex, including integers and floats, and not only
    complex instances.
    Large integer literals pass through the compiler in a safer
    way. To prevent truncation in C code, non 32-bit literals are
    turned into Python objects if not used in a C context. This
    context can either be given by a clear C literal suffix such
    as "UL" or "LL" (or "L" in Python 3 code), or it can be an
    assignment to a typed variable or a typed function argument,
    in which case it is up to the user to take care of a sufficiently
    large value space of the target.
    Python functions are declared in the order they appear in the
    file, rather than all being created at module creation time.
    This is consistent with Python and needed to support, for
    example, conditional or repeated declarations of functions. In
    the face of circular imports this may cause code to break, so
    a new --disable-function-redefinition flag was added to revert
    to the old behavior. This flag will be removed in a future
    release, so should only be used as a stopgap until old code
    can be fixed.
This commit is contained in:
wiz 2012-08-12 21:08:46 +00:00
parent 1e2cfa3728
commit 90574c4713
7 changed files with 175 additions and 41 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.4 2012/04/08 19:08:52 wiz Exp $
# $NetBSD: Makefile,v 1.5 2012/08/12 21:08:46 wiz Exp $
#
DISTNAME= Cython-0.13
PKGNAME= ${PYPKGPREFIX}-cython-0.13
DISTNAME= Cython-0.16
PKGNAME= ${PYPKGPREFIX}-cython-0.16
CATEGORIES= lang python
MASTER_SITES= http://cython.org/release/
@ -20,6 +20,7 @@ PLIST_SUBST+= PYVERSSUFFIX=${PYVERSSUFFIX}
post-extract:
cd ${WRKSRC}/bin && ${MV} cython cython${PYVERSSUFFIX}
cd ${WRKSRC}/bin && ${MV} cygdb cygdb${PYVERSSUFFIX}
# for test only
#USE_LANGUAGES+= c++

View file

@ -1,5 +1,27 @@
@comment $NetBSD: PLIST,v 1.2 2010/11/24 17:58:22 drochner Exp $
@comment $NetBSD: PLIST,v 1.3 2012/08/12 21:08:46 wiz Exp $
bin/cygdb${PYVERSSUFFIX}
bin/cython${PYVERSSUFFIX}
${PYSITELIB}/Cython/Build/BuildExecutable.py
${PYSITELIB}/Cython/Build/BuildExecutable.pyc
${PYSITELIB}/Cython/Build/BuildExecutable.pyo
${PYSITELIB}/Cython/Build/Dependencies.py
${PYSITELIB}/Cython/Build/Dependencies.pyc
${PYSITELIB}/Cython/Build/Dependencies.pyo
${PYSITELIB}/Cython/Build/Inline.py
${PYSITELIB}/Cython/Build/Inline.pyc
${PYSITELIB}/Cython/Build/Inline.pyo
${PYSITELIB}/Cython/Build/Tests/TestInline.py
${PYSITELIB}/Cython/Build/Tests/TestInline.pyc
${PYSITELIB}/Cython/Build/Tests/TestInline.pyo
${PYSITELIB}/Cython/Build/Tests/TestStripLiterals.py
${PYSITELIB}/Cython/Build/Tests/TestStripLiterals.pyc
${PYSITELIB}/Cython/Build/Tests/TestStripLiterals.pyo
${PYSITELIB}/Cython/Build/Tests/__init__.py
${PYSITELIB}/Cython/Build/Tests/__init__.pyc
${PYSITELIB}/Cython/Build/Tests/__init__.pyo
${PYSITELIB}/Cython/Build/__init__.py
${PYSITELIB}/Cython/Build/__init__.pyc
${PYSITELIB}/Cython/Build/__init__.pyo
${PYSITELIB}/Cython/CodeWriter.py
${PYSITELIB}/Cython/CodeWriter.pyc
${PYSITELIB}/Cython/CodeWriter.pyo
@ -21,15 +43,14 @@ ${PYSITELIB}/Cython/Compiler/Builtin.pyo
${PYSITELIB}/Cython/Compiler/CmdLine.py
${PYSITELIB}/Cython/Compiler/CmdLine.pyc
${PYSITELIB}/Cython/Compiler/CmdLine.pyo
${PYSITELIB}/Cython/Compiler/Code.pxd
${PYSITELIB}/Cython/Compiler/Code.py
${PYSITELIB}/Cython/Compiler/Code.pyc
${PYSITELIB}/Cython/Compiler/Code.pyo
${PYSITELIB}/Cython/Compiler/Code.so
${PYSITELIB}/Cython/Compiler/CodeGeneration.py
${PYSITELIB}/Cython/Compiler/CodeGeneration.pyc
${PYSITELIB}/Cython/Compiler/CodeGeneration.pyo
${PYSITELIB}/Cython/Compiler/ControlFlow.py
${PYSITELIB}/Cython/Compiler/ControlFlow.pyc
${PYSITELIB}/Cython/Compiler/ControlFlow.pyo
${PYSITELIB}/Cython/Compiler/CythonScope.py
${PYSITELIB}/Cython/Compiler/CythonScope.pyc
${PYSITELIB}/Cython/Compiler/CythonScope.pyo
@ -42,6 +63,11 @@ ${PYSITELIB}/Cython/Compiler/Errors.pyo
${PYSITELIB}/Cython/Compiler/ExprNodes.py
${PYSITELIB}/Cython/Compiler/ExprNodes.pyc
${PYSITELIB}/Cython/Compiler/ExprNodes.pyo
${PYSITELIB}/Cython/Compiler/FlowControl.pxd
${PYSITELIB}/Cython/Compiler/FlowControl.py
${PYSITELIB}/Cython/Compiler/FlowControl.pyc
${PYSITELIB}/Cython/Compiler/FlowControl.pyo
${PYSITELIB}/Cython/Compiler/FlowControl.so
${PYSITELIB}/Cython/Compiler/Future.py
${PYSITELIB}/Cython/Compiler/Future.pyc
${PYSITELIB}/Cython/Compiler/Future.pyo
@ -51,9 +77,13 @@ ${PYSITELIB}/Cython/Compiler/Interpreter.pyo
${PYSITELIB}/Cython/Compiler/Lexicon.py
${PYSITELIB}/Cython/Compiler/Lexicon.pyc
${PYSITELIB}/Cython/Compiler/Lexicon.pyo
${PYSITELIB}/Cython/Compiler/Lexicon.so
${PYSITELIB}/Cython/Compiler/Main.py
${PYSITELIB}/Cython/Compiler/Main.pyc
${PYSITELIB}/Cython/Compiler/Main.pyo
${PYSITELIB}/Cython/Compiler/MemoryView.py
${PYSITELIB}/Cython/Compiler/MemoryView.pyc
${PYSITELIB}/Cython/Compiler/MemoryView.pyo
${PYSITELIB}/Cython/Compiler/ModuleNode.py
${PYSITELIB}/Cython/Compiler/ModuleNode.pyc
${PYSITELIB}/Cython/Compiler/ModuleNode.pyo
@ -69,6 +99,7 @@ ${PYSITELIB}/Cython/Compiler/Optimize.pyo
${PYSITELIB}/Cython/Compiler/Options.py
${PYSITELIB}/Cython/Compiler/Options.pyc
${PYSITELIB}/Cython/Compiler/Options.pyo
${PYSITELIB}/Cython/Compiler/ParseTreeTransforms.pxd
${PYSITELIB}/Cython/Compiler/ParseTreeTransforms.py
${PYSITELIB}/Cython/Compiler/ParseTreeTransforms.pyc
${PYSITELIB}/Cython/Compiler/ParseTreeTransforms.pyo
@ -77,6 +108,9 @@ ${PYSITELIB}/Cython/Compiler/Parsing.py
${PYSITELIB}/Cython/Compiler/Parsing.pyc
${PYSITELIB}/Cython/Compiler/Parsing.pyo
${PYSITELIB}/Cython/Compiler/Parsing.so
${PYSITELIB}/Cython/Compiler/Pipeline.py
${PYSITELIB}/Cython/Compiler/Pipeline.pyc
${PYSITELIB}/Cython/Compiler/Pipeline.pyo
${PYSITELIB}/Cython/Compiler/PyrexTypes.py
${PYSITELIB}/Cython/Compiler/PyrexTypes.pyc
${PYSITELIB}/Cython/Compiler/PyrexTypes.pyo
@ -94,9 +128,9 @@ ${PYSITELIB}/Cython/Compiler/Symtab.pyo
${PYSITELIB}/Cython/Compiler/Tests/TestBuffer.py
${PYSITELIB}/Cython/Compiler/Tests/TestBuffer.pyc
${PYSITELIB}/Cython/Compiler/Tests/TestBuffer.pyo
${PYSITELIB}/Cython/Compiler/Tests/TestDecorators.py
${PYSITELIB}/Cython/Compiler/Tests/TestDecorators.pyc
${PYSITELIB}/Cython/Compiler/Tests/TestDecorators.pyo
${PYSITELIB}/Cython/Compiler/Tests/TestMemView.py
${PYSITELIB}/Cython/Compiler/Tests/TestMemView.pyc
${PYSITELIB}/Cython/Compiler/Tests/TestMemView.pyo
${PYSITELIB}/Cython/Compiler/Tests/TestParseTreeTransforms.py
${PYSITELIB}/Cython/Compiler/Tests/TestParseTreeTransforms.pyc
${PYSITELIB}/Cython/Compiler/Tests/TestParseTreeTransforms.pyo
@ -106,6 +140,9 @@ ${PYSITELIB}/Cython/Compiler/Tests/TestTreeFragment.pyo
${PYSITELIB}/Cython/Compiler/Tests/TestTreePath.py
${PYSITELIB}/Cython/Compiler/Tests/TestTreePath.pyc
${PYSITELIB}/Cython/Compiler/Tests/TestTreePath.pyo
${PYSITELIB}/Cython/Compiler/Tests/TestUtilityLoad.py
${PYSITELIB}/Cython/Compiler/Tests/TestUtilityLoad.pyc
${PYSITELIB}/Cython/Compiler/Tests/TestUtilityLoad.pyo
${PYSITELIB}/Cython/Compiler/Tests/__init__.py
${PYSITELIB}/Cython/Compiler/Tests/__init__.pyc
${PYSITELIB}/Cython/Compiler/Tests/__init__.pyo
@ -124,6 +161,9 @@ ${PYSITELIB}/Cython/Compiler/TypeSlots.pyo
${PYSITELIB}/Cython/Compiler/UtilNodes.py
${PYSITELIB}/Cython/Compiler/UtilNodes.pyc
${PYSITELIB}/Cython/Compiler/UtilNodes.pyo
${PYSITELIB}/Cython/Compiler/UtilityCode.py
${PYSITELIB}/Cython/Compiler/UtilityCode.pyc
${PYSITELIB}/Cython/Compiler/UtilityCode.pyo
${PYSITELIB}/Cython/Compiler/Version.py
${PYSITELIB}/Cython/Compiler/Version.pyc
${PYSITELIB}/Cython/Compiler/Version.pyo
@ -135,6 +175,35 @@ ${PYSITELIB}/Cython/Compiler/Visitor.so
${PYSITELIB}/Cython/Compiler/__init__.py
${PYSITELIB}/Cython/Compiler/__init__.pyc
${PYSITELIB}/Cython/Compiler/__init__.pyo
${PYSITELIB}/Cython/Debugger/Cygdb.py
${PYSITELIB}/Cython/Debugger/Cygdb.pyc
${PYSITELIB}/Cython/Debugger/Cygdb.pyo
${PYSITELIB}/Cython/Debugger/DebugWriter.py
${PYSITELIB}/Cython/Debugger/DebugWriter.pyc
${PYSITELIB}/Cython/Debugger/DebugWriter.pyo
${PYSITELIB}/Cython/Debugger/Tests/TestLibCython.py
${PYSITELIB}/Cython/Debugger/Tests/TestLibCython.pyc
${PYSITELIB}/Cython/Debugger/Tests/TestLibCython.pyo
${PYSITELIB}/Cython/Debugger/Tests/__init__.py
${PYSITELIB}/Cython/Debugger/Tests/__init__.pyc
${PYSITELIB}/Cython/Debugger/Tests/__init__.pyo
${PYSITELIB}/Cython/Debugger/Tests/cfuncs.c
${PYSITELIB}/Cython/Debugger/Tests/codefile
${PYSITELIB}/Cython/Debugger/Tests/test_libcython_in_gdb.py
${PYSITELIB}/Cython/Debugger/Tests/test_libcython_in_gdb.pyc
${PYSITELIB}/Cython/Debugger/Tests/test_libcython_in_gdb.pyo
${PYSITELIB}/Cython/Debugger/Tests/test_libpython_in_gdb.py
${PYSITELIB}/Cython/Debugger/Tests/test_libpython_in_gdb.pyc
${PYSITELIB}/Cython/Debugger/Tests/test_libpython_in_gdb.pyo
${PYSITELIB}/Cython/Debugger/__init__.py
${PYSITELIB}/Cython/Debugger/__init__.pyc
${PYSITELIB}/Cython/Debugger/__init__.pyo
${PYSITELIB}/Cython/Debugger/libcython.py
${PYSITELIB}/Cython/Debugger/libcython.pyc
${PYSITELIB}/Cython/Debugger/libcython.pyo
${PYSITELIB}/Cython/Debugger/libpython.py
${PYSITELIB}/Cython/Debugger/libpython.pyc
${PYSITELIB}/Cython/Debugger/libpython.pyo
${PYSITELIB}/Cython/Debugging.py
${PYSITELIB}/Cython/Debugging.pyc
${PYSITELIB}/Cython/Debugging.pyo
@ -208,6 +277,7 @@ ${PYSITELIB}/Cython/Includes/cpython/number.pxd
${PYSITELIB}/Cython/Includes/cpython/object.pxd
${PYSITELIB}/Cython/Includes/cpython/oldbuffer.pxd
${PYSITELIB}/Cython/Includes/cpython/pycapsule.pxd
${PYSITELIB}/Cython/Includes/cpython/pystate.pxd
${PYSITELIB}/Cython/Includes/cpython/pythread.pxd
${PYSITELIB}/Cython/Includes/cpython/ref.pxd
${PYSITELIB}/Cython/Includes/cpython/sequence.pxd
@ -223,6 +293,8 @@ ${PYSITELIB}/Cython/Includes/libc/errno.pxd
${PYSITELIB}/Cython/Includes/libc/float.pxd
${PYSITELIB}/Cython/Includes/libc/limits.pxd
${PYSITELIB}/Cython/Includes/libc/locale.pxd
${PYSITELIB}/Cython/Includes/libc/math.pxd
${PYSITELIB}/Cython/Includes/libc/setjmp.pxd
${PYSITELIB}/Cython/Includes/libc/signal.pxd
${PYSITELIB}/Cython/Includes/libc/stddef.pxd
${PYSITELIB}/Cython/Includes/libc/stdint.pxd
@ -237,14 +309,20 @@ ${PYSITELIB}/Cython/Includes/libcpp/pair.pxd
${PYSITELIB}/Cython/Includes/libcpp/queue.pxd
${PYSITELIB}/Cython/Includes/libcpp/set.pxd
${PYSITELIB}/Cython/Includes/libcpp/stack.pxd
${PYSITELIB}/Cython/Includes/libcpp/string.pxd
${PYSITELIB}/Cython/Includes/libcpp/utility.pxd
${PYSITELIB}/Cython/Includes/libcpp/vector.pxd
${PYSITELIB}/Cython/Includes/numpy.pxd
${PYSITELIB}/Cython/Includes/openmp.pxd
${PYSITELIB}/Cython/Includes/posix/__init__.pxd
${PYSITELIB}/Cython/Includes/posix/fcntl.pxd
${PYSITELIB}/Cython/Includes/posix/ioctl.pxd
${PYSITELIB}/Cython/Includes/posix/unistd.pxd
${PYSITELIB}/Cython/Plex/Actions.pxd
${PYSITELIB}/Cython/Plex/Actions.py
${PYSITELIB}/Cython/Plex/Actions.pyc
${PYSITELIB}/Cython/Plex/Actions.pyo
${PYSITELIB}/Cython/Plex/Actions.so
${PYSITELIB}/Cython/Plex/DFA.py
${PYSITELIB}/Cython/Plex/DFA.pyc
${PYSITELIB}/Cython/Plex/DFA.pyo
@ -288,18 +366,48 @@ ${PYSITELIB}/Cython/Shadow.pyo
${PYSITELIB}/Cython/StringIOTree.py
${PYSITELIB}/Cython/StringIOTree.pyc
${PYSITELIB}/Cython/StringIOTree.pyo
${PYSITELIB}/Cython/Tempita/__init__.py
${PYSITELIB}/Cython/Tempita/__init__.pyc
${PYSITELIB}/Cython/Tempita/__init__.pyo
${PYSITELIB}/Cython/Tempita/_looper.py
${PYSITELIB}/Cython/Tempita/_looper.pyc
${PYSITELIB}/Cython/Tempita/_looper.pyo
${PYSITELIB}/Cython/Tempita/compat3.py
${PYSITELIB}/Cython/Tempita/compat3.pyc
${PYSITELIB}/Cython/Tempita/compat3.pyo
${PYSITELIB}/Cython/TestUtils.py
${PYSITELIB}/Cython/TestUtils.pyc
${PYSITELIB}/Cython/TestUtils.pyo
${PYSITELIB}/Cython/Tests/TestCodeWriter.py
${PYSITELIB}/Cython/Tests/TestCodeWriter.pyc
${PYSITELIB}/Cython/Tests/TestCodeWriter.pyo
${PYSITELIB}/Cython/Tests/TestStringIOTree.py
${PYSITELIB}/Cython/Tests/TestStringIOTree.pyc
${PYSITELIB}/Cython/Tests/TestStringIOTree.pyo
${PYSITELIB}/Cython/Tests/__init__.py
${PYSITELIB}/Cython/Tests/__init__.pyc
${PYSITELIB}/Cython/Tests/__init__.pyo
${PYSITELIB}/Cython/Tests/xmlrunner.py
${PYSITELIB}/Cython/Tests/xmlrunner.pyc
${PYSITELIB}/Cython/Tests/xmlrunner.pyo
${PYSITELIB}/Cython/Utility/Buffer.c
${PYSITELIB}/Cython/Utility/Capsule.c
${PYSITELIB}/Cython/Utility/CythonFunction.c
${PYSITELIB}/Cython/Utility/Exceptions.c
${PYSITELIB}/Cython/Utility/FunctionArguments.c
${PYSITELIB}/Cython/Utility/Generator.c
${PYSITELIB}/Cython/Utility/MemoryView.pyx
${PYSITELIB}/Cython/Utility/MemoryView_C.c
${PYSITELIB}/Cython/Utility/ModuleSetupCode.c
${PYSITELIB}/Cython/Utility/Optimize.c
${PYSITELIB}/Cython/Utility/StringTools.c
${PYSITELIB}/Cython/Utility/TestCyUtilityLoader.pyx
${PYSITELIB}/Cython/Utility/TestCythonScope.pyx
${PYSITELIB}/Cython/Utility/TestUtilityLoader.c
${PYSITELIB}/Cython/Utility/TypeConversion.c
${PYSITELIB}/Cython/Utility/__init__.py
${PYSITELIB}/Cython/Utility/__init__.pyc
${PYSITELIB}/Cython/Utility/__init__.pyo
${PYSITELIB}/Cython/Utils.py
${PYSITELIB}/Cython/Utils.pyc
${PYSITELIB}/Cython/Utils.pyo

View file

@ -1,15 +1,12 @@
# $NetBSD: buildlink3.mk,v 1.1.1.1 2010/07/15 17:41:57 drochner Exp $
# $NetBSD: buildlink3.mk,v 1.2 2012/08/12 21:08:46 wiz Exp $
BUILDLINK_TREE+= pycython
BUILDLINK_TREE+= py-cython
.if !defined(PY_CYTHON_BUILDLINK3_MK)
PY_CYTHON_BUILDLINK3_MK:=
.include "../../lang/python/pyversion.mk"
BUILDLINK_API_DEPENDS.py-cython+= ${PYPKGPREFIX}-cython>=0.12.1
BUILDLINK_PKGSRCDIR.py-cython?= ../../devel/py-cython
.endif # PY_CYTHON_BUILDLINK3_MK
BUILDLINK_API_DEPENDS.pycython+= ${PYPKGPREFIX}-cython>=0.12.1
BUILDLINK_PKGSRCDIR.pycython?= ../../devel/py-cython
.endif # PY_CYTHON_BUILDLINK3_MK
BUILDLINK_TREE+= -pycython
BUILDLINK_TREE+= -py-cython

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.2 2010/11/24 17:58:22 drochner Exp $
$NetBSD: distinfo,v 1.3 2012/08/12 21:08:46 wiz Exp $
SHA1 (Cython-0.13.tar.gz) = 8f17947fa75c03cabe11a8a5a19dc74e27f0d1e2
RMD160 (Cython-0.13.tar.gz) = 4771e9b82371a5923a76badb4123f416b65e773a
Size (Cython-0.13.tar.gz) = 644797 bytes
SHA1 (patch-aa) = d51b7d17a69857ce8a682cc2ae762a30610c4d40
SHA1 (patch-ab) = e61bbbadafbe3f10dbc7dfd70494fb377bb35db3
SHA1 (patch-ac) = 3e966b08564bdb701557a0c47072f87b9ae7bb25
SHA1 (Cython-0.16.tar.gz) = b271c1d4b02c1e73d32ea4b242c92643b6bdd16e
RMD160 (Cython-0.16.tar.gz) = 168ef4138945a867ad19a4f05c924f9ce97008c0
Size (Cython-0.16.tar.gz) = 1240372 bytes
SHA1 (patch-aa) = b66269a12ff43be9b7ea980d5245b5fdbbe41e64
SHA1 (patch-ab) = de923488eb3f08f7e048c35c57bd60cbfb2b4c53
SHA1 (patch-ac) = 1caa956748f9fa221f9ef263d1d695e6565f36d8

View file

@ -1,8 +1,10 @@
$NetBSD: patch-aa,v 1.1.1.1 2010/07/15 17:41:57 drochner Exp $
$NetBSD: patch-aa,v 1.2 2012/08/12 21:08:46 wiz Exp $
--- setup.py.orig 2010-02-02 10:11:17.000000000 +0000
Avoid conflicts between different python package versions.
--- setup.py.orig 2012-04-21 11:34:22.000000000 +0000
+++ setup.py
@@ -68,7 +68,7 @@ if 'setuptools' in sys.modules:
@@ -90,13 +90,13 @@ if 'setuptools' in sys.modules:
scripts = []
else:
if os.name == "posix":
@ -11,3 +13,10 @@ $NetBSD: patch-aa,v 1.1.1.1 2010/07/15 17:41:57 drochner Exp $
else:
scripts = ["cython.py"]
if include_debugger:
if os.name == "posix":
- scripts.append('bin/cygdb')
+ scripts.append('bin/cygdb' + sys.version[0:3])
else:
scripts.append('cygdb.py')

View file

@ -1,13 +1,30 @@
$NetBSD: patch-ab,v 1.2 2010/11/24 17:58:22 drochner Exp $
$NetBSD: patch-ab,v 1.3 2012/08/12 21:08:46 wiz Exp $
--- runtests.py.orig 2010-08-25 06:38:31.000000000 +0000
Use correct make for pkgsrc.
--- runtests.py.orig 2012-04-21 11:34:22.000000000 +0000
+++ runtests.py
@@ -646,7 +646,7 @@ class EmbedTest(unittest.TestCase):
def test_embed(self):
@@ -1100,12 +1100,12 @@ class EmbedTest(unittest.TestCase):
self.old_dir = os.getcwd()
os.chdir(self.working_dir)
os.system(
- "make PYTHON='%s' clean > /dev/null" % sys.executable)
+ "gmake PYTHON='%s' clean > /dev/null" % sys.executable)
def tearDown(self):
try:
os.system(
- "make PYTHON='%s' clean > /dev/null" % sys.executable)
+ "gmake PYTHON='%s' clean > /dev/null" % sys.executable)
except:
pass
os.chdir(self.old_dir)
@@ -1126,7 +1126,7 @@ class EmbedTest(unittest.TestCase):
cython = os.path.join(CY3_DIR, cython)
cython = os.path.abspath(os.path.join('..', '..', cython))
self.assert_(os.system(
- "make PYTHON='%s' test > make.output" % sys.executable) == 0)
+ "gmake PYTHON='%s' test > make.output" % sys.executable) == 0)
- "make PYTHON='%s' CYTHON='%s' LIBDIR1='%s' test > make.output" % (sys.executable, cython, libdir)) == 0)
+ "gmake PYTHON='%s' CYTHON='%s' LIBDIR1='%s' test > make.output" % (sys.executable, cython, libdir)) == 0)
try:
os.remove('make.output')
except OSError:

View file

@ -1,13 +1,15 @@
$NetBSD: patch-ac,v 1.2 2010/11/24 17:58:22 drochner Exp $
$NetBSD: patch-ac,v 1.3 2012/08/12 21:08:46 wiz Exp $
--- Demos/embed/Makefile.orig 2010-08-25 06:38:31.000000000 +0000
Add missing rpath.
--- Demos/embed/Makefile.orig 2012-04-21 11:34:22.000000000 +0000
+++ Demos/embed/Makefile
@@ -13,7 +13,7 @@ LIBS=$(shell $(PYTHON) -c "import distut
@@ -14,7 +14,7 @@ LIBS=$(shell $(PYTHON) -c "import distut
SYSLIBS= $(shell $(PYTHON) -c "import distutils.sysconfig; print(distutils.sysconfig.get_config_var('SYSLIBS'))")
embedded: embedded.o
- $(LINKCC) -o $@ $^ $(LINKFORSHARED) -L$(LIBDIR1) -L$(LIBDIR2) -lpython$(PYVERSION) $(LIBS) $(SYSLIBS)
+ $(LINKCC) -o $@ $^ $(LINKFORSHARED) -L$(LIBDIR1) -L$(LIBDIR2) -lpython$(PYVERSION) $(LIBS) $(SYSLIBS) -Wl,-R$(LIBDIR1)
- $(LINKCC) -o $@ $^ -L$(LIBDIR1) -L$(LIBDIR2) -l$(PYLIB) $(LIBS) $(SYSLIBS) $(LINKFORSHARED)
+ $(LINKCC) -o $@ $^ -L$(LIBDIR1) -L$(LIBDIR2) -l$(PYLIB) $(LIBS) $(SYSLIBS) $(LINKFORSHARED) -Wl,-R$(LIBDIR1)
embedded.o: embedded.c
$(CC) -c $^ -I$(INCDIR)