Use devel/readline/Makefile.readline to get readline support on systems

without libedit readline emulation.  Don't accidentally link against
ncurses.

The ncurses dependency was removed a while back, but I'm not entirely sure
that was correct.  I don't think the curses library is enough to get this
package to work on pre-1.5 NetBSD systems.  I also don't know if this will
work with Solaris curses either.  We'll have to wait for bug reports.
This commit is contained in:
jlam 2001-05-16 20:27:23 +00:00
parent 5da9c93eaa
commit 90709cc4df
4 changed files with 15 additions and 56 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.23 2001/05/13 06:13:15 tron Exp $
# $NetBSD: Makefile,v 1.24 2001/05/16 20:27:23 jlam Exp $
# FreeBSD Id: Makefile,v 1.39 1998/01/31 17:49:48 jseger Exp
#
@ -12,24 +12,15 @@ COMMENT= FTP replacement with advanced user interface
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --disable-extra-dirs
BUILD_DEFS+= USE_SOCKS
CONFIGURE_ARGS+= --disable-ncurses
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}"
CONFIGURE_ENV+= ac_cv_lib_intl_strftime=no
.include "../../mk/bsd.prefs.mk"
# Check for readline.h as standard
.if exists(/usr/include/readline.h) || exists(/usr/include/readline/readline.h)
CPPFLAGS+= -DHAVE_LIBREADLINE=1
CPPFLAGS+= -DHAVE_FILENAME_COMPLETION_FUNCTION=1
CPPFLAGS+= -DHAVE_READLINE_H=1 -DHAVE_HISTORY_H=1
CONFIGURE_ARGS+= --disable-readline --disable-ncurses
CONFIGURE_ENV+= LIBS="-ledit -ltermcap"
.else
DEPENDS+= readline>=4.0:../../devel/readline
.endif
# Include SOCKS firewall support
.if defined(USE_SOCKS) && (${USE_SOCKS} == 4 || ${USE_SOCKS} == 5)
BUILD_DEFS+= USE_SOCKS
.if ${USE_SOCKS} == 4
CONFIGURE_ARGS+= --enable-socks
DEPENDS+= socks4-2.2:../../net/socks4
@ -39,11 +30,12 @@ DEPENDS+= socks5-1.0.2:../../net/socks5
.endif
.endif
.if ${OPSYS} == "SunOS"
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}"
.endif
.include "../../devel/readline/Makefile.readline"
CPPFLAGS+= -I${WRKINCDIR}
LDFLAGS+= -L${WRKLIBDIR}
pre-configure: link-readline-headers link-readline-libs
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ncftp ${PREFIX}/bin/ncftp2

View file

@ -1,8 +1,7 @@
$NetBSD: distinfo,v 1.2 2001/04/21 11:23:23 wiz Exp $
$NetBSD: distinfo,v 1.3 2001/05/16 20:27:23 jlam Exp $
SHA1 (ncftp-2.4.3.tar.gz) = 467476420e16e14f09213e834bea9d2a37596a3e
Size (ncftp-2.4.3.tar.gz) = 192937 bytes
SHA1 (patch-aa) = 792be48d48a53cfc2fe1f2a14b47d0488ba78b3c
SHA1 (patch-ab) = 7661bf5d6700633f01ecb9a9a2f014f01c363728
SHA1 (patch-ab) = 4525161f649415fb44d3896899ffa0068127586e
SHA1 (patch-ac) = 39ae65bcae18308e35c5590262360982672dbfef
SHA1 (patch-ad) = ef33bea0a275689c1d3eb71e636e8f89e4fbcfcd

View file

@ -1,20 +1,8 @@
$NetBSD: patch-ab,v 1.4 1999/07/13 01:34:42 jlam Exp $
$NetBSD: patch-ab,v 1.5 2001/05/16 20:27:23 jlam Exp $
--- Complete.c.orig Fri Oct 18 01:10:31 1996
+++ Complete.c Thu Jul 8 15:33:42 1999
@@ -52,7 +52,11 @@
typedef char * (*CompleteFunc)(char *, int);
#ifdef HAVE_LIBREADLINE
+#if HAVE_READLINE_H
+#include <readline.h>
+#else
#include <readline/readline.h>
+#endif
#ifdef HAVE_FILENAME_COMPLETION_FUNCTION
/* This should have been in your readline.h already, but some older
@@ -241,7 +245,11 @@
@@ -241,7 +241,11 @@
static int
CompareStrings(char **a, char **b)
{

View file

@ -1,20 +0,0 @@
$NetBSD: patch-ad,v 1.1 1999/07/13 01:34:42 jlam Exp $
--- LGets.c.orig Fri Apr 7 23:28:00 1995
+++ LGets.c Thu Jul 8 15:38:00 1999
@@ -5,11 +5,15 @@
#include "LGets.h"
#ifdef HAVE_LIBREADLINE
+#if HAVE_HISTORY_H
+# include <history.h>
+#else
# include <readline/readline.h>
# ifdef HAVE_READLINE_HISTORY_H
/* Required for version 2.0 of readline. */
# include <readline/history.h>
# endif
+#endif
#endif /* HAVE_LIBREADLINE */
#ifdef HAVE_LIBGETLINE