couchdb: Update to 3.2.2.
Changes since 2.3.1 are too numerous to list here, please see the following URLs for the full changelogs: https://docs.couchdb.org/en/latest/whatsnew/3.0.html https://docs.couchdb.org/en/latest/whatsnew/3.1.html https://docs.couchdb.org/en/latest/whatsnew/3.2.html
This commit is contained in:
parent
5c02a4ddd5
commit
90b45e2d1a
9 changed files with 120 additions and 159 deletions
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.81 2022/11/23 16:19:33 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.82 2022/11/29 19:16:04 jperkin Exp $
|
||||
|
||||
DISTNAME= apache-couchdb-2.3.1
|
||||
DISTNAME= apache-couchdb-3.2.2
|
||||
PKGNAME= ${DISTNAME:S/apache-//}
|
||||
PKGREVISION= 17
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= ${MASTER_SITE_APACHE:=couchdb/source/${PKGVERSION_NOREV}/}
|
||||
|
||||
|
@ -17,7 +16,6 @@ USE_TOOLS+= gmake pax pkg-config
|
|||
USE_LIBTOOL= yes
|
||||
BUILD_DEFS+= VARBASE
|
||||
|
||||
BUILD_DEPENDS+= help2man-[0-9]*:../../converters/help2man
|
||||
BUILD_DEPENDS+= rebar21>=2.6.0<3:../../devel/rebar21
|
||||
|
||||
MAKE_ENV+= REBAR=${PREFIX}/bin/rebar
|
||||
|
@ -72,6 +70,8 @@ CONFIGURE_ARGS+= --user\ ${COUCH_USER}
|
|||
CONFIGURE_ARGS+= --skip-deps
|
||||
CONFIGURE_ARGS+= --with-curl
|
||||
|
||||
BUILDLINK_TRANSFORM+= rm:-Werror
|
||||
|
||||
BUILD_TARGET= release
|
||||
TEST_TARGET= check
|
||||
|
||||
|
@ -120,6 +120,7 @@ do-install:
|
|||
${DESTDIR}${PREFIX}/couchdb/share
|
||||
cd ${WRKSRC}/rel/couchdb/etc && ${PAX} -rw -pp *.ini vm.args \
|
||||
${DESTDIR}${COUCH_EGDIR}
|
||||
${FIND} ${DESTDIR}${PREFIX} -type f -exec ${CHMOD} og-w {} +
|
||||
|
||||
# The erlang VM gets embedded, but it may still need the curses lib
|
||||
BUILDLINK_DEPMETHOD.erlang= build
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.10 2019/09/06 09:10:47 jperkin Exp $
|
||||
@comment $NetBSD: PLIST,v 1.11 2022/11/29 19:16:04 jperkin Exp $
|
||||
bin/couchdb
|
||||
bin/couchjs
|
||||
couchdb/releases/${PKGVERSION}/couchdb.boot
|
||||
|
@ -13,7 +13,8 @@ couchdb/releases/RELEASES
|
|||
couchdb/releases/start_erl.data
|
||||
couchdb/share/server/main-coffee.js
|
||||
couchdb/share/server/main.js
|
||||
couchdb/share/www/dashboard.assets/css/styles.89dbadd64e69e0df7653.css
|
||||
couchdb/share/www/dashboard.assets/css/styles.01f570698487acedea0d.css
|
||||
couchdb/share/www/dashboard.assets/css/styles.1dd5f02ec0ce91979b00.css
|
||||
couchdb/share/www/dashboard.assets/fonts/fauxtonicon5.eot
|
||||
couchdb/share/www/dashboard.assets/fonts/fauxtonicon5.ttf
|
||||
couchdb/share/www/dashboard.assets/fonts/fauxtonicon5.woff
|
||||
|
@ -31,9 +32,13 @@ couchdb/share/www/dashboard.assets/img/googleplus.png
|
|||
couchdb/share/www/dashboard.assets/img/linkedin.png
|
||||
couchdb/share/www/dashboard.assets/img/loader.gif
|
||||
couchdb/share/www/dashboard.assets/img/twitter.png
|
||||
couchdb/share/www/dashboard.assets/js/bundle.89dbadd64e69e0df7653.js
|
||||
couchdb/share/www/dashboard.assets/js/manifest.a154524a560e5f6f431b.js
|
||||
couchdb/share/www/dashboard.assets/js/vendor.9993972098ce728e0fc2.js
|
||||
couchdb/share/www/dashboard.assets/js/bundle.01f570698487acedea0d.js
|
||||
couchdb/share/www/dashboard.assets/js/manifest.9d15b7c24fc8359d2668.js
|
||||
couchdb/share/www/dashboard.assets/js/vendor.1dd5f02ec0ce91979b00.js
|
||||
couchdb/share/www/docs/_images/23379351593_0c480537de_q.jpg
|
||||
couchdb/share/www/docs/_images/TLS-Handshake.png
|
||||
couchdb/share/www/docs/_images/fair-enough.png
|
||||
couchdb/share/www/docs/_images/gf-gnome-rainbows.png
|
||||
couchdb/share/www/docs/_images/intro-consistency-01.png
|
||||
couchdb/share/www/docs/_images/intro-consistency-02.png
|
||||
couchdb/share/www/docs/_images/intro-consistency-03.png
|
||||
|
@ -68,12 +73,14 @@ couchdb/share/www/docs/_sources/api/ddoc/common.rst.txt
|
|||
couchdb/share/www/docs/_sources/api/ddoc/index.rst.txt
|
||||
couchdb/share/www/docs/_sources/api/ddoc/render.rst.txt
|
||||
couchdb/share/www/docs/_sources/api/ddoc/rewrites.rst.txt
|
||||
couchdb/share/www/docs/_sources/api/ddoc/search.rst.txt
|
||||
couchdb/share/www/docs/_sources/api/ddoc/views.rst.txt
|
||||
couchdb/share/www/docs/_sources/api/document/attachments.rst.txt
|
||||
couchdb/share/www/docs/_sources/api/document/common.rst.txt
|
||||
couchdb/share/www/docs/_sources/api/document/index.rst.txt
|
||||
couchdb/share/www/docs/_sources/api/index.rst.txt
|
||||
couchdb/share/www/docs/_sources/api/local.rst.txt
|
||||
couchdb/share/www/docs/_sources/api/partitioned-dbs.rst.txt
|
||||
couchdb/share/www/docs/_sources/api/server/authn.rst.txt
|
||||
couchdb/share/www/docs/_sources/api/server/common.rst.txt
|
||||
couchdb/share/www/docs/_sources/api/server/configuration.rst.txt
|
||||
|
@ -91,6 +98,8 @@ couchdb/share/www/docs/_sources/cluster/nodes.rst.txt
|
|||
couchdb/share/www/docs/_sources/cluster/purging.rst.txt
|
||||
couchdb/share/www/docs/_sources/cluster/sharding.rst.txt
|
||||
couchdb/share/www/docs/_sources/cluster/theory.rst.txt
|
||||
couchdb/share/www/docs/_sources/cluster/tls_erlang_distribution.rst.txt
|
||||
couchdb/share/www/docs/_sources/cluster/troubleshooting.rst.txt
|
||||
couchdb/share/www/docs/_sources/config/auth.rst.txt
|
||||
couchdb/share/www/docs/_sources/config/cluster.rst.txt
|
||||
couchdb/share/www/docs/_sources/config/compaction.rst.txt
|
||||
|
@ -98,12 +107,14 @@ couchdb/share/www/docs/_sources/config/couch-peruser.rst.txt
|
|||
couchdb/share/www/docs/_sources/config/couchdb.rst.txt
|
||||
couchdb/share/www/docs/_sources/config/http.rst.txt
|
||||
couchdb/share/www/docs/_sources/config/index.rst.txt
|
||||
couchdb/share/www/docs/_sources/config/indexbuilds.rst.txt
|
||||
couchdb/share/www/docs/_sources/config/intro.rst.txt
|
||||
couchdb/share/www/docs/_sources/config/ioq.rst.txt
|
||||
couchdb/share/www/docs/_sources/config/logging.rst.txt
|
||||
couchdb/share/www/docs/_sources/config/misc.rst.txt
|
||||
couchdb/share/www/docs/_sources/config/query-servers.rst.txt
|
||||
couchdb/share/www/docs/_sources/config/replicator.rst.txt
|
||||
couchdb/share/www/docs/_sources/config/services.rst.txt
|
||||
couchdb/share/www/docs/_sources/config/resharding.rst.txt
|
||||
couchdb/share/www/docs/_sources/contributing.rst.txt
|
||||
couchdb/share/www/docs/_sources/cve/2010-0009.rst.txt
|
||||
couchdb/share/www/docs/_sources/cve/2010-2234.rst.txt
|
||||
|
@ -117,9 +128,12 @@ couchdb/share/www/docs/_sources/cve/2017-12636.rst.txt
|
|||
couchdb/share/www/docs/_sources/cve/2018-11769.rst.txt
|
||||
couchdb/share/www/docs/_sources/cve/2018-17188.rst.txt
|
||||
couchdb/share/www/docs/_sources/cve/2018-8007.rst.txt
|
||||
couchdb/share/www/docs/_sources/cve/2020-1955.rst.txt
|
||||
couchdb/share/www/docs/_sources/cve/2021-38295.rst.txt
|
||||
couchdb/share/www/docs/_sources/cve/index.rst.txt
|
||||
couchdb/share/www/docs/_sources/ddocs/ddocs.rst.txt
|
||||
couchdb/share/www/docs/_sources/ddocs/index.rst.txt
|
||||
couchdb/share/www/docs/_sources/ddocs/search.rst.txt
|
||||
couchdb/share/www/docs/_sources/ddocs/views/collation.rst.txt
|
||||
couchdb/share/www/docs/_sources/ddocs/views/index.rst.txt
|
||||
couchdb/share/www/docs/_sources/ddocs/views/intro.rst.txt
|
||||
|
@ -133,7 +147,9 @@ couchdb/share/www/docs/_sources/index.rst.txt
|
|||
couchdb/share/www/docs/_sources/install/docker.rst.txt
|
||||
couchdb/share/www/docs/_sources/install/freebsd.rst.txt
|
||||
couchdb/share/www/docs/_sources/install/index.rst.txt
|
||||
couchdb/share/www/docs/_sources/install/kubernetes.rst.txt
|
||||
couchdb/share/www/docs/_sources/install/mac.rst.txt
|
||||
couchdb/share/www/docs/_sources/install/search.rst.txt
|
||||
couchdb/share/www/docs/_sources/install/snap.rst.txt
|
||||
couchdb/share/www/docs/_sources/install/troubleshooting.rst.txt
|
||||
couchdb/share/www/docs/_sources/install/unix.rst.txt
|
||||
|
@ -152,6 +168,7 @@ couchdb/share/www/docs/_sources/maintenance/backups.rst.txt
|
|||
couchdb/share/www/docs/_sources/maintenance/compaction.rst.txt
|
||||
couchdb/share/www/docs/_sources/maintenance/index.rst.txt
|
||||
couchdb/share/www/docs/_sources/maintenance/performance.rst.txt
|
||||
couchdb/share/www/docs/_sources/partitioned-dbs/index.rst.txt
|
||||
couchdb/share/www/docs/_sources/query-server/erlang.rst.txt
|
||||
couchdb/share/www/docs/_sources/query-server/index.rst.txt
|
||||
couchdb/share/www/docs/_sources/query-server/javascript.rst.txt
|
||||
|
@ -180,44 +197,43 @@ couchdb/share/www/docs/_sources/whatsnew/2.0.rst.txt
|
|||
couchdb/share/www/docs/_sources/whatsnew/2.1.rst.txt
|
||||
couchdb/share/www/docs/_sources/whatsnew/2.2.rst.txt
|
||||
couchdb/share/www/docs/_sources/whatsnew/2.3.rst.txt
|
||||
couchdb/share/www/docs/_sources/whatsnew/3.0.rst.txt
|
||||
couchdb/share/www/docs/_sources/whatsnew/3.1.rst.txt
|
||||
couchdb/share/www/docs/_sources/whatsnew/3.2.rst.txt
|
||||
couchdb/share/www/docs/_sources/whatsnew/index.rst.txt
|
||||
couchdb/share/www/docs/_static/ajax-loader.gif
|
||||
couchdb/share/www/docs/_static/basic.css
|
||||
couchdb/share/www/docs/_static/comment-bright.png
|
||||
couchdb/share/www/docs/_static/comment-close.png
|
||||
couchdb/share/www/docs/_static/comment.png
|
||||
couchdb/share/www/docs/_static/css/badge_only.css
|
||||
couchdb/share/www/docs/_static/css/rtd_theme.css
|
||||
couchdb/share/www/docs/_static/css/theme.css
|
||||
couchdb/share/www/docs/_static/doctools.js
|
||||
couchdb/share/www/docs/_static/down-pressed.png
|
||||
couchdb/share/www/docs/_static/down.png
|
||||
couchdb/share/www/docs/_static/documentation_options.js
|
||||
couchdb/share/www/docs/_static/favicon.ico
|
||||
couchdb/share/www/docs/_static/file.png
|
||||
couchdb/share/www/docs/_static/fonts/Inconsolata-Bold.ttf
|
||||
couchdb/share/www/docs/_static/fonts/Inconsolata-Regular.ttf
|
||||
couchdb/share/www/docs/_static/fonts/Lato-Bold.ttf
|
||||
couchdb/share/www/docs/_static/fonts/Lato-Bold.woff2
|
||||
couchdb/share/www/docs/_static/fonts/Lato-BoldItalic.ttf
|
||||
couchdb/share/www/docs/_static/fonts/Lato-BoldItalic.woff2
|
||||
couchdb/share/www/docs/_static/fonts/Lato-Italic.ttf
|
||||
couchdb/share/www/docs/_static/fonts/Lato-Italic.woff2
|
||||
couchdb/share/www/docs/_static/fonts/Lato-Regular.ttf
|
||||
couchdb/share/www/docs/_static/fonts/RobotoSlab-Bold.ttf
|
||||
couchdb/share/www/docs/_static/fonts/RobotoSlab-Regular.ttf
|
||||
couchdb/share/www/docs/_static/fonts/Lato-Regular.woff2
|
||||
couchdb/share/www/docs/_static/fonts/RobotoSlab-Bold.woff2
|
||||
couchdb/share/www/docs/_static/fonts/RobotoSlab-Regular.woff2
|
||||
couchdb/share/www/docs/_static/fonts/fontawesome-webfont.eot
|
||||
couchdb/share/www/docs/_static/fonts/fontawesome-webfont.svg
|
||||
couchdb/share/www/docs/_static/fonts/fontawesome-webfont.ttf
|
||||
couchdb/share/www/docs/_static/fonts/fontawesome-webfont.woff
|
||||
couchdb/share/www/docs/_static/jquery-3.1.0.js
|
||||
couchdb/share/www/docs/_static/fonts/fontawesome-webfont.woff2
|
||||
couchdb/share/www/docs/_static/jquery.js
|
||||
couchdb/share/www/docs/_static/js/modernizr.min.js
|
||||
couchdb/share/www/docs/_static/js/theme.js
|
||||
couchdb/share/www/docs/_static/language_data.js
|
||||
couchdb/share/www/docs/_static/logo.png
|
||||
couchdb/share/www/docs/_static/minus.png
|
||||
couchdb/share/www/docs/_static/plus.png
|
||||
couchdb/share/www/docs/_static/pygments.css
|
||||
couchdb/share/www/docs/_static/searchtools.js
|
||||
couchdb/share/www/docs/_static/underscore-1.3.1.js
|
||||
couchdb/share/www/docs/_static/underscore.js
|
||||
couchdb/share/www/docs/_static/up-pressed.png
|
||||
couchdb/share/www/docs/_static/up.png
|
||||
couchdb/share/www/docs/_static/websupport.js
|
||||
couchdb/share/www/docs/about.html
|
||||
couchdb/share/www/docs/api/basics.html
|
||||
couchdb/share/www/docs/api/database/bulk-api.html
|
||||
|
@ -233,12 +249,14 @@ couchdb/share/www/docs/api/ddoc/common.html
|
|||
couchdb/share/www/docs/api/ddoc/index.html
|
||||
couchdb/share/www/docs/api/ddoc/render.html
|
||||
couchdb/share/www/docs/api/ddoc/rewrites.html
|
||||
couchdb/share/www/docs/api/ddoc/search.html
|
||||
couchdb/share/www/docs/api/ddoc/views.html
|
||||
couchdb/share/www/docs/api/document/attachments.html
|
||||
couchdb/share/www/docs/api/document/common.html
|
||||
couchdb/share/www/docs/api/document/index.html
|
||||
couchdb/share/www/docs/api/index.html
|
||||
couchdb/share/www/docs/api/local.html
|
||||
couchdb/share/www/docs/api/partitioned-dbs.html
|
||||
couchdb/share/www/docs/api/server/authn.html
|
||||
couchdb/share/www/docs/api/server/common.html
|
||||
couchdb/share/www/docs/api/server/configuration.html
|
||||
|
@ -256,6 +274,8 @@ couchdb/share/www/docs/cluster/nodes.html
|
|||
couchdb/share/www/docs/cluster/purging.html
|
||||
couchdb/share/www/docs/cluster/sharding.html
|
||||
couchdb/share/www/docs/cluster/theory.html
|
||||
couchdb/share/www/docs/cluster/tls_erlang_distribution.html
|
||||
couchdb/share/www/docs/cluster/troubleshooting.html
|
||||
couchdb/share/www/docs/config-ref.html
|
||||
couchdb/share/www/docs/config/auth.html
|
||||
couchdb/share/www/docs/config/cluster.html
|
||||
|
@ -264,12 +284,14 @@ couchdb/share/www/docs/config/couch-peruser.html
|
|||
couchdb/share/www/docs/config/couchdb.html
|
||||
couchdb/share/www/docs/config/http.html
|
||||
couchdb/share/www/docs/config/index.html
|
||||
couchdb/share/www/docs/config/indexbuilds.html
|
||||
couchdb/share/www/docs/config/intro.html
|
||||
couchdb/share/www/docs/config/ioq.html
|
||||
couchdb/share/www/docs/config/logging.html
|
||||
couchdb/share/www/docs/config/misc.html
|
||||
couchdb/share/www/docs/config/query-servers.html
|
||||
couchdb/share/www/docs/config/replicator.html
|
||||
couchdb/share/www/docs/config/services.html
|
||||
couchdb/share/www/docs/config/resharding.html
|
||||
couchdb/share/www/docs/contributing.html
|
||||
couchdb/share/www/docs/cve/2010-0009.html
|
||||
couchdb/share/www/docs/cve/2010-2234.html
|
||||
|
@ -283,9 +305,12 @@ couchdb/share/www/docs/cve/2017-12636.html
|
|||
couchdb/share/www/docs/cve/2018-11769.html
|
||||
couchdb/share/www/docs/cve/2018-17188.html
|
||||
couchdb/share/www/docs/cve/2018-8007.html
|
||||
couchdb/share/www/docs/cve/2020-1955.html
|
||||
couchdb/share/www/docs/cve/2021-38295.html
|
||||
couchdb/share/www/docs/cve/index.html
|
||||
couchdb/share/www/docs/ddocs/ddocs.html
|
||||
couchdb/share/www/docs/ddocs/index.html
|
||||
couchdb/share/www/docs/ddocs/search.html
|
||||
couchdb/share/www/docs/ddocs/views/collation.html
|
||||
couchdb/share/www/docs/ddocs/views/index.html
|
||||
couchdb/share/www/docs/ddocs/views/intro.html
|
||||
|
@ -301,7 +326,9 @@ couchdb/share/www/docs/index.html
|
|||
couchdb/share/www/docs/install/docker.html
|
||||
couchdb/share/www/docs/install/freebsd.html
|
||||
couchdb/share/www/docs/install/index.html
|
||||
couchdb/share/www/docs/install/kubernetes.html
|
||||
couchdb/share/www/docs/install/mac.html
|
||||
couchdb/share/www/docs/install/search.html
|
||||
couchdb/share/www/docs/install/snap.html
|
||||
couchdb/share/www/docs/install/troubleshooting.html
|
||||
couchdb/share/www/docs/install/unix.html
|
||||
|
@ -321,6 +348,7 @@ couchdb/share/www/docs/maintenance/compaction.html
|
|||
couchdb/share/www/docs/maintenance/index.html
|
||||
couchdb/share/www/docs/maintenance/performance.html
|
||||
couchdb/share/www/docs/objects.inv
|
||||
couchdb/share/www/docs/partitioned-dbs/index.html
|
||||
couchdb/share/www/docs/query-server/erlang.html
|
||||
couchdb/share/www/docs/query-server/index.html
|
||||
couchdb/share/www/docs/query-server/javascript.html
|
||||
|
@ -351,6 +379,9 @@ couchdb/share/www/docs/whatsnew/2.0.html
|
|||
couchdb/share/www/docs/whatsnew/2.1.html
|
||||
couchdb/share/www/docs/whatsnew/2.2.html
|
||||
couchdb/share/www/docs/whatsnew/2.3.html
|
||||
couchdb/share/www/docs/whatsnew/3.0.html
|
||||
couchdb/share/www/docs/whatsnew/3.1.html
|
||||
couchdb/share/www/docs/whatsnew/3.2.html
|
||||
couchdb/share/www/docs/whatsnew/index.html
|
||||
couchdb/share/www/index.html
|
||||
man/man1/couchdb.1
|
||||
|
|
|
@ -1,12 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.21 2021/10/26 10:09:15 nia Exp $
|
||||
$NetBSD: distinfo,v 1.22 2022/11/29 19:16:04 jperkin Exp $
|
||||
|
||||
BLAKE2s (apache-couchdb-2.3.1.tar.gz) = 58701851e546e763526b960946530061f50b24a8ee5f170456f2837ece576b12
|
||||
SHA512 (apache-couchdb-2.3.1.tar.gz) = a34a8775b2be3c51f48c9f45c5ccaa01fbd8435d58aa326e1e53f1c82678fdbf657f90003d476ad43d3898bbd3cbedfc2dd9adbd2d98cec31f850ca743c8c64c
|
||||
Size (apache-couchdb-2.3.1.tar.gz) = 13473795 bytes
|
||||
SHA1 (patch-aa) = c657ce706e3ba0487aff6ac96628ebf3c97b1475
|
||||
SHA1 (patch-rebar.config.script) = 628340e6a8085e92d4193ac11905eebd8377a6b6
|
||||
SHA1 (patch-rel_files_couchdb.in) = d94bf0e54657fea26dd42e807cc2de36a67e8fda
|
||||
SHA1 (patch-rel_overlay_etc_default.ini) = 203af5ee1684288b66103842c30fa0f9135abd4b
|
||||
BLAKE2s (apache-couchdb-3.2.2.tar.gz) = 2d2e337f4746ef4fe4c9e26703c5f377bf79138161a914ec4ea398ea35169811
|
||||
SHA512 (apache-couchdb-3.2.2.tar.gz) = 2212ee1e7819a703ebdfe201dfbb1359ff674ddcbfe0936db22faa640f84ab8ebfeba7be412adcb9021f7267b14855f2fff53b89cd2d9a7eb98e72e9f3996814
|
||||
Size (apache-couchdb-3.2.2.tar.gz) = 16597518 bytes
|
||||
SHA1 (patch-aa) = ab69943c33c92f8830643a7ffb75e87ffdc47fd0
|
||||
SHA1 (patch-rel_files_couchdb.in) = fb1d38cbda801fb56bc4945ea62a7baacc36de12
|
||||
SHA1 (patch-rel_overlay_etc_default.ini) = 01a2c0164a26adcfd9f3d69a8d74626017ea0f94
|
||||
SHA1 (patch-src_config_src_config__app.erl) = 62c15c6e48961736dab4dd0d27b0c968847df323
|
||||
SHA1 (patch-src_couch_rebar.config.script) = 75f1d2d8aaa32d87f79c1c9820fad9b1d7b2b03b
|
||||
SHA1 (patch-src_snappy_rebar.config) = 767157cd1ff73267d8b023c2902d3861aedbc61b
|
||||
SHA1 (patch-src_couch_rebar.config.script) = 88b57002859e267e060cf77f3ea611f4e394d705
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
$NetBSD: patch-aa,v 1.12 2021/01/27 16:20:20 jperkin Exp $
|
||||
$NetBSD: patch-aa,v 1.13 2022/11/29 19:16:04 jperkin Exp $
|
||||
|
||||
Set pkgsrc standard paths. Portability.
|
||||
|
||||
--- configure.orig 2019-03-05 22:42:20.000000000 +0000
|
||||
--- configure.orig 2022-04-06 03:31:40.000000000 +0000
|
||||
+++ configure
|
||||
@@ -102,7 +102,7 @@ parse_opts() {
|
||||
@@ -123,7 +123,7 @@ parse_opts() {
|
||||
|
||||
--rebar)
|
||||
if [ -x "$2" ]; then
|
||||
|
@ -13,7 +13,7 @@ Set pkgsrc standard paths. Portability.
|
|||
if [ $? -ne 0 ]; then
|
||||
printf 'Rebar >=2.6.0 and <3.0.0 required' >&2
|
||||
exit 1
|
||||
@@ -167,11 +167,11 @@ cat > rel/couchdb.config << EOF
|
||||
@@ -220,11 +220,11 @@ cat > rel/couchdb.config << EOF
|
||||
% The contents of this file are auto-generated by configure
|
||||
%
|
||||
{package_author_name, "$PACKAGE_AUTHOR_NAME"}.
|
||||
|
@ -28,5 +28,5 @@ Set pkgsrc standard paths. Portability.
|
|||
+{log_file, "@COUCH_LOGDIR@/couch.log"}.
|
||||
+{fauxton_root, "@PREFIX@/couchdb/share/www"}.
|
||||
{user, "$COUCHDB_USER"}.
|
||||
{spidermonkey_version, "$SM_VSN"}.
|
||||
{node_name, "-name couchdb@127.0.0.1"}.
|
||||
{cluster_port, 5984}.
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-rebar.config.script,v 1.2 2019/09/06 09:10:48 jperkin Exp $
|
||||
|
||||
Support newer OTP.
|
||||
|
||||
--- rebar.config.script.orig 2019-03-05 22:42:20.000000000 +0000
|
||||
+++ rebar.config.script
|
||||
@@ -128,7 +128,7 @@ ErlOpts = case os:getenv("ERL_OPTS") of
|
||||
end,
|
||||
|
||||
AddConfig = [
|
||||
- {require_otp_vsn, "17|18|19|20|21"},
|
||||
+ {require_otp_vsn, "17|18|19|20|21|22"},
|
||||
{deps_dir, "src"},
|
||||
{deps, lists:map(MakeDep, DepDescs)},
|
||||
{sub_dirs, SubDirs},
|
|
@ -1,26 +1,20 @@
|
|||
$NetBSD: patch-rel_files_couchdb.in,v 1.1 2019/09/06 09:10:48 jperkin Exp $
|
||||
$NetBSD: patch-rel_files_couchdb.in,v 1.2 2022/11/29 19:16:04 jperkin Exp $
|
||||
|
||||
Support pkgsrc layout.
|
||||
|
||||
--- rel/files/couchdb.in.orig 2019-03-05 22:42:20.000000000 +0000
|
||||
--- rel/files/couchdb.in.orig 2022-04-06 03:31:40.000000000 +0000
|
||||
+++ rel/files/couchdb.in
|
||||
@@ -12,11 +12,7 @@
|
||||
# License for the specific language governing permissions and limitations under
|
||||
# the License.
|
||||
|
||||
-COUCHDB_BIN_DIR=$(cd "${0%/*}" && pwd)
|
||||
@@ -22,11 +22,9 @@ canonical_readlink ()
|
||||
cd "${1%/*}" && pwd -P;
|
||||
fi
|
||||
}
|
||||
-COUCHDB_BIN_DIR=$(canonical_readlink "$0")
|
||||
-ERTS_BIN_DIR=$COUCHDB_BIN_DIR/../
|
||||
-cd "$COUCHDB_BIN_DIR/../"
|
||||
-
|
||||
|
||||
-export ROOTDIR=${ERTS_BIN_DIR%/*}
|
||||
+export ROOTDIR="@PREFIX@/couchdb"
|
||||
+export COUCHDB_ARGS_FILE="${COUCHDB_ARGS_FILE:-@PKG_SYSCONFDIR@/vm.args}"
|
||||
|
||||
START_ERL=`cat "$ROOTDIR/releases/start_erl.data"`
|
||||
ERTS_VSN=${START_ERL% *}
|
||||
@@ -33,5 +29,5 @@ ARGS_FILE="${COUCHDB_ARGS_FILE:-$ROOTDIR
|
||||
SYSCONFIG_FILE="${COUCHDB_SYSCONFIG_FILE:-$ROOTDIR/releases/$APP_VSN/sys.config}"
|
||||
|
||||
exec "$BINDIR/erlexec" -boot "$ROOTDIR/releases/$APP_VSN/couchdb" \
|
||||
- -args_file "${ARGS_FILE}" \
|
||||
+ -args_file "@PKG_SYSCONFDIR@/vm.args" \
|
||||
-config "${SYSCONFIG_FILE}" "$@"
|
||||
|
|
|
@ -1,19 +1,19 @@
|
|||
$NetBSD: patch-rel_overlay_etc_default.ini,v 1.3 2019/09/06 09:10:48 jperkin Exp $
|
||||
$NetBSD: patch-rel_overlay_etc_default.ini,v 1.4 2022/11/29 19:16:04 jperkin Exp $
|
||||
|
||||
Set pkgsrc standard paths.
|
||||
|
||||
--- rel/overlay/etc/default.ini.orig 2019-03-05 22:42:20.000000000 +0000
|
||||
--- rel/overlay/etc/default.ini.orig 2022-04-06 03:31:40.000000000 +0000
|
||||
+++ rel/overlay/etc/default.ini
|
||||
@@ -532,7 +532,7 @@ level = info
|
||||
; rsyslog writer for deployments that need to have logs sent
|
||||
; over the network.
|
||||
@@ -574,7 +574,7 @@ partitioned||* = true
|
||||
; over the network, and a journald writer that's more suitable
|
||||
; when using systemd journald.
|
||||
;
|
||||
-writer = stderr
|
||||
-;writer = stderr
|
||||
+writer = file
|
||||
; Journald Writer notes:
|
||||
;
|
||||
; File Writer Options:
|
||||
;
|
||||
@@ -540,7 +540,7 @@ writer = stderr
|
||||
; The journald writer doesn't have any options. It still writes
|
||||
@@ -590,7 +590,7 @@ partitioned||* = true
|
||||
; to reopen its file. This is useful for people that configure
|
||||
; logrotate to move log files periodically.
|
||||
;
|
||||
|
|
|
@ -1,88 +1,52 @@
|
|||
$NetBSD: patch-src_couch_rebar.config.script,v 1.2 2019/09/06 09:10:48 jperkin Exp $
|
||||
$NetBSD: patch-src_couch_rebar.config.script,v 1.3 2022/11/29 19:16:04 jperkin Exp $
|
||||
|
||||
Set pkgsrc standard paths.
|
||||
Use pkg-config to set SpiderMonkey CFLAGS/LDFLAGS.
|
||||
|
||||
--- src/couch/rebar.config.script.orig 2019-03-05 22:42:20.000000000 +0000
|
||||
--- src/couch/rebar.config.script.orig 2022-04-06 03:31:40.000000000 +0000
|
||||
+++ src/couch/rebar.config.script
|
||||
@@ -78,23 +78,26 @@ MD5Config = case lists:keyfind(erlang_md
|
||||
[]
|
||||
end,
|
||||
@@ -112,6 +112,11 @@ ProperConfig = case code:lib_dir(proper)
|
||||
_ -> [{d, 'WITH_PROPER'}]
|
||||
end.
|
||||
|
||||
+CFLAGS = [os:getenv("CFLAGS")],
|
||||
+LDFLAGS = [os:getenv("LDFLAGS")],
|
||||
+JSFLAGS = string:strip(os:cmd("pkg-config --cflags mozjs185"), right, $\n),
|
||||
+JSLIBS = string:strip(os:cmd("pkg-config --libs mozjs185"), right, $\n),
|
||||
+
|
||||
%% TODO support curl on Windows
|
||||
{JS_CFLAGS, JS_LDFLAGS} = case lists:keyfind(with_curl, 1, CouchConfig) of
|
||||
{with_curl, true} ->
|
||||
case os:type() of
|
||||
{win32, _} ->
|
||||
{"/DHAVE_CURL /IC:\\relax\\curl\\include", "/LIBPATH:C:\\relax\\js-1.8.5\\js\\src /LIBPATH:C:\\Relax\\curl\\lib\\release-ssl mozjs185-1.0.lib libcurl_imp.lib"};
|
||||
- {unix, freebsd} ->
|
||||
- {"-DHAVE_CURL -I/usr/local/include", "-DHAVE_CURL -lmozjs185 -lcurl"};
|
||||
_ ->
|
||||
- {"-DHAVE_CURL", "-DHAVE_CURL -lmozjs185 -lcurl"}
|
||||
+ {"$CFLAGS -DHAVE_CURL " ++ JSFLAGS, "$LDFLAGS -DHAVE_CURL -lcurl " ++ JSLIBS}
|
||||
end;
|
||||
_ ->
|
||||
case os:type() of
|
||||
{win32, _} ->
|
||||
{"", "/LIBPATH:C:\\relax\\js-1.8.5\\js\\src mozjs185-1.0.lib"};
|
||||
_ ->
|
||||
- {"", "-lmozjs185"}
|
||||
+ {"$CFLAGS " ++ JSFLAGS, "$LDFLAGS " ++ JSLIBS}
|
||||
end
|
||||
end,
|
||||
{JS_CFLAGS, JS_LDFLAGS} = case os:type() of
|
||||
{win32, _} when SMVsn == "1.8.5" ->
|
||||
{
|
||||
@@ -120,8 +125,8 @@ end.
|
||||
};
|
||||
{unix, _} when SMVsn == "1.8.5" ->
|
||||
{
|
||||
- "-DXP_UNIX -I/usr/include/js -I/usr/local/include/js",
|
||||
- "-L/usr/local/lib -lmozjs185 -lm"
|
||||
+ "$CFLAGS -DXP_UNIX " ++ JSFLAGS,
|
||||
+ "$LDFLAGS -lm " ++ JSLIBS
|
||||
};
|
||||
{win32, _} when SMVsn == "60" ->
|
||||
{
|
||||
@@ -187,8 +192,8 @@ CouchJSEnv = case SMVsn of
|
||||
]
|
||||
end.
|
||||
|
||||
@@ -102,33 +105,38 @@ CouchJSSrc = ["priv/couch_js/*.c"],
|
||||
|
||||
IcuPath = "priv/couch_icu_driver.so",
|
||||
IcuSrc = ["priv/icu_driver/*.c"],
|
||||
-IcuEnv = [{"DRV_CFLAGS", "$DRV_CFLAGS -DPIC -O2 -fno-common"},
|
||||
- {"DRV_LDFLAGS", "$DRV_LDFLAGS -lm -licuuc -licudata -licui18n -lpthread"}],
|
||||
+IcuEnv = [{"DRV_CFLAGS", "$CFLAGS $DRV_CFLAGS -DPIC -O2 -fno-common"},
|
||||
+ {"DRV_LDFLAGS", "$DRV_LDFLAGS $LDFLAGS -lm -licuuc -licudata -licui18n -lpthread"}],
|
||||
IcuDarwinEnv = [{"CFLAGS", "-DXP_UNIX -I/usr/local/opt/icu4c/include"},
|
||||
{"LDFLAGS", "-L/usr/local/opt/icu4c/lib"}],
|
||||
- {"DRV_LDFLAGS", "$DRV_LDFLAGS -lm -licuuc -licudata -licui18n -lpthread"}].
|
||||
+IcuEnv = [{"DRV_CFLAGS", "$CFLAGS $DRV_CFLAGS -DPIC -O2 -fno-common"},
|
||||
+ {"DRV_LDFLAGS", "$LDFLAGS $DRV_LDFLAGS -lm -licuuc -licudata -licui18n -lpthread"}].
|
||||
IcuDarwinEnv = [{"CFLAGS", "-DXP_UNIX -I/usr/local/opt/icu4c/include -I/opt/homebrew/opt/icu4c/include"},
|
||||
{"LDFLAGS", "-L/usr/local/opt/icu4c/lib -L/opt/homebrew/opt/icu4c/lib"}].
|
||||
IcuBsdEnv = [{"CFLAGS", "-DXP_UNIX -I/usr/local/include"},
|
||||
{"LDFLAGS", "-L/usr/local/lib"}],
|
||||
IcuWinEnv = [{"CFLAGS", "/DXP_WIN /IC:\\relax\\icu\\include"},
|
||||
{"LDFLAGS", "/LIBPATH:C:\\relax\\icu\\lib64 icuin.lib icudt.lib icuuc.lib"}],
|
||||
+UnixEnv = [{"CFLAGS", " $CFLAGS -DXP_UNIX"},
|
||||
+ {"LDFLAGS", " $LDFLAGS -lm"}],
|
||||
|
||||
ComparePath = "priv/couch_ejson_compare.so",
|
||||
CompareSrc = ["priv/couch_ejson_compare/*.c"],
|
||||
|
||||
BaseSpecs = [
|
||||
@@ -203,9 +208,7 @@ BaseSpecs = [
|
||||
%% couchjs
|
||||
- {"darwin", CouchJSPath, CouchJSSrc, [{env, [{"CFLAGS", JS_CFLAGS ++ " -DXP_UNIX -I/usr/local/include/js"}, {"LDFLAGS", JS_LDFLAGS ++ " -L/usr/local/lib"}]}]},
|
||||
- {"linux", CouchJSPath, CouchJSSrc, [{env, [{"CFLAGS", JS_CFLAGS ++ " -DXP_UNIX -I/usr/include/js"}, {"LDFLAGS", JS_LDFLAGS ++ " -lm"}]}]},
|
||||
- {"bsd", CouchJSPath, CouchJSSrc, [{env, [{"CFLAGS", JS_CFLAGS ++ " -DXP_UNIX -I/usr/local/include/js"}, {"LDFLAGS", JS_LDFLAGS ++ " -L/usr/local/lib -lm"}]}]},
|
||||
+ {"darwin", CouchJSPath, CouchJSSrc, [{env, [{"CFLAGS", JS_CFLAGS ++ " -DXP_UNIX"}, {"LDFLAGS", JS_LDFLAGS}]}]},
|
||||
+ {"linux", CouchJSPath, CouchJSSrc, [{env, [{"CFLAGS", JS_CFLAGS ++ " -DXP_UNIX"}, {"LDFLAGS", JS_LDFLAGS ++ " -lm"}]}]},
|
||||
+ {"bsd", CouchJSPath, CouchJSSrc, [{env, [{"CFLAGS", JS_CFLAGS ++ " -DXP_UNIX"}, {"LDFLAGS", JS_LDFLAGS ++ " -lm"}]}]},
|
||||
+ {"solaris", CouchJSPath, CouchJSSrc, [{env, [{"CFLAGS", JS_CFLAGS ++ " -DXP_UNIX"}, {"LDFLAGS", JS_LDFLAGS ++ " -lm"}]}]},
|
||||
{"win32", CouchJSPath, CouchJSSrc, [{env, [{"CFLAGS", JS_CFLAGS ++ " /DXP_WIN /IC:\\relax\\js-1.8.5\\js\\src"}, {"LDFLAGS", JS_LDFLAGS}]}]},
|
||||
% ICU
|
||||
- {"darwin", IcuPath, IcuSrc, [{env, IcuEnv ++ IcuDarwinEnv}]},
|
||||
- {"linux", IcuPath, IcuSrc, [{env, IcuEnv}]},
|
||||
- {"bsd", IcuPath, IcuSrc, [{env, IcuEnv ++ IcuBsdEnv}]},
|
||||
+ {"darwin", IcuPath, IcuSrc, [{env, IcuEnv ++ UnixEnv}]},
|
||||
+ {"linux", IcuPath, IcuSrc, [{env, IcuEnv ++ UnixEnv}]},
|
||||
+ {"bsd", IcuPath, IcuSrc, [{env, IcuEnv ++ UnixEnv}]},
|
||||
+ {"solaris", IcuPath, IcuSrc, [{env, IcuEnv ++ UnixEnv}]},
|
||||
{"win32", IcuPath, IcuSrc, [{env, IcuWinEnv}]},
|
||||
{".*", CouchJSPath, CouchJSSrc, [{env, CouchJSEnv}]},
|
||||
% ejson_compare
|
||||
- {"darwin", ComparePath, CompareSrc, [{env, IcuEnv ++ IcuDarwinEnv}]},
|
||||
- {"linux", ComparePath, CompareSrc, [{env, IcuEnv}]},
|
||||
- {"bsd", ComparePath, CompareSrc, [{env, IcuEnv ++ IcuBsdEnv}]},
|
||||
+ {"darwin", ComparePath, CompareSrc, [{env, IcuEnv ++ UnixEnv}]},
|
||||
+ {"linux", ComparePath, CompareSrc, [{env, IcuEnv ++ UnixEnv}]},
|
||||
+ {"bsd", ComparePath, CompareSrc, [{env, IcuEnv ++ UnixEnv}]},
|
||||
+ {"solaris", ComparePath, CompareSrc, [{env, IcuEnv ++ UnixEnv}]},
|
||||
+ {".*", ComparePath, CompareSrc, [{env, IcuEnv}]},
|
||||
{"win32", ComparePath, CompareSrc, [{env, IcuWinEnv}]}
|
||||
],
|
||||
].
|
||||
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
$NetBSD: patch-src_snappy_rebar.config,v 1.2 2019/09/06 09:10:48 jperkin Exp $
|
||||
|
||||
Support newer OTP.
|
||||
|
||||
--- src/snappy/rebar.config.orig 2018-10-16 16:07:58.000000000 +0000
|
||||
+++ src/snappy/rebar.config
|
||||
@@ -1,4 +1,4 @@
|
||||
-{require_otp_vsn, "R14|R15|R16|17|18|19|20|21"}.
|
||||
+{require_otp_vsn, "R14|R15|R16|17|18|19|20|21|22"}.
|
||||
|
||||
{erl_opts, [debug_info, warn_unused_vars, warn_shadow_vars, warn_unused_import]}.
|
||||
{port_sources, ["c_src/*.cc",
|
Loading…
Reference in a new issue