add a patch for a libexif 0.6.x API change and depend on libexif-0.6.x
explicitely (refrain from bumping PKGREVISION - the pkg was just updated so ride on it)
This commit is contained in:
parent
25b7c0b707
commit
90b7d68a80
3 changed files with 19 additions and 2 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.38 2004/10/26 21:07:32 jmmv Exp $
|
||||
# $NetBSD: Makefile,v 1.39 2004/10/27 19:33:37 drochner Exp $
|
||||
#
|
||||
|
||||
DISTNAME= nautilus-2.8.1
|
||||
|
@ -25,6 +25,8 @@ CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR}
|
|||
|
||||
GCONF2_SCHEMAS= apps_nautilus_preferences.schemas
|
||||
|
||||
BUILDLINK_DEPENDS.libexif= libexif>=0.6.10
|
||||
|
||||
.include "../../audio/esound/buildlink3.mk"
|
||||
.include "../../devel/GConf2/schemas.mk"
|
||||
.include "../../devel/eel2/buildlink3.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.14 2004/10/26 21:07:32 jmmv Exp $
|
||||
$NetBSD: distinfo,v 1.15 2004/10/27 19:33:37 drochner Exp $
|
||||
|
||||
SHA1 (nautilus-2.8.1.tar.bz2) = 76ef92ee99365c56528b16ba5edf1f652edcc97f
|
||||
Size (nautilus-2.8.1.tar.bz2) = 5767420 bytes
|
||||
|
@ -7,3 +7,4 @@ SHA1 (patch-ae) = a67d8b7ba3a1b9a71958736ef4946be301e67124
|
|||
SHA1 (patch-af) = dbdfb1e7e2103a3174fddaccad64868781052057
|
||||
SHA1 (patch-ah) = 081da3e950f04573e136b6ed8c1ce0d057e803c5
|
||||
SHA1 (patch-ai) = fe69717dce315877966e7c4d394ddfdcfd379bde
|
||||
SHA1 (patch-aj) = 325018516f0d4566af893d0d88f00e055348c0a5
|
||||
|
|
14
sysutils/nautilus/patches/patch-aj
Normal file
14
sysutils/nautilus/patches/patch-aj
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-aj,v 1.1 2004/10/27 19:33:37 drochner Exp $
|
||||
|
||||
--- components/image_properties/nautilus-image-properties-view.c.orig 2004-10-11 20:22:21.000000000 +0200
|
||||
+++ components/image_properties/nautilus-image-properties-view.c
|
||||
@@ -130,7 +130,8 @@ exif_content_callback (ExifContent *cont
|
||||
return;
|
||||
}
|
||||
|
||||
- attribute->value = g_strdup (exif_content_get_value (content, attribute->tag));
|
||||
+ char value[1024];
|
||||
+ attribute->value = g_strdup (exif_content_get_value (content, attribute->tag, value, sizeof(value)));
|
||||
if (attribute->value != NULL) {
|
||||
attribute->found = TRUE;
|
||||
}
|
Loading…
Reference in a new issue