Update py-docutils to 0.8.1.
While here, * register egg-info. * switch to use external roman.py module. * set LICENSE. Release 0.8.1 (2011-08-30) ========================== * General: - Fix [ 3364658 ] (Change last file with Apache license to BSD-2-Clause) and [ 3395920 ] (correct copyright info for rst.el). * docutils/test/ - Apply [ 3303733 ] and [ 3365041 ] to fix tests under py3k. * docutils/writers/latex2e/__init__.py - Clean up Babel language setting. Restores Sphinx compatibility. Release 0.8 (2011-07-07) ======================== * General: - Handle language codes according to `BCP 47`_. - If the specified language is not supported by Docutils, warn and fall back to English. - Math support: reStructuredText "math" role and directive, ``math`` and ``math_block`` doctree elements. - Decode command line arguments with the locale's preferred encoding (to allow, e.g., ``--title=Dornröschen``). - Orphaned "python" reader and "newlatex2e" writer moved to the sandbox. - New sub-module `error_reporting`: handle encoding/decoding errors when reporting exceptions. - Some additions to the Docutils core are released under the 2-Clause BSD license, see COPYING_ for details. .. _BCP 47: http://www.rfc-editor.org/rfc/bcp/bcp47.txt .. _COPYING: COPYING.html * reStructuredText: - Most directives now support a "name" option that attaches a reference name. - Directive content may start on the first line also when the directive type accepts options. * docs/dev/policies.txt: - Recommend the 2-Clause BSD license (http://www.spdx.org/licenses/BSD-2-Clause) for code that is kept under the author's copyright. * tools/buildhtml.py: - Fix ``--local`` switch. * Fix [ 3018371 ] Added Lithuanian mappings by Dalius Dobravolskas. * docutils/writers/html4css1/__init__.py - Set "lang" argument for objects with class argument "language-<language tag>". - New setting "math-output" with support for HTML, MathML, and LaTeX. * docutils/writers/latex2e/__init__.py - Fix [ 3043986 ] AttributeError using :local: with table of content. - Place title data in the document preamble. - Load `babel` package only if required. - Update list of supported languages. - New config setting "hyperref-options". No hard-coded "unicode" hyperref option (clash with xetex). - Set language for custom roles, paragraphs, block-quotes, and line-quotes with class argument "language-<language tag>". - Fix [ 3095603 ] wrong quotes output for russian and other languages. - Convert image URI to a local file path. - Apply [ 3148141 ] fix multicolumn support when a colspanning cell has more than one paragraph (Wolfgang Scherer). - \leavevmode before longtable only when needed (prevents spurious vspace) - do not advance table counter for tables without caption * docutils/writers/xetex/__init__.py - New writer generating LaTeX code for compiling with ``xelatex``. A separate writer (inheriting from latex2e) instead of a ``--xetex`` option allows separate config options for XeTeX vs. LaTeX2e. * docutils/writers/manpage.py - Fix: BUG#3219183 - vertical space in definition lists containing markup. - Fix: vertical space cleaning for option group ``.``. * tools/editors/emacs/rst.el: - Fix [ 3001100 ] does not handle spaces in filenames (thanks to Jakub Wilk) * docutils/utils.py: - strip whitespace from stylesheet arguments - exclude combining chars from column_width (partial fix for [ 2926161 ]) * docutils/parsers/rst/directives/misc.py: - Fix [ 1830389 ] Replace not breaking on getting system_messages from nested_parse * docutils/io.py: - Do not close() sys.stdin, sys.stdout, or sys.stderr. Prevents ``Exception ValueError: 'I/O operation on closed file.'`` with Python 3.
This commit is contained in:
parent
222013e774
commit
90e826ac01
4 changed files with 37 additions and 61 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.31 2010/12/02 15:00:03 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.32 2011/10/05 07:47:28 obache Exp $
|
||||
|
||||
DISTNAME= docutils-0.7
|
||||
DISTNAME= docutils-0.8.1
|
||||
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
|
||||
CATEGORIES= textproc python
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=docutils/}
|
||||
|
@ -8,16 +8,11 @@ MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=docutils/}
|
|||
MAINTAINER= darcy@NetBSD.org
|
||||
HOMEPAGE= http://docutils.sourceforge.net/
|
||||
COMMENT= Python tool to generate documents
|
||||
LICENSE= public-domain AND 2-clause-bsd
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
PYDISTUTILSPKG= YES
|
||||
|
||||
.include "../../lang/python/extension.mk"
|
||||
|
||||
PLIST_VARS+= std
|
||||
.if !empty(PYVERSSUFFIX:M2*[12])
|
||||
PLIST.std= yes
|
||||
.endif
|
||||
DEPENDS+= ${PYPKGPREFIX}-roman>=1.4:../../math/py-roman
|
||||
|
||||
.include "../../lang/python/distutils.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,14 +1,15 @@
|
|||
@comment $NetBSD: PLIST,v 1.14 2009/10/31 03:00:27 wiz Exp $
|
||||
@comment $NetBSD: PLIST,v 1.15 2011/10/05 07:47:28 obache Exp $
|
||||
bin/rst2html.py
|
||||
bin/rst2latex.py
|
||||
bin/rst2man.py
|
||||
bin/rst2newlatex.py
|
||||
bin/rst2odt.py
|
||||
bin/rst2odt_prepstyles.py
|
||||
bin/rst2pseudoxml.py
|
||||
bin/rst2s5.py
|
||||
bin/rst2xetex.py
|
||||
bin/rst2xml.py
|
||||
bin/rstpep2html.py
|
||||
${PLIST.eggfile}${PYSITELIB}/${EGG_FILE}
|
||||
${PYSITELIB}/docutils/__init__.py
|
||||
${PYSITELIB}/docutils/__init__.pyc
|
||||
${PYSITELIB}/docutils/__init__.pyo
|
||||
|
@ -21,6 +22,9 @@ ${PYSITELIB}/docutils/_string_template_compat.pyo
|
|||
${PYSITELIB}/docutils/core.py
|
||||
${PYSITELIB}/docutils/core.pyc
|
||||
${PYSITELIB}/docutils/core.pyo
|
||||
${PYSITELIB}/docutils/error_reporting.py
|
||||
${PYSITELIB}/docutils/error_reporting.pyc
|
||||
${PYSITELIB}/docutils/error_reporting.pyo
|
||||
${PYSITELIB}/docutils/examples.py
|
||||
${PYSITELIB}/docutils/examples.pyc
|
||||
${PYSITELIB}/docutils/examples.pyo
|
||||
|
@ -72,6 +76,9 @@ ${PYSITELIB}/docutils/languages/it.pyo
|
|||
${PYSITELIB}/docutils/languages/ja.py
|
||||
${PYSITELIB}/docutils/languages/ja.pyc
|
||||
${PYSITELIB}/docutils/languages/ja.pyo
|
||||
${PYSITELIB}/docutils/languages/lt.py
|
||||
${PYSITELIB}/docutils/languages/lt.pyc
|
||||
${PYSITELIB}/docutils/languages/lt.pyo
|
||||
${PYSITELIB}/docutils/languages/nl.py
|
||||
${PYSITELIB}/docutils/languages/nl.pyc
|
||||
${PYSITELIB}/docutils/languages/nl.pyo
|
||||
|
@ -96,6 +103,18 @@ ${PYSITELIB}/docutils/languages/zh_cn.pyo
|
|||
${PYSITELIB}/docutils/languages/zh_tw.py
|
||||
${PYSITELIB}/docutils/languages/zh_tw.pyc
|
||||
${PYSITELIB}/docutils/languages/zh_tw.pyo
|
||||
${PYSITELIB}/docutils/math/__init__.py
|
||||
${PYSITELIB}/docutils/math/__init__.pyc
|
||||
${PYSITELIB}/docutils/math/__init__.pyo
|
||||
${PYSITELIB}/docutils/math/latex2mathml.py
|
||||
${PYSITELIB}/docutils/math/latex2mathml.pyc
|
||||
${PYSITELIB}/docutils/math/latex2mathml.pyo
|
||||
${PYSITELIB}/docutils/math/math2html.py
|
||||
${PYSITELIB}/docutils/math/math2html.pyc
|
||||
${PYSITELIB}/docutils/math/math2html.pyo
|
||||
${PYSITELIB}/docutils/math/unimathsymbols2tex.py
|
||||
${PYSITELIB}/docutils/math/unimathsymbols2tex.pyc
|
||||
${PYSITELIB}/docutils/math/unimathsymbols2tex.pyo
|
||||
${PYSITELIB}/docutils/nodes.py
|
||||
${PYSITELIB}/docutils/nodes.pyc
|
||||
${PYSITELIB}/docutils/nodes.pyo
|
||||
|
@ -211,6 +230,9 @@ ${PYSITELIB}/docutils/parsers/rst/languages/it.pyo
|
|||
${PYSITELIB}/docutils/parsers/rst/languages/ja.py
|
||||
${PYSITELIB}/docutils/parsers/rst/languages/ja.pyc
|
||||
${PYSITELIB}/docutils/parsers/rst/languages/ja.pyo
|
||||
${PYSITELIB}/docutils/parsers/rst/languages/lt.py
|
||||
${PYSITELIB}/docutils/parsers/rst/languages/lt.pyc
|
||||
${PYSITELIB}/docutils/parsers/rst/languages/lt.pyo
|
||||
${PYSITELIB}/docutils/parsers/rst/languages/nl.py
|
||||
${PYSITELIB}/docutils/parsers/rst/languages/nl.pyc
|
||||
${PYSITELIB}/docutils/parsers/rst/languages/nl.pyo
|
||||
|
@ -253,15 +275,6 @@ ${PYSITELIB}/docutils/readers/doctree.pyo
|
|||
${PYSITELIB}/docutils/readers/pep.py
|
||||
${PYSITELIB}/docutils/readers/pep.pyc
|
||||
${PYSITELIB}/docutils/readers/pep.pyo
|
||||
${PYSITELIB}/docutils/readers/python/__init__.py
|
||||
${PYSITELIB}/docutils/readers/python/__init__.pyc
|
||||
${PYSITELIB}/docutils/readers/python/__init__.pyo
|
||||
${PYSITELIB}/docutils/readers/python/moduleparser.py
|
||||
${PYSITELIB}/docutils/readers/python/moduleparser.pyc
|
||||
${PYSITELIB}/docutils/readers/python/moduleparser.pyo
|
||||
${PYSITELIB}/docutils/readers/python/pynodes.py
|
||||
${PYSITELIB}/docutils/readers/python/pynodes.pyc
|
||||
${PYSITELIB}/docutils/readers/python/pynodes.pyo
|
||||
${PYSITELIB}/docutils/readers/standalone.py
|
||||
${PYSITELIB}/docutils/readers/standalone.pyc
|
||||
${PYSITELIB}/docutils/readers/standalone.pyo
|
||||
|
@ -317,16 +330,10 @@ ${PYSITELIB}/docutils/writers/latex2e/__init__.pyc
|
|||
${PYSITELIB}/docutils/writers/latex2e/__init__.pyo
|
||||
${PYSITELIB}/docutils/writers/latex2e/default.tex
|
||||
${PYSITELIB}/docutils/writers/latex2e/titlepage.tex
|
||||
${PYSITELIB}/docutils/writers/latex2e/xelatex.tex
|
||||
${PYSITELIB}/docutils/writers/manpage.py
|
||||
${PYSITELIB}/docutils/writers/manpage.pyc
|
||||
${PYSITELIB}/docutils/writers/manpage.pyo
|
||||
${PYSITELIB}/docutils/writers/newlatex2e/__init__.py
|
||||
${PYSITELIB}/docutils/writers/newlatex2e/__init__.pyc
|
||||
${PYSITELIB}/docutils/writers/newlatex2e/__init__.pyo
|
||||
${PYSITELIB}/docutils/writers/newlatex2e/base.tex
|
||||
${PYSITELIB}/docutils/writers/newlatex2e/unicode_map.py
|
||||
${PYSITELIB}/docutils/writers/newlatex2e/unicode_map.pyc
|
||||
${PYSITELIB}/docutils/writers/newlatex2e/unicode_map.pyo
|
||||
${PYSITELIB}/docutils/writers/null.py
|
||||
${PYSITELIB}/docutils/writers/null.pyc
|
||||
${PYSITELIB}/docutils/writers/null.pyo
|
||||
|
@ -372,6 +379,6 @@ ${PYSITELIB}/docutils/writers/s5_html/themes/small-black/__base__
|
|||
${PYSITELIB}/docutils/writers/s5_html/themes/small-black/pretty.css
|
||||
${PYSITELIB}/docutils/writers/s5_html/themes/small-white/framing.css
|
||||
${PYSITELIB}/docutils/writers/s5_html/themes/small-white/pretty.css
|
||||
${PYSITELIB}/roman.py
|
||||
${PYSITELIB}/roman.pyc
|
||||
${PYSITELIB}/roman.pyo
|
||||
${PYSITELIB}/docutils/writers/xetex/__init__.py
|
||||
${PYSITELIB}/docutils/writers/xetex/__init__.pyc
|
||||
${PYSITELIB}/docutils/writers/xetex/__init__.pyo
|
||||
|
|
|
@ -1,6 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.12 2010/12/02 15:00:03 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.13 2011/10/05 07:47:28 obache Exp $
|
||||
|
||||
SHA1 (docutils-0.7.tar.gz) = e82988f826844ef8d8bf28fa286a19de211349cd
|
||||
RMD160 (docutils-0.7.tar.gz) = 73c832860405c3cba655c92aacccca1582c8f905
|
||||
Size (docutils-0.7.tar.gz) = 1404131 bytes
|
||||
SHA1 (patch-aa) = 85b585b0920c56210e2e50cc6b8dbb350704658c
|
||||
SHA1 (docutils-0.8.1.tar.gz) = 5c23bf94b46d5ad786dd6f278233d1f16c3047e8
|
||||
RMD160 (docutils-0.8.1.tar.gz) = 372abf9f47af11f0e63ae11f35f7db450097d960
|
||||
Size (docutils-0.8.1.tar.gz) = 1499832 bytes
|
||||
|
|
|
@ -1,25 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.3 2009/11/01 02:19:39 obache Exp $
|
||||
|
||||
Since the 'roman' module is unconditionally present in the PLIST,
|
||||
it must be unconditionally built and installed.
|
||||
(when building the py-docutils package while already having it installed,
|
||||
setup.py excluded the module, causing PLIST breakage with USE_DESTDIR=yes)
|
||||
|
||||
--- setup.py.orig 2009-10-05 19:08:10.000000000 +0000
|
||||
+++ setup.py
|
||||
@@ -174,13 +174,12 @@ classifiers = [
|
||||
"""Trove classifiers for the Distutils "register" command;
|
||||
Python 2.3 and up."""
|
||||
|
||||
-extra_modules = [('roman', '1.4', ['toRoman', 'fromRoman',
|
||||
- 'InvalidRomanNumeralError'])]
|
||||
+extra_modules = []
|
||||
"""Third-party modules to install if they're not already present.
|
||||
List of (module name, minimum __version__ string, [attribute names])."""
|
||||
|
||||
def get_extras():
|
||||
- extras = []
|
||||
+ extras = ['roman']
|
||||
for module_name, version, attributes in extra_modules:
|
||||
try:
|
||||
module = __import__(module_name)
|
Loading…
Reference in a new issue