Use c89; fix void main; preliminary LP64 fixes (a lot more likely required)
This commit is contained in:
parent
440f27ab30
commit
9105082fbf
9 changed files with 240 additions and 15 deletions
|
@ -1,11 +1,11 @@
|
|||
$NetBSD: distinfo,v 1.5 2006/09/02 20:47:03 rillig Exp $
|
||||
$NetBSD: distinfo,v 1.6 2013/04/14 00:15:27 dholland Exp $
|
||||
|
||||
SHA1 (vcg.1.30.r3.17.tgz) = 03a821b4a0bd9c5584d34882b167672868fe723d
|
||||
RMD160 (vcg.1.30.r3.17.tgz) = 4df7ce2ff7d5de253f9e851194a703d64ed4cdc3
|
||||
Size (vcg.1.30.r3.17.tgz) = 1429486 bytes
|
||||
SHA1 (patch-aa) = b22f4df0a74ae3f970780a514c43a8c23e04163e
|
||||
SHA1 (patch-ab) = 26610ed150bef2ec69e3324fc9a2e44e50543978
|
||||
SHA1 (patch-ac) = 980efa1bca8d5a21facb917c346b2b55e169c836
|
||||
SHA1 (patch-ac) = 3cda9b0ab98750c1dab1e7308f4f07f4820936e5
|
||||
SHA1 (patch-ad) = cbde5f2486927cfdd48632473df1599ae9eac31e
|
||||
SHA1 (patch-ae) = 3ac50f38ba013df290634e9a7a669a3c467eda44
|
||||
SHA1 (patch-af) = a49ed3044ba017a151c0cbb8a1766358f1a95153
|
||||
|
@ -20,3 +20,8 @@ SHA1 (patch-an) = 593e624ddbc15869c146dfc6824126b8016527e9
|
|||
SHA1 (patch-ao) = ef65b3ce1121b6dbe478c98cec7a26e11e1e8539
|
||||
SHA1 (patch-ap) = f439d09a321768ecf9988b77aa1ac28b4c3a0ad7
|
||||
SHA1 (patch-aq) = f9a5465d932c1264b2cf3fb1bf734f9363f64650
|
||||
SHA1 (patch-demo_animation1_c) = 38feda7060648920be7d372a4c62ed819676ceeb
|
||||
SHA1 (patch-demo_animation2_c) = 1073161550bc48ad33cd14d5493198eac0295e11
|
||||
SHA1 (patch-demo_animation3_c) = fdce029f72cd8edc64633ac31beddabeba722fbd
|
||||
SHA1 (patch-demo_vcgcount_c) = 0ae39c7a6b14b656734264502bd3d617222d9d46
|
||||
SHA1 (patch-preconf_X11ccSunOS_conf) = 04fba7328b57ee04f16312c404840e99d5cf3c96
|
||||
|
|
|
@ -2,7 +2,7 @@ ADDINCLUDEPATHNAME|-I/usr/X11R6/include/
|
|||
ADDLIBPATHNAME|-L/usr/X11R6/lib/
|
||||
ADDLIBSNAME|-lXext -lX11 -lm
|
||||
ALIGNMENTNAME|8
|
||||
ANSINAME|#undef ANSI_C
|
||||
ANSINAME|#define ANSI_C
|
||||
BIGLTEXNAME|not_available
|
||||
BINPATHNAME|/usr/X11R6/bin
|
||||
BISONNAME|not_available
|
||||
|
|
|
@ -17,7 +17,7 @@
|
|||
/* */
|
||||
/*--------------------------------------------------------------------*/
|
||||
|
||||
/* $NetBSD: globals.h,v 1.3 1999/06/13 13:06:08 sakamoto Exp $ */
|
||||
/* $NetBSD: globals.h,v 1.4 2013/04/14 00:15:27 dholland Exp $ */
|
||||
/* FreeBSD Id: globals.h,v 1.1.1.1 1995/02/19 09:25:43 hsu Exp $ */
|
||||
|
||||
/*
|
||||
|
@ -43,13 +43,17 @@
|
|||
*/
|
||||
|
||||
|
||||
/* $Log: globals.h,v $
|
||||
/* Revision 1.3 1999/06/13 13:06:08 sakamoto
|
||||
/* Fix FreeBSD RCS Id,Log.
|
||||
/*
|
||||
/* Revision 1.2 1999/06/13 12:54:19 sakamoto
|
||||
/* Adapt this package to NetBSD.
|
||||
/*
|
||||
* $Log: globals.h,v $
|
||||
* Revision 1.4 2013/04/14 00:15:27 dholland
|
||||
* Use c89; fix void main; preliminary LP64 fixes (a lot more likely required)
|
||||
*
|
||||
* Revision 1.3 1999/06/13 13:06:08 sakamoto
|
||||
* Fix FreeBSD RCS Id,Log.
|
||||
*
|
||||
* Revision 1.2 1999/06/13 12:54:19 sakamoto
|
||||
* Adapt this package to NetBSD.
|
||||
*
|
||||
* Revision 1.1.1.1 1995/02/19 09:25:43 hsu
|
||||
* vcg - a visualization tool for compiler graphs
|
||||
*
|
||||
|
|
|
@ -1,8 +1,11 @@
|
|||
$NetBSD: patch-ac,v 1.2 1999/06/13 12:54:19 sakamoto Exp $
|
||||
$NetBSD: patch-ac,v 1.3 2013/04/14 00:15:27 dholland Exp $
|
||||
|
||||
--- 1.1 1995/02/18 17:07:16
|
||||
+++ src/preconf/y.tab.c 1995/02/18 17:20:13
|
||||
@@ -446,7 +446,7 @@
|
||||
- use standard headers
|
||||
- use <ctype.h> functions correctly
|
||||
|
||||
--- src/preconf/y.tab.c.orig 1995-02-08 18:40:18.000000000 +0000
|
||||
+++ src/preconf/y.tab.c
|
||||
@@ -443,7 +443,7 @@ extern YY_CHAR *yytext;
|
||||
|
||||
#ifndef YY_MALLOC_DECL
|
||||
#define YY_MALLOC_DECL
|
||||
|
@ -11,7 +14,29 @@ $NetBSD: patch-ac,v 1.2 1999/06/13 12:54:19 sakamoto Exp $
|
|||
#endif
|
||||
|
||||
#undef YYVALGLOBAL
|
||||
@@ -5815,7 +5815,7 @@
|
||||
@@ -5755,8 +5755,8 @@ char *mesge;
|
||||
#endif
|
||||
{
|
||||
strcpy(myprivmessage,mesge);
|
||||
- if (islower(*myprivmessage))
|
||||
- *myprivmessage = toupper(*myprivmessage);
|
||||
+ if (islower((unsigned char)*myprivmessage))
|
||||
+ *myprivmessage = toupper((unsigned char)*myprivmessage);
|
||||
FPRINTF(stderr,"Syntax error (%s: l:%d p:%d): %s !\n",
|
||||
filename,line,pos,myprivmessage);
|
||||
nr_errors++;
|
||||
@@ -5781,8 +5781,8 @@ char *mesge;
|
||||
#endif
|
||||
{
|
||||
strcpy(myprivmessage,mesge);
|
||||
- if (islower(*myprivmessage))
|
||||
- *myprivmessage = toupper(*myprivmessage);
|
||||
+ if (islower((unsigned char)*myprivmessage))
|
||||
+ *myprivmessage = toupper((unsigned char)*myprivmessage);
|
||||
FPRINTF(stderr,"Warning (%s: l:%d p:%d): %s !\n",
|
||||
filename,line,pos,myprivmessage);
|
||||
}
|
||||
@@ -5812,7 +5812,7 @@ static char *stdpc_id_string="$Id: stdpc
|
||||
|
||||
|
||||
#include <stdio.h>
|
||||
|
|
24
graphics/vcg/patches/patch-demo_animation1_c
Normal file
24
graphics/vcg/patches/patch-demo_animation1_c
Normal file
|
@ -0,0 +1,24 @@
|
|||
$NetBSD: patch-demo_animation1_c,v 1.1 2013/04/14 00:15:27 dholland Exp $
|
||||
|
||||
- use standard headers
|
||||
- call execl correctly
|
||||
|
||||
--- demo/animation1.c~ 1995-02-08 11:27:32.000000000 +0000
|
||||
+++ demo/animation1.c
|
||||
@@ -80,6 +80,7 @@
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
#include <signal.h>
|
||||
+#include <unistd.h>
|
||||
#include <sys/types.h>
|
||||
#include <sys/stat.h>
|
||||
#include "../src/globals.h"
|
||||
@@ -228,7 +229,7 @@ void call_vcg()
|
||||
#ifdef X11
|
||||
"-geometry","200x200-30+30",
|
||||
#endif
|
||||
- filename,0L);
|
||||
+ filename, (char *)NULL);
|
||||
}
|
||||
/* NEVER REACHED */
|
||||
|
24
graphics/vcg/patches/patch-demo_animation2_c
Normal file
24
graphics/vcg/patches/patch-demo_animation2_c
Normal file
|
@ -0,0 +1,24 @@
|
|||
$NetBSD: patch-demo_animation2_c,v 1.1 2013/04/14 00:15:27 dholland Exp $
|
||||
|
||||
- use standard headers
|
||||
- call execl correctly
|
||||
|
||||
--- demo/animation2.c~ 1995-02-08 11:27:33.000000000 +0000
|
||||
+++ demo/animation2.c
|
||||
@@ -83,6 +83,7 @@
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
#include <signal.h>
|
||||
+#include <unistd.h>
|
||||
#include "../src/globals.h"
|
||||
|
||||
|
||||
@@ -237,7 +238,7 @@ void call_vcg()
|
||||
#ifdef X11
|
||||
"-geometry","200x200-30+30",
|
||||
#endif
|
||||
- filename,0L);
|
||||
+ filename, (char *)NULL);
|
||||
}
|
||||
/* NEVER REACHED */
|
||||
|
92
graphics/vcg/patches/patch-demo_animation3_c
Normal file
92
graphics/vcg/patches/patch-demo_animation3_c
Normal file
|
@ -0,0 +1,92 @@
|
|||
$NetBSD: patch-demo_animation3_c,v 1.1 2013/04/14 00:15:27 dholland Exp $
|
||||
|
||||
- fix void main
|
||||
- print pointers correctly (use %jd rather than %p as it appears they
|
||||
need to print in decimal)
|
||||
- call execl() correctly
|
||||
|
||||
--- demo/animation3.c.orig 1995-02-08 18:54:17.000000000 +0000
|
||||
+++ demo/animation3.c
|
||||
@@ -69,16 +69,19 @@
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
#include <signal.h>
|
||||
+#include <unistd.h>
|
||||
+#include <stdint.h>
|
||||
#include <sys/types.h>
|
||||
#include <sys/stat.h>
|
||||
#include "../src/globals.h"
|
||||
|
||||
+#define PRINTPTR(n) ((intmax_t)(intptr_t)n)
|
||||
|
||||
/* Prototypes
|
||||
* ----------
|
||||
*/
|
||||
|
||||
-void main _PP((int argc, char *argv[]));
|
||||
+int main _PP((int argc, char *argv[]));
|
||||
void call_vcg _PP((void));
|
||||
void signal_vcg _PP((int k));
|
||||
void wait_for_vcg _PP((void));
|
||||
@@ -132,9 +135,9 @@ int ins[15] = {
|
||||
char timep[20] = "1";
|
||||
|
||||
#ifdef ANSI_C
|
||||
-void main(int argc, char *argv[])
|
||||
+int main(int argc, char *argv[])
|
||||
#else
|
||||
-void main(argc, argv)
|
||||
+int main(argc, argv)
|
||||
int argc;
|
||||
char *argv[];
|
||||
#endif
|
||||
@@ -172,6 +175,7 @@ char *argv[];
|
||||
signal_vcg(- SIGUSR2); /* close vcg (does not work with X11) */
|
||||
sleep(3);
|
||||
signal_vcg(- SIGQUIT); /* exit vcg */
|
||||
+ return 0;
|
||||
}
|
||||
|
||||
|
||||
@@ -224,7 +228,7 @@ void call_vcg()
|
||||
#ifdef X11
|
||||
"-geometry","200x200-30+30",
|
||||
#endif
|
||||
- filename,0L);
|
||||
+ filename, (char *)NULL);
|
||||
}
|
||||
/* NEVER REACHED */
|
||||
|
||||
@@ -762,8 +766,8 @@ NODE n;
|
||||
int i;
|
||||
#endif
|
||||
{
|
||||
- FPRINTF(f," node: { title: \"%d\" label: \"%d\" ",
|
||||
- n, n->num);
|
||||
+ FPRINTF(f," node: { title: \"%jd\" label: \"%d\" ",
|
||||
+ PRINTPTR(n), n->num);
|
||||
FPRINTF(f,"width: 34 ");
|
||||
FPRINTF(f,"height: 34 ");
|
||||
|
||||
@@ -797,8 +801,8 @@ int i;
|
||||
if (n->sons==2) {
|
||||
print_node(f,n->son[0], 0);
|
||||
|
||||
- FPRINTF(f," edge: { sourcename: \"%d\" ", n);
|
||||
- FPRINTF(f,"targetname: \"%d\" ", n->son[0]);
|
||||
+ FPRINTF(f," edge: { sourcename: \"%jd\" ", PRINTPTR(n));
|
||||
+ FPRINTF(f,"targetname: \"%jd\" ", PRINTPTR(n->son[0]));
|
||||
if ((n->son[0])->col == RED) {
|
||||
FPRINTF(f,"color: red ");
|
||||
FPRINTF(f,"linestyle: dotted ");
|
||||
@@ -810,8 +814,8 @@ int i;
|
||||
|
||||
print_node(f,n->son[1], 1);
|
||||
|
||||
- FPRINTF(f," edge: { sourcename: \"%d\" ", n);
|
||||
- FPRINTF(f,"targetname: \"%d\" ", n->son[1]);
|
||||
+ FPRINTF(f," edge: { sourcename: \"%jd\" ", PRINTPTR(n));
|
||||
+ FPRINTF(f,"targetname: \"%jd\" ", PRINTPTR(n->son[1]));
|
||||
if ((n->son[1])->col == RED) {
|
||||
FPRINTF(f,"color: red ");
|
||||
FPRINTF(f,"linestyle: dotted ");
|
35
graphics/vcg/patches/patch-demo_vcgcount_c
Normal file
35
graphics/vcg/patches/patch-demo_vcgcount_c
Normal file
|
@ -0,0 +1,35 @@
|
|||
$NetBSD: patch-demo_vcgcount_c,v 1.1 2013/04/14 00:15:27 dholland Exp $
|
||||
|
||||
- fix void main
|
||||
|
||||
--- demo/vcgcount.c~ 1995-02-08 11:27:34.000000000 +0000
|
||||
+++ demo/vcgcount.c
|
||||
@@ -64,7 +64,7 @@
|
||||
* ----------
|
||||
*/
|
||||
|
||||
-void main _PP((void));
|
||||
+int main _PP((void));
|
||||
|
||||
|
||||
|
||||
@@ -85,9 +85,9 @@ int nredges; /* The number of edges
|
||||
*/
|
||||
|
||||
#ifdef ANSI_C
|
||||
-void main(void)
|
||||
+int main(void)
|
||||
#else
|
||||
-void main()
|
||||
+int main()
|
||||
#endif
|
||||
{
|
||||
register char *c;
|
||||
@@ -120,6 +120,7 @@ void main()
|
||||
}
|
||||
PRINTF("This graph contains %d nodes and %d edges.\n",
|
||||
nrnodes, nredges);
|
||||
+ return 0;
|
||||
}
|
||||
|
||||
|
16
graphics/vcg/patches/patch-preconf_X11ccSunOS_conf
Normal file
16
graphics/vcg/patches/patch-preconf_X11ccSunOS_conf
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-preconf_X11ccSunOS_conf,v 1.1 2013/04/14 00:15:27 dholland Exp $
|
||||
|
||||
Fix Sun CC configuration to assume at least C89. Otherwise it tries to
|
||||
use <varargs.h> and fails.
|
||||
|
||||
--- preconf/X11ccSunOS/conf~ 1995-02-08 19:48:39.000000000 +0000
|
||||
+++ preconf/X11ccSunOS/conf
|
||||
@@ -2,7 +2,7 @@ ADDINCLUDEPATHNAME|-I/RW/esprit/X11R5/R6
|
||||
ADDLIBPATHNAME|-L/RW/esprit/X11R5/R6/lib/
|
||||
ADDLIBSNAME|-lXext -lX11 -lm
|
||||
ALIGNMENTNAME|8
|
||||
-ANSINAME|#undef ANSI_C
|
||||
+ANSINAME|#define ANSI_C
|
||||
BIGLTEXNAME|big-latex
|
||||
BINPATHNAME|/usr/local/bin/
|
||||
BISONNAME|not_available
|
Loading…
Reference in a new issue