libetonyek: update to 0.1.10.
libetonyek 0.1.10 - All formats: + Parse shadow. + Improve detection of the "new" formats. (tdf#123571) + Fix handling of text baseline shift. - Keynote 6+: + Parse layout properties of textboxes. + Improve handling of colors. + Parse bullet images. + Fix handling of line stroke. + Avoid adding superfluous empty lines. + Parse image masks. + Improve parsing of shape groups. + Handle fit-to-size in text boxes. - Numbers 1-2: + Improve parsing of range addresses. + Parse textboxes. + Parse images. + Handle grouped shapes. + Parse cell comments. + Create a special graphic sheet if needed. + Parse sticky notes. - Numbers 3+: + Parse formulas. + Parse cell formats. + Parse sheet references. + Parse cell comments. + Parse shapes (including groups). + Improve parsing of bezier paths. + Parse sticky notes. + Improve handling of colors. + Parse bullet images. + Parse image masks. + Handle fit-to-size in text boxes. - Pages 1-4: + Handle text boxes attached as character. - Pages 5+: + Improve handling of colors. + Parse bullet images. + Process page headers and footers even if the document is empty. + Fix handling of line stroke. + Parse image masks. + Improve parsing of shape groups. + Handle text boxes attached as character. + Parse page background. + Handle fit-to-size in text boxes.
This commit is contained in:
parent
65af29453e
commit
912404ac90
3 changed files with 8 additions and 28 deletions
|
@ -1,7 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.33 2021/04/21 13:24:07 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.34 2021/05/31 10:42:57 wiz Exp $
|
||||
|
||||
DISTNAME= libetonyek-0.1.9
|
||||
PKGREVISION= 10
|
||||
DISTNAME= libetonyek-0.1.10
|
||||
CATEGORIES= converters
|
||||
MASTER_SITES= http://dev-www.libreoffice.org/src/
|
||||
EXTRACT_SUFX= .tar.xz
|
||||
|
@ -27,7 +26,7 @@ PKGCONFIG_OVERRIDE+= libetonyek.pc.in
|
|||
.include "../../converters/libwpd/buildlink3.mk"
|
||||
.include "../../converters/librevenge/buildlink3.mk"
|
||||
.include "../../devel/boost-libs/buildlink3.mk"
|
||||
.include "../../devel/mdds1.2/buildlink3.mk"
|
||||
.include "../../devel/mdds/buildlink3.mk"
|
||||
.include "../../devel/zlib/buildlink3.mk"
|
||||
.include "../../graphics/glm/buildlink3.mk"
|
||||
.include "../../textproc/libxml2/buildlink3.mk"
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.9 2020/05/17 21:45:51 rillig Exp $
|
||||
$NetBSD: distinfo,v 1.10 2021/05/31 10:42:57 wiz Exp $
|
||||
|
||||
SHA1 (libetonyek-0.1.9.tar.xz) = b98862359b44f6838246428a482c442ad3bb67e4
|
||||
RMD160 (libetonyek-0.1.9.tar.xz) = 05769e91a32fca98060a753ec265e54e9dcf0b6d
|
||||
SHA512 (libetonyek-0.1.9.tar.xz) = 3f439b369d450bb1a4bdb3fe92023bda234b323cf676570f1738318c56867a97910f536280b9b164c3fdaa423a3ee669c935df75a5c700bc1530ea5b9a00391e
|
||||
Size (libetonyek-0.1.9.tar.xz) = 1477064 bytes
|
||||
SHA1 (patch-src_lib_NUM3Parser.cpp) = e5cabaa4a4c776fc65d1988fc7ad064fb426470d
|
||||
SHA1 (libetonyek-0.1.10.tar.xz) = d0dc3fac41b56edaf3ac528ec274aa07357f989b
|
||||
RMD160 (libetonyek-0.1.10.tar.xz) = 24c5deb1f04cc5f961243c712cde11e3d58e41b3
|
||||
SHA512 (libetonyek-0.1.10.tar.xz) = 516a14fcb7b7b5898484a4263d593a036ac728b90144da9d1c22a5d0fdffc879839e19a7b390f99d924c390d433e64433fb08939b1e04ca24359315571c5772b
|
||||
Size (libetonyek-0.1.10.tar.xz) = 1494000 bytes
|
||||
|
|
|
@ -1,18 +0,0 @@
|
|||
$NetBSD: patch-src_lib_NUM3Parser.cpp,v 1.1 2020/05/17 21:45:51 rillig Exp $
|
||||
|
||||
NUM3Parser.cpp: In member function 'virtual bool libetonyek::NUM3Parser::parseDocument()':
|
||||
NUM3Parser.cpp:46:3: error: 'for_each' is not a member of 'std'
|
||||
std::for_each(sheetListRefs.begin(), sheetListRefs.end(), std::bind(&NUM3Parser::parseSheet, this, std::placeholders::_1));
|
||||
|
||||
https://lists.freedesktop.org/archives/libreoffice/2020-May/date.html
|
||||
|
||||
--- src/lib/NUM3Parser.cpp.orig 2018-12-28 17:45:35.000000000 +0000
|
||||
+++ src/lib/NUM3Parser.cpp
|
||||
@@ -7,6 +7,7 @@
|
||||
* file, You can obtain one at http://mozilla.org/MPL/2.0/.
|
||||
*/
|
||||
|
||||
+#include <algorithm>
|
||||
#include <functional>
|
||||
|
||||
#include "NUM3Parser.h"
|
Loading…
Reference in a new issue