Try fixing the SunOS build, from Ingo Schwarze (upstream).

This commit is contained in:
wiz 2013-10-06 15:48:42 +00:00
parent 1b6e9e57c8
commit 9155022522
4 changed files with 81 additions and 1 deletions

View file

@ -1,8 +1,11 @@
$NetBSD: distinfo,v 1.28 2013/10/05 14:48:15 wiz Exp $
$NetBSD: distinfo,v 1.29 2013/10/06 15:48:42 wiz Exp $
SHA1 (mdocml-1.12.2.tar.gz) = 6a86cc4f373bcc51aa8bf1a7499db368e977a166
RMD160 (mdocml-1.12.2.tar.gz) = 8fcd1b9dd20b3a2eee9412d210e1b994c9ae7c17
Size (mdocml-1.12.2.tar.gz) = 286400 bytes
SHA1 (patch-Makefile) = 30ae6393f1af5995735fb98c9bbfa53f22cdc0a8
SHA1 (patch-apropos__db.c) = fa26351e17a465dd1b89854903f3c04408440d47
SHA1 (patch-config.h.post) = 23b57b1c20e02733a12acbe7a62c5113cc245ecd
SHA1 (patch-mandocdb.c) = 6c376bff856ab48f16721e589e71ce7b981a802b
SHA1 (patch-preconv.1) = 92787c58f451e1d247a25bbe136f188bf42e4c73
SHA1 (patch-roff.7) = a8daeae7e8e6c0117d499fb0c4a848d724b29b3e

View file

@ -0,0 +1,29 @@
$NetBSD: patch-apropos__db.c,v 1.1 2013/10/06 15:48:42 wiz Exp $
--- apropos_db.c.orig 2013-10-05 14:09:07.000000000 +0000
+++ apropos_db.c
@@ -30,14 +30,19 @@
#include <string.h>
#include <unistd.h>
-#if defined(__linux__)
-# include <endian.h>
-# include <db_185.h>
-#elif defined(__APPLE__)
+#if defined(__APPLE__)
# include <libkern/OSByteOrder.h>
-# include <db.h>
+#elif defined(__linux__)
+# include <endian.h>
+#elif defined(__sun)
+# include <sys/byteorder.h>
#else
# include <sys/endian.h>
+#endif
+
+#if defined(__linux__)
+# include <db_185.h>
+#else
# include <db.h>
#endif

View file

@ -0,0 +1,14 @@
$NetBSD: patch-config.h.post,v 1.1 2013/10/06 15:48:42 wiz Exp $
--- config.h.post.orig 2013-10-05 14:09:07.000000000 +0000
+++ config.h.post
@@ -19,6 +19,9 @@
# if defined(__APPLE__)
# define betoh64(x) OSSwapBigToHostInt64(x)
# define htobe64(x) OSSwapHostToBigInt64(x)
+# elif defined(__sun)
+# define betoh64(x) BE_64(x)
+# define htobe64(x) BE_64(x)
# else
# define betoh64(x) be64toh(x)
# endif

View file

@ -0,0 +1,34 @@
$NetBSD: patch-mandocdb.c,v 1.4 2013/10/06 15:48:42 wiz Exp $
--- mandocdb.c.orig 2013-10-05 14:09:07.000000000 +0000
+++ mandocdb.c
@@ -34,19 +34,21 @@
#include <string.h>
#include <unistd.h>
-#if defined(__linux__) || defined(__sun)
-# include <endian.h>
-# include <db_185.h>
-#elif defined(__APPLE__)
+#if defined(__APPLE__)
# include <libkern/OSByteOrder.h>
-# include <db.h>
+#elif defined(__linux__)
+# include <endian.h>
+#elif defined(__sun)
+# include <sys/byteorder.h>
+# include <sys/stat.h>
#else
# include <sys/endian.h>
-# include <db.h>
#endif
-#if defined(__sun)
-#include <sys/stat.h>
+#if defined(__linux__)
+# include <db_185.h>
+#else
+# include <db.h>
#endif
#include "man.h"