Update guile-slib and slib to version 2.4.2 (slib-2d2). Changes from
version 2c8 include: New initialization files for DrScheme, Guile, and Scheme48-0.57. New modules: coerce.scm (implementation of Common Lisp coerce and type-of), differ.scm (O(NP) sequence comparison algorithm), http-cgi.scm (Service HTTP and CGI requests), pnm.scm (Read PNM image files), simetrix.scm (SI metric interchange format), srfi-1.scm, srfi.scm, and uri.scm (the URI functions from db2html.scm and some new ones). scmactst.scm, struct.scm, and structst.scm were removed due to lack of license. Package update provided by Eric Gillespie Jr. <epg@trantor.pretzelnet.org> in pkg/14008.
This commit is contained in:
parent
1b942a2177
commit
9168868b3f
5 changed files with 25 additions and 29 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.4 2001/02/16 14:38:30 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.5 2001/10/03 09:08:37 jlam Exp $
|
||||
|
||||
DISTNAME= guile-slib-2c8
|
||||
DISTNAME= guile-slib-2.4.2
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= # empty
|
||||
DISTFILES= # empty
|
||||
|
@ -10,11 +10,10 @@ HOMEPAGE= http://swissnet.ai.mit.edu/~jaffer/SLIB.html
|
|||
COMMENT= SLIB installation for guile Scheme interpreter
|
||||
|
||||
DEPENDS+= guile>=1.3.2:../../lang/guile
|
||||
DEPENDS+= slib-2c8:../../devel/slib
|
||||
DEPENDS+= slib-${PKGVERSION}:../../devel/slib
|
||||
|
||||
EXTRACT_ONLY= # empty
|
||||
NO_CHECKSUM= yes
|
||||
NO_CONFIGURE= yes
|
||||
NO_BUILD= yes
|
||||
|
||||
do-install:
|
||||
|
|
|
@ -1,7 +1,11 @@
|
|||
# $NetBSD: Makefile,v 1.4 2001/02/16 14:39:03 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.5 2001/10/03 09:08:38 jlam Exp $
|
||||
|
||||
DISTNAME= slib2c8
|
||||
PKGNAME= slib-2c8
|
||||
DISTNAME= slib2d2
|
||||
#
|
||||
# Convert the version number as follows 2d2 -> 2.4.2, where the d is
|
||||
# changed to a 4, representing the 4th letter.
|
||||
#
|
||||
PKGNAME= slib-2.4.2
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://swissnet.ai.mit.edu/ftpdir/scm/ \
|
||||
${MASTER_SITE_GNU:=jacal/}
|
||||
|
@ -11,7 +15,6 @@ MAINTAINER= jlam@netbsd.org
|
|||
HOMEPAGE= http://swissnet.ai.mit.edu/~jaffer/SLIB.html
|
||||
COMMENT= portable Scheme library of compatibility and utility functions
|
||||
|
||||
NO_CONFIGURE= # defined
|
||||
NO_BUILD= # defined
|
||||
WRKSRC= ${WRKDIR}/slib
|
||||
|
||||
|
|
|
@ -1,5 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.2 2001/04/21 00:44:46 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.3 2001/10/03 09:08:38 jlam Exp $
|
||||
|
||||
SHA1 (slib2c8.zip) = 84bd4a0d5f489bd5f81d9c591f5a6158a9b90f65
|
||||
Size (slib2c8.zip) = 567803 bytes
|
||||
SHA1 (patch-aa) = 272923dcaed2dcc0fae75fd523cfb40edeab1762
|
||||
SHA1 (slib2d2.zip) = 74df5b1d45d9e4f24521ddd687210c1964d2b483
|
||||
Size (slib2d2.zip) = 627968 bytes
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2000/02/23 20:20:45 jlam Exp $
|
||||
|
||||
--- require.scm.orig Sun Dec 5 19:54:37 1999
|
||||
+++ require.scm Wed Feb 23 14:49:52 2000
|
||||
@@ -126,7 +126,7 @@
|
||||
(if (not *catalog*)
|
||||
(let ((slibcat (catalog:try-read (implementation-vicinity) "slibcat")))
|
||||
(cond ((not (catalog/require-version-match? slibcat))
|
||||
- (slib:load (in-vicinity (library-vicinity) "mklibcat"))
|
||||
+ (slib:load (in-vicinity (library-vicinity) "mklibcat.scm"))
|
||||
(set! slibcat
|
||||
(catalog:try-read (implementation-vicinity) "slibcat"))))
|
||||
(cond (slibcat
|
|
@ -1,10 +1,11 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2000/06/21 05:58:34 jlam Exp $
|
||||
@comment $NetBSD: PLIST,v 1.3 2001/10/03 09:08:39 jlam Exp $
|
||||
@unexec install-info --delete %D/info/slib.info %D/info/dir
|
||||
info/slib.info
|
||||
@exec install-info %D/info/slib.info %D/info/dir
|
||||
share/doc/slib/FAQ
|
||||
share/doc/slib/README
|
||||
share/slib/Bev2slib.scm
|
||||
share/slib/DrScheme.init
|
||||
share/slib/RScheme.init
|
||||
share/slib/STk.init
|
||||
share/slib/Template.scm
|
||||
|
@ -20,6 +21,7 @@ share/slib/chap.scm
|
|||
share/slib/charplot.scm
|
||||
share/slib/chez.init
|
||||
share/slib/cltime.scm
|
||||
share/slib/coerce.scm
|
||||
share/slib/collect.scm
|
||||
share/slib/comlist.scm
|
||||
share/slib/comparse.scm
|
||||
|
@ -30,6 +32,7 @@ share/slib/dbutil.scm
|
|||
share/slib/debug.scm
|
||||
share/slib/defmacex.scm
|
||||
share/slib/determ.scm
|
||||
share/slib/differ.scm
|
||||
share/slib/dwindtst.scm
|
||||
share/slib/dynamic.scm
|
||||
share/slib/dynwind.scm
|
||||
|
@ -45,9 +48,11 @@ share/slib/genwrite.scm
|
|||
share/slib/getopt.scm
|
||||
share/slib/getparam.scm
|
||||
share/slib/glob.scm
|
||||
share/slib/guile.init
|
||||
share/slib/hash.scm
|
||||
share/slib/hashtab.scm
|
||||
share/slib/htmlform.scm
|
||||
share/slib/http-cgi.scm
|
||||
share/slib/lineio.scm
|
||||
share/slib/logical.scm
|
||||
share/slib/macrotst.scm
|
||||
|
@ -69,6 +74,7 @@ share/slib/obj2str.scm
|
|||
share/slib/object.scm
|
||||
share/slib/paramlst.scm
|
||||
share/slib/plottest.scm
|
||||
share/slib/pnm.scm
|
||||
share/slib/pp.scm
|
||||
share/slib/ppfile.scm
|
||||
share/slib/prec.scm
|
||||
|
@ -91,6 +97,7 @@ share/slib/repl.scm
|
|||
share/slib/report.scm
|
||||
share/slib/require.scm
|
||||
share/slib/root.scm
|
||||
share/slib/s48-0_57.init
|
||||
share/slib/sc2.scm
|
||||
share/slib/sc4opt.scm
|
||||
share/slib/sc4sc3.scm
|
||||
|
@ -105,18 +112,18 @@ share/slib/scheme48.init
|
|||
share/slib/schmooz.scm
|
||||
share/slib/scm.init
|
||||
share/slib/scmacro.scm
|
||||
share/slib/scmactst.scm
|
||||
share/slib/scsh.init
|
||||
share/slib/selfset.scm
|
||||
share/slib/sierpinski.scm
|
||||
share/slib/simetrix.scm
|
||||
share/slib/sort.scm
|
||||
share/slib/soundex.scm
|
||||
share/slib/srfi-1.scm
|
||||
share/slib/srfi.scm
|
||||
share/slib/stdio.scm
|
||||
share/slib/strcase.scm
|
||||
share/slib/strport.scm
|
||||
share/slib/strsrch.scm
|
||||
share/slib/struct.scm
|
||||
share/slib/structst.scm
|
||||
share/slib/structure.scm
|
||||
share/slib/synchk.scm
|
||||
share/slib/synclo.scm
|
||||
|
@ -131,6 +138,7 @@ share/slib/trnscrpt.scm
|
|||
share/slib/tsort.scm
|
||||
share/slib/tzfile.scm
|
||||
share/slib/umbscheme.init
|
||||
share/slib/uri.scm
|
||||
share/slib/values.scm
|
||||
share/slib/vscm.init
|
||||
share/slib/withfile.scm
|
||||
|
|
Loading…
Reference in a new issue