Patch provided by PR pkg/48911

applied for Emacs24-24.4.50 and Emacs25-25.0.50
This commit is contained in:
mef 2014-11-23 06:13:37 +00:00
parent 6dbd6b4030
commit 9190b93ce9
6 changed files with 77 additions and 2 deletions

View file

@ -1,8 +1,9 @@
# $NetBSD: Makefile,v 1.24 2013/04/08 07:37:46 mef Exp $
# $NetBSD: Makefile,v 1.25 2014/11/23 06:13:37 mef Exp $
#
DISTNAME= riece-9.0.0
PKGNAME= ${EMACS_PKGNAME_PREFIX}${DISTNAME}
PKGREVISION= 1
CATEGORIES= chat japanese
MASTER_SITES= http://download.savannah.gnu.org/releases/riece/
LICENSE= gnu-gpl-v3

View file

@ -1,5 +1,9 @@
$NetBSD: distinfo,v 1.11 2013/04/08 07:13:07 mef Exp $
$NetBSD: distinfo,v 1.12 2014/11/23 06:13:37 mef Exp $
SHA1 (riece-9.0.0.tar.gz) = 62c295a17488a0dfc1f0751fd41fbecedc8bdb40
RMD160 (riece-9.0.0.tar.gz) = 21b1737802c149983e6c34ef275fa42c787a4294
Size (riece-9.0.0.tar.gz) = 438553 bytes
SHA1 (patch-riece-ctlseq.el) = 37e1fe8f1337f3e5e2b4d7f64523c44d7925747a
SHA1 (patch-riece-highlight.el) = 5876583ad9c02ec04a3c24de358b9d654f719ae5
SHA1 (patch-riece-shrink-buffer.el) = 7de3f8a0be34c4686254246c23840503c554f730
SHA1 (patch-riece-twitter.el) = 551b76821421e4df3fe1af45e1ec3bd0aae9a59a

View file

@ -0,0 +1,17 @@
$NetBSD: patch-riece-ctlseq.el,v 1.1 2014/11/23 06:13:37 mef Exp $
In riece-ctlseq-make-face:
riece-ctlseq.el:104:27:Warning: `set-face-underline-p' is an obsolete function
(as of 24.3); use `set-face-underline' instead.
--- lisp/riece-ctlseq.el~ 2011-04-04 15:24:37.000000000 +0900
+++ lisp/riece-ctlseq.el 2014-06-15 21:57:58.000000000 +0900
@@ -102,7 +102,7 @@ To set up colors compatible with X-Chat
(if (plist-get attrs 'bold)
(make-face-bold face))
(if (plist-get attrs 'underline)
- (set-face-underline-p face t))
+ (set-face-underline face t))
(if (setq foreground (plist-get attrs 'foreground))
(set-face-foreground face foreground))
(if (setq background (plist-get attrs 'background))

View file

@ -0,0 +1,18 @@
$NetBSD: patch-riece-highlight.el,v 1.1 2014/11/23 06:13:37 mef Exp $
riece-highlight.el:197:4:Warning: make-face called with 2 arguments, but
accepts only 1
--- lisp/riece-highlight.el~ 2011-04-04 15:43:24.000000000 +0900
+++ lisp/riece-highlight.el 2014-06-15 21:59:23.000000000 +0900
@@ -194,8 +194,8 @@
:group 'riece-highlight)
(unless (riece-facep 'riece-modeline-current-face)
- (make-face 'riece-modeline-current-face
- "Face used for displaying the current channel in modeline.")
+ (make-face 'riece-modeline-current-face)
+;; "Face used for displaying the current channel in modeline.")
(if (featurep 'xemacs)
(set-face-parent 'riece-modeline-current-face 'modeline))
(set-face-foreground 'riece-modeline-current-face

View file

@ -0,0 +1,19 @@
$NetBSD: patch-riece-shrink-buffer.el,v 1.1 2014/11/23 06:13:37 mef Exp $
riece-shrink-buffer.el:70:29:Warning: Use `with-current-buffer' rather than
save-excursion+set-buffer
--- lisp/riece-shrink-buffer.el~ 2011-04-04 15:46:44.000000000 +0900
+++ lisp/riece-shrink-buffer.el 2014-06-15 22:01:10.000000000 +0900
@@ -68,8 +68,9 @@
(setq buffers (cdr buffers)))))
(defun riece-shrink-buffer (buffer)
- (save-excursion
- (set-buffer buffer)
+; (save-excursion
+; (set-buffer buffer)
+ (with-current-buffer
(goto-char (point-min))
(while (> (buffer-size) riece-max-buffer-size)
(let* ((inhibit-read-only t)

View file

@ -0,0 +1,16 @@
$NetBSD: patch-riece-twitter.el,v 1.1 2014/11/23 06:13:37 mef Exp $
riece-twitter.el:79:25:Warning: `interactive-p' is an obsolete function (as of
23.2); use `called-interactively-p' instead.
--- lisp/riece-twitter.el~ 2011-04-04 15:47:41.000000000 +0900
+++ lisp/riece-twitter.el 2014-06-15 22:02:07.000000000 +0900
@@ -77,7 +77,7 @@
(process
(apply #'start-process
"curl" nil "curl"
- (if (interactive-p)
+ (if (called-interactively-p)
args
(append args
(list "-H" "X-Twitter-Client: Riece"