Initial import of pam_ssh_agent_auth version 0.9.1 into the packages

collection - kudos to Jan Schaumann for pointing it out.

	PAM module which permits authentication for arbitrary services
	via ssh-agent.  Written with sudo in mind, but like any auth
	PAM module, can be used for for many purposes.
This commit is contained in:
agc 2009-12-11 19:48:12 +00:00
parent e964c98602
commit 919a5125b7
7 changed files with 80 additions and 0 deletions

View file

@ -0,0 +1,3 @@
PAM module which permits authentication for arbitrary services via
ssh-agent. Written with sudo in mind, but like any auth PAM module,
can be used for for many purposes.

View file

@ -0,0 +1,16 @@
# $NetBSD: Makefile,v 1.1.1.1 2009/12/11 19:48:12 agc Exp $
DISTNAME= pam_ssh_agent_auth-0.9.1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=pamsshagentauth/}
EXTRACT_SUFX= .tar.bz2
MAINTAINER= agc@NetBSD.org
HOMEPAGE= http://sourceforge.net/projects/pamsshagentauth/
COMMENT= PAM module which permits authentication via ssh-agent
LICENSE= gnu-gpl-v3
GNU_CONFIGURE= yes
PKG_DESTDIR_SUPPORT= user-destdir
.include "../../mk/bsd.pkg.mk"

View file

@ -0,0 +1,3 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2009/12/11 19:48:12 agc Exp $
libexec/pam_ssh_agent_auth.so
man/man8/pam_ssh_agent_auth.8

View file

@ -0,0 +1,8 @@
$NetBSD: distinfo,v 1.1.1.1 2009/12/11 19:48:12 agc Exp $
SHA1 (pam_ssh_agent_auth-0.9.1.tar.bz2) = 72707ab428a3d36bd64bb1b1a297a855e0f54705
RMD160 (pam_ssh_agent_auth-0.9.1.tar.bz2) = 2157cc4e8c64c989d05478a1cb31822fc712ac0a
Size (pam_ssh_agent_auth-0.9.1.tar.bz2) = 244188 bytes
SHA1 (patch-aa) = a32866ae59734b94c55a3531094bbd6b6d9cdbfc
SHA1 (patch-ab) = 9ef4711ea6a65a627e581d8905a3a9f8ef0cf202
SHA1 (patch-ac) = ade7a45c5e42307ee0e9ffbdbd708a6fef64ada0

View file

@ -0,0 +1,13 @@
$NetBSD: patch-aa,v 1.1.1.1 2009/12/11 19:48:12 agc Exp $
--- log.h 2009/12/11 15:51:23 1.1
+++ log.h 2009/12/11 15:51:40
@@ -15,6 +15,8 @@
#ifndef SSH_LOG_H
#define SSH_LOG_H
+#include <stdarg.h>
+
/* Supported syslog facilities and levels. */
typedef enum {
SYSLOG_FACILITY_DAEMON,

View file

@ -0,0 +1,15 @@
$NetBSD: patch-ab,v 1.1.1.1 2009/12/11 19:48:12 agc Exp $
--- pam_user_authorized_keys.c 2009/12/11 15:54:07 1.1
+++ pam_user_authorized_keys.c 2009/12/11 15:55:45
@@ -81,6 +81,10 @@
extern uint8_t allow_user_owned_authorized_keys_file;
uid_t authorized_keys_file_allowed_owner_uid;
+#ifndef HOST_NAME_MAX
+#define HOST_NAME_MAX MAXHOSTNAMELEN
+#endif
+
void
parse_authorized_key_file(const char *user, const char *authorized_keys_file_input)
{

View file

@ -0,0 +1,22 @@
$NetBSD: patch-ac,v 1.1.1.1 2009/12/11 19:48:12 agc Exp $
--- Makefile.in 2009/12/11 17:10:57 1.1
+++ Makefile.in 2009/12/11 17:11:56
@@ -13,7 +13,7 @@
datadir=@datadir@
datarootdir=@datarootdir@
mandir=@mandir@
-mansubdir=@mansubdir@
+mansubdir=man
sysconfdir=@sysconfdir@
piddir=@piddir@
srcdir=@srcdir@
@@ -130,7 +130,7 @@
uninstall:
-rm -f $(DESTDIR)$(libexecdir)/pam_ssh_agent_auth.so
- -rm -f $(DESTDIR)$(mandir)/$(mansubdir)8/$(mansubdir)8/pam_ssh_agent_auth.8
+ -rm -f $(DESTDIR)$(mandir)/$(mansubdir)8/pam_ssh_agent_auth.8
compat-tests: $(LIBCOMPAT)
(cd openbsd-compat/regress && $(MAKE))