Update to 2.6.5.

Version 2.6.5 - 2003-02-28

* new mirror options --log=<file> and --script=<file> to produce lftp commands
  equivalent to the actions done (log) or to be done (script) by mirror.
  `-' as file name means stdout.
* fixed a dead-lock when resuming FXP with passive source.
* re-get file size and date after HTTP redirect.
* added workarounds for proftpd.
* handle EPIPE (Broken pipe) error as temporary network error.
* fixed a dead-lock in HTTP retrieval after redirect.
* added cls option --sort=date (Oskar Liljeblad).
* fixed compilation on OpenBSD and older Solaris.
* fixed handling of symbolic links in find.
* lftp -f and -c options can now be combined
* fixed slot handling in non-interactive mode.
* fixed large file support in cat command.
* fixed dante socks compilation (now lftp does not use poll with dante).
* fixed data connection abort with ssl connection to wu-ftpd.
This commit is contained in:
wiz 2003-03-06 08:46:31 +00:00
parent fe1192c696
commit 91ad8cab36
3 changed files with 5 additions and 21 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.21 2003/02/06 14:22:16 seb Exp $
# $NetBSD: Makefile,v 1.22 2003/03/06 08:46:31 wiz Exp $
#
DISTNAME= lftp-2.6.4
PKGREVISION= 1
DISTNAME= lftp-2.6.5
CATEGORIES= net
MASTER_SITES= ftp://ftp.yars.free.net/pub/software/unix/net/ftp/client/lftp/ \
ftp://ftp.yars.free.net/pub/software/unix/net/ftp/client/lftp/old/

View file

@ -1,8 +1,7 @@
$NetBSD: distinfo,v 1.8 2003/02/06 14:22:16 seb Exp $
$NetBSD: distinfo,v 1.9 2003/03/06 08:46:31 wiz Exp $
SHA1 (lftp-2.6.4.tar.bz2) = 5237e08132eabd4166f466e7f73db27bbe143716
Size (lftp-2.6.4.tar.bz2) = 1129181 bytes
SHA1 (lftp-2.6.5.tar.bz2) = f2605e190cdcd9dafa02be1f9173dbdd9cb022ac
Size (lftp-2.6.5.tar.bz2) = 1135329 bytes
SHA1 (patch-aa) = 727d216e32d66671e2c74e08e32c1f1017acc87e
SHA1 (patch-ab) = 4312c2878b6e553bdadfab8528906f811cd9d381
SHA1 (patch-ac) = 6df164610322c4dcfa82b8cb92e6a0845a75aee2
SHA1 (patch-ad) = 1cbea05135253e5cfa63aad9435d21552d31d1de

View file

@ -1,14 +0,0 @@
$NetBSD: patch-ad,v 1.1 2003/02/06 14:22:16 seb Exp $
--- src/NetAccess.cc.orig Wed Dec 25 13:44:31 2002
+++ src/NetAccess.cc
@@ -24,6 +24,9 @@
#include <errno.h>
#include <assert.h>
+#ifdef HAVE_SYS_TYPES_H
+#include <sys/types.h>
+#endif
#include <math.h>
#include <netinet/in.h>
#include <arpa/inet.h>