Update memcached to 1.2.8
Critical bug affecting multithreaded builds Many minor bugfixes, new statistics, minor new features. Major crash fixes, DTrace support, minor updates. Minor bugfixes, build support for opensolaris, ipv6 support, "noreply" mode for many commands, largepage support for solaris. Made out of memory errors more clear and added eviction/OOM tracking per slab class. Many bug and platform fixes since 1.2.2. New threading support for stat queries. New commands 'append', 'prepend', 'gets', and 'cas'.
This commit is contained in:
parent
4017654b0e
commit
91ae98c77c
6 changed files with 61 additions and 30 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.19 2009/02/27 22:53:46 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.20 2009/04/15 09:07:15 mjl Exp $
|
||||
#
|
||||
|
||||
DISTNAME= memcached-1.2.2
|
||||
PKGREVISION= 4
|
||||
DISTNAME= memcached-1.2.8
|
||||
# PKGREVISION= 4
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://www.danga.com/memcached/dist/
|
||||
|
||||
|
@ -12,8 +12,11 @@ COMMENT= High-performance distributed memory object caching system
|
|||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
USE_TOOLS+= perl
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
REPLACE_PERL= scripts/memcached-tool
|
||||
|
||||
CONFIGURE_ARGS+= --with-libevent=${BUILDLINK_PREFIX.libevent}
|
||||
|
||||
INSTALLATION_DIRS= bin share/doc/${PKGBASE} ${PKGMANDIR}/man1 sbin
|
||||
|
@ -22,6 +25,7 @@ do-install:
|
|||
${INSTALL_PROGRAM} ${WRKSRC}/memcached ${DESTDIR}${PREFIX}/sbin
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/memcached.1 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/*.txt ${DESTDIR}${PREFIX}/share/doc/${PKGBASE}
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/scripts/memcached-tool ${DESTDIR}${PREFIX}/sbin
|
||||
|
||||
.include "../../devel/libevent/buildlink3.mk"
|
||||
BUILDLINK_API_DEPENDS.libevent+= libevent>=1.0
|
||||
|
|
|
@ -1,6 +1,8 @@
|
|||
@comment $NetBSD: PLIST,v 1.3 2007/08/20 17:02:40 abs Exp $
|
||||
@comment $NetBSD: PLIST,v 1.4 2009/04/15 09:07:15 mjl Exp $
|
||||
man/man1/memcached.1
|
||||
sbin/memcached
|
||||
sbin/memcached-tool
|
||||
share/doc/memcached/binary-protocol-plan.txt
|
||||
share/doc/memcached/memory_management.txt
|
||||
share/doc/memcached/protocol.txt
|
||||
share/doc/memcached/threads.txt
|
||||
|
|
|
@ -1,7 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.7 2007/08/30 19:32:49 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.8 2009/04/15 09:07:15 mjl Exp $
|
||||
|
||||
SHA1 (memcached-1.2.2.tar.gz) = b2160f63ffe6e50681b3dd13a192153130897366
|
||||
RMD160 (memcached-1.2.2.tar.gz) = 78dd094efb9b17a5e80a631690b929b3a4427854
|
||||
Size (memcached-1.2.2.tar.gz) = 166201 bytes
|
||||
SHA1 (memcached-1.2.8.tar.gz) = 6f99414f37cc5b1a6866d9b3ec9254c2ebda237a
|
||||
RMD160 (memcached-1.2.8.tar.gz) = 8866865f57b6914fca98f3cf5ae0942f7e94ba00
|
||||
Size (memcached-1.2.8.tar.gz) = 221285 bytes
|
||||
SHA1 (patch-aa) = 70b649a987f48a1811014ad92c7cc61299d7d6fe
|
||||
SHA1 (patch-ab) = 3668463dd4f7881588cfe32a20f17e8ce19478ab
|
||||
SHA1 (patch-ac) = c2a057b617f23ed2fc681dcd7b9072e62a5ae039
|
||||
SHA1 (patch-ad) = d9cf95fda0d81c95e797b37c4e9211adc6d5a15d
|
||||
|
|
|
@ -1,21 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.4 2007/08/30 19:32:50 joerg Exp $
|
||||
|
||||
--- memcached.h.orig 2007-05-02 22:58:51.000000000 +0000
|
||||
+++ memcached.h
|
||||
@@ -3,6 +3,7 @@
|
||||
|
||||
#include "config.h"
|
||||
#include <sys/types.h>
|
||||
+#include <sys/socket.h>
|
||||
#include <sys/time.h>
|
||||
#include <netinet/in.h>
|
||||
#include <event.h>
|
||||
@@ -102,7 +103,7 @@ typedef struct _stritem {
|
||||
uint8_t it_flags; /* ITEM_* above */
|
||||
uint8_t slabs_clsid;/* which slab class we're in */
|
||||
uint8_t nkey; /* key length, w/terminating null and padding */
|
||||
- void * end[0];
|
||||
+ void * end[];
|
||||
/* then null-terminated key */
|
||||
/* then " flags length\r\n" (no terminating null) */
|
||||
/* then data with terminating \r\n (no terminating null; it's binary!) */
|
31
devel/memcached/patches/patch-ac
Normal file
31
devel/memcached/patches/patch-ac
Normal file
|
@ -0,0 +1,31 @@
|
|||
$NetBSD: patch-ac,v 1.1 2009/04/15 09:07:15 mjl Exp $
|
||||
|
||||
--- configure.orig 2009-04-15 10:39:37.000000000 +0200
|
||||
+++ configure 2009-04-15 10:39:59.000000000 +0200
|
||||
@@ -3807,7 +3807,7 @@
|
||||
enableval=$enable_dtrace;
|
||||
fi
|
||||
|
||||
-if test "x$enable_dtrace" == "xyes"; then
|
||||
+if test "x$enable_dtrace" = "xyes"; then
|
||||
# Extract the first word of "dtrace", so it can be a program name with args.
|
||||
set dummy dtrace; ac_word=$2
|
||||
{ $as_echo "$as_me:$LINENO: checking for $ac_word" >&5
|
||||
@@ -3880,7 +3880,7 @@
|
||||
enableval=$enable_64bit;
|
||||
fi
|
||||
|
||||
-if test "x$enable_64bit" == "xyes"
|
||||
+if test "x$enable_64bit" = "xyes"
|
||||
then
|
||||
org_cflags=$CFLAGS
|
||||
CFLAGS=-m64
|
||||
@@ -5842,7 +5842,7 @@
|
||||
enableval=$enable_threads;
|
||||
fi
|
||||
|
||||
-if test "x$enable_threads" == "xyes"; then
|
||||
+if test "x$enable_threads" = "xyes"; then
|
||||
{ $as_echo "$as_me:$LINENO: checking for library containing pthread_create" >&5
|
||||
$as_echo_n "checking for library containing pthread_create... " >&6; }
|
||||
if test "${ac_cv_search_pthread_create+set}" = set; then
|
14
devel/memcached/patches/patch-ad
Normal file
14
devel/memcached/patches/patch-ad
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-ad,v 1.1 2009/04/15 09:07:15 mjl Exp $
|
||||
|
||||
Note: Patch from FreeBSD memcached port
|
||||
|
||||
--- thread.c.orig 2009-01-27 00:34:19.000000000 -0200
|
||||
+++ thread.c 2009-01-27 00:34:04.000000000 -0200
|
||||
@@ -644,6 +644,7 @@
|
||||
perror("Can't allocate thread descriptors");
|
||||
exit(1);
|
||||
}
|
||||
+ memset(threads, 0, sizeof(LIBEVENT_THREAD) * nthreads);
|
||||
|
||||
threads[0].base = main_base;
|
||||
threads[0].thread_id = pthread_self();
|
Loading…
Reference in a new issue