Don't add -frerun-cse-after-loop. Use do-install to do it properly.

This commit is contained in:
joerg 2013-11-11 16:44:45 +00:00
parent 7563a1b6bf
commit 91c5c1e7fe
3 changed files with 14 additions and 8 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.23 2013/11/10 12:50:19 ryoon Exp $
# $NetBSD: Makefile,v 1.24 2013/11/11 16:44:45 joerg Exp $
#
DISTNAME= arcem-1.50-src
@ -29,9 +29,8 @@ MAKE_ENV+= SYSTEM=X
INSTALLATION_DIRS+= bin share/arcem
#BUILDLINK_TRANSFORM+= rm:-Werror
post-install:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/arcem ${DESTDIR}${PREFIX}/bin
${INSTALL_DATA} ${WRKDIR}/linux.rom \
${DESTDIR}${PREFIX}/share/arcem/ROM
${INSTALL_DATA} ${WRKDIR}/HardImage1 \

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.6 2013/11/10 12:50:19 ryoon Exp $
$NetBSD: distinfo,v 1.7 2013/11/11 16:44:45 joerg Exp $
SHA1 (HardImage1.gz) = ab3c2ddd5a913a4051d4c21707e7701b27a103f3
RMD160 (HardImage1.gz) = 09176071c9c325b50a3a2074938789f4e6136d44
@ -9,5 +9,5 @@ Size (arcem-1.50-src.zip) = 1420685 bytes
SHA1 (linux.rom.gz) = 5a3ed7b8bf7e560d14ede14232e50a40a96f9147
RMD160 (linux.rom.gz) = 5bf035a3e6f054a61de62fcf880c52c996f503c6
Size (linux.rom.gz) = 341085 bytes
SHA1 (patch-aa) = 558eefa0f3061b295a24d8adfef86d902e7894aa
SHA1 (patch-aa) = 2835320a70d04bd435b7d6a159db8019a8bda472
SHA1 (patch-hostfs.c) = 56b3649fdd95ff4b6c98fc2666fd6b0d04c811f8

View file

@ -1,4 +1,4 @@
$NetBSD: patch-aa,v 1.4 2013/11/10 12:50:19 ryoon Exp $
$NetBSD: patch-aa,v 1.5 2013/11/11 16:44:45 joerg Exp $
--- Makefile.orig 2012-12-12 23:41:33.000000000 +0000
+++ Makefile
@ -13,7 +13,14 @@ $NetBSD: patch-aa,v 1.4 2013/11/10 12:50:19 ryoon Exp $
WARN = -Wall -Wno-return-type -Wno-unknown-pragmas -Wshadow \
-Wpointer-arith -Wcast-align -Wstrict-prototypes \
@@ -69,7 +71,7 @@ endif
@@ -63,13 +65,13 @@ ifeq ($(DEBUG),yes)
CFLAGS += -O0 -g
else
CFLAGS = -O3 -funroll-loops -fexpensive-optimizations -ffast-math \
- -fomit-frame-pointer -frerun-cse-after-loop
+ -fomit-frame-pointer
endif
endif
CFLAGS += \
$(CFL) $(WARN) \