Update to 6.5
* patches/patch-bin_cmew is merged to upstream. Changelog: Mew 6.5 stable release (2012/04/16) Mew 6.5rc2 (2012/04/05) * Checking libwrap for stunnel. * Supporting stunnel 4.53. TAKANO Yuji <takachan> * Disabling libwrap. ARAI Shun-ichi <hermes> Mew 6.5rc1 (2012/03/28) * Workaround of cmew for Ruby 1.9. Tatsuya Kinoshita <tats> * mew-make-temp-name allows non-ASCII characters Yoshinari Nomura <nom> Mew 6.4.50 (2012/03/07) * Supporting stunnel 4.51. Seiji Ariga <ariga> * Hilighting HTML produced by w3m. * Fixing regex of mew-regex-ignore-scan-body-list. Tatsuya Kinoshita <tats> * Fixing cmew bugs.
This commit is contained in:
parent
80764b865a
commit
91fb00ceaf
3 changed files with 6 additions and 56 deletions
|
@ -1,8 +1,7 @@
|
||||||
# $NetBSD: Makefile,v 1.85 2012/01/31 14:52:20 taca Exp $
|
# $NetBSD: Makefile,v 1.86 2012/04/16 17:00:28 ryoon Exp $
|
||||||
|
|
||||||
DISTNAME= mew-6.4
|
DISTNAME= mew-6.5
|
||||||
PKGNAME= ${EMACS_PKGNAME_PREFIX}${DISTNAME}
|
PKGNAME= ${EMACS_PKGNAME_PREFIX}${DISTNAME}
|
||||||
PKGREVISION= 1
|
|
||||||
CATEGORIES= mail
|
CATEGORIES= mail
|
||||||
MASTER_SITES= http://www.mew.org/Release/
|
MASTER_SITES= http://www.mew.org/Release/
|
||||||
|
|
||||||
|
|
|
@ -1,7 +1,6 @@
|
||||||
$NetBSD: distinfo,v 1.42 2012/01/31 14:52:20 taca Exp $
|
$NetBSD: distinfo,v 1.43 2012/04/16 17:00:28 ryoon Exp $
|
||||||
|
|
||||||
SHA1 (mew-6.4.tar.gz) = 260cf65b0852c2e871faa1c34a445ab692e26359
|
SHA1 (mew-6.5.tar.gz) = 742b32eca07c4ae7eab24b2678b745aac2b296ea
|
||||||
RMD160 (mew-6.4.tar.gz) = 295634fa5b2a58a29a8e5c2d271900990d726835
|
RMD160 (mew-6.5.tar.gz) = d8ab45bec1f8bdab19b42790609a41afd10601cf
|
||||||
Size (mew-6.4.tar.gz) = 1025983 bytes
|
Size (mew-6.5.tar.gz) = 1026322 bytes
|
||||||
SHA1 (patch-aa) = 7d98b2408108ef93137677373b289e7658949209
|
SHA1 (patch-aa) = 7d98b2408108ef93137677373b289e7658949209
|
||||||
SHA1 (patch-bin_cmew) = 245712f3d5fb60ec4e87f85c56f26c67f1440fe9
|
|
||||||
|
|
|
@ -1,48 +0,0 @@
|
||||||
$NetBSD: patch-bin_cmew,v 1.1 2012/01/31 14:52:20 taca Exp $
|
|
||||||
|
|
||||||
Fix case significant problem of keys.
|
|
||||||
|
|
||||||
--- bin/cmew.orig 2011-10-19 08:46:38.000000000 +0000
|
|
||||||
+++ bin/cmew
|
|
||||||
@@ -29,7 +29,8 @@ def mail_header(path)
|
|
||||||
next if /^From / =~ l
|
|
||||||
break if /^$/ =~ l
|
|
||||||
if /^\s+/ !~ l
|
|
||||||
- (name, value) = l.split(/:\s+/, 2)
|
|
||||||
+ (name, value) = l.split(/:\s*/, 2)
|
|
||||||
+ value = '' if value.nil?
|
|
||||||
@header[name.downcase] = value
|
|
||||||
else
|
|
||||||
value << $'
|
|
||||||
@@ -103,7 +104,7 @@ def check_id(id)
|
|
||||||
end
|
|
||||||
|
|
||||||
def get_id(msg)
|
|
||||||
- return check_id(msg['Message-Id'])
|
|
||||||
+ return check_id(msg['message-id'])
|
|
||||||
end
|
|
||||||
|
|
||||||
def get_parid(msg)
|
|
||||||
@@ -111,11 +112,11 @@ def get_parid(msg)
|
|
||||||
# (2) The References contains one or more IDs, use the last one.
|
|
||||||
# (3) The In-Reply-To contains two or more IDs, use the first one.
|
|
||||||
irt = []
|
|
||||||
- irt = msg['In-Reply-To'].split(/[ \t\n]+/) if msg['In-Reply-To']
|
|
||||||
+ irt = msg['in-reply-to'].split(/[ \t\n]+/) if msg['in-reply-to']
|
|
||||||
irt.delete_if {|id| !check_id(id) }
|
|
||||||
return irt[0] if irt.size == 1
|
|
||||||
ref = []
|
|
||||||
- ref = msg['References'].split(/[ \t\n]+/) if msg['References']
|
|
||||||
+ ref = msg['references'].split(/[ \t\n]+/) if msg['references']
|
|
||||||
ref.delete_if {|id| !check_id(id) }
|
|
||||||
return ref.pop if ref.size > 0
|
|
||||||
return irt[0] if irt.size > 1
|
|
||||||
@@ -124,7 +125,7 @@ end
|
|
||||||
|
|
||||||
def get_date(msg)
|
|
||||||
begin
|
|
||||||
- date = Time.rfc2822(msg['Date']).getutc().strftime('%Y%m%d%H%M%S')
|
|
||||||
+ date = Time.rfc2822(msg['date']).getutc().strftime('%Y%m%d%H%M%S')
|
|
||||||
rescue
|
|
||||||
date = '19700101000000'
|
|
||||||
end
|
|
Loading…
Reference in a new issue