Remove extremely stupid and naive tests for whether YACC is "bison -y"

and LEX is "flex".  They break when full paths are passed to the
configure script via YACC and LEX (!!).
This commit is contained in:
jlam 2005-05-23 21:24:17 +00:00
parent 49bef90a54
commit 920592c1cb
4 changed files with 60 additions and 2 deletions

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.5 2005/02/24 13:10:04 agc Exp $
$NetBSD: distinfo,v 1.6 2005/05/23 21:24:17 jlam Exp $
SHA1 (aide-0.10.tar.gz) = e1a65a96ea66742290b3e445d98c543008057938
RMD160 (aide-0.10.tar.gz) = b3b63b018f3358f1d03cbc76270e5ea6ff9df943
Size (aide-0.10.tar.gz) = 234184 bytes
SHA1 (patch-aa) = 22f4be852c82a9252b29150cf73ce3b938d2f982
SHA1 (patch-ab) = 67ae8c17e8ca99ddade99dc6099499f0b15bcc36

View file

@ -0,0 +1,28 @@
$NetBSD: patch-ab,v 1.1 2005/05/23 21:24:17 jlam Exp $
--- configure.orig 2003-11-28 10:14:08.000000000 -0500
+++ configure
@@ -1164,11 +1164,6 @@ test -n "$YACC" && break
done
test -n "$YACC" || YACC="yacc"
-if test "x${YACC}" != "xbison -y"; then
- echo "AIDE requires GNU bison"
- exit 5
-fi
-
echo $ac_n "checking how to run the C preprocessor""... $ac_c" 1>&6
echo "configure:1174: checking how to run the C preprocessor" >&5
# On Suns, sometimes $CPP names a directory.
@@ -1425,11 +1420,6 @@ EOF
fi
-if test "x${LEX}" != "xflex"; then
- echo "AIDE requires GNU flex"
- exit 5
-fi
-

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.4 2005/02/24 13:10:04 agc Exp $
$NetBSD: distinfo,v 1.5 2005/05/23 21:24:17 jlam Exp $
SHA1 (aide-0.6.tar.gz) = e6d112193ad96bdbbe1e1b685dac644d958a1155
RMD160 (aide-0.6.tar.gz) = 034fe31c83125b6b0a7d23516122e161da0a2b2d
@ -7,3 +7,4 @@ SHA1 (patch-aa) = db675e373464c5127f9bd4cbfd38e6634c950ebf
SHA1 (patch-ab) = 5cc5fdd9fcfde2c5e118bfa4cf68ec7e05215003
SHA1 (patch-ac) = 994de0dc4fc72d9a94f1110c79ece4cc4c0129cb
SHA1 (patch-ad) = 95cb43837470eb1316ef3c234abd71e79838e752
SHA1 (patch-ae) = bf37dc4f8f6d32f8357925d05f7cd398c917c317

View file

@ -0,0 +1,28 @@
$NetBSD: patch-ae,v 1.1 2005/05/23 21:24:17 jlam Exp $
--- configure.orig 2000-01-19 02:25:45.000000000 -0500
+++ configure
@@ -1120,11 +1120,6 @@ test -n "$YACC" && break
done
test -n "$YACC" || YACC="yacc"
-if test "x${YACC}" != "xbison -y"; then
- echo "AIDE requires GNU bison"
- exit 5
-fi
-
echo $ac_n "checking how to run the C preprocessor""... $ac_c" 1>&6
echo "configure:1130: checking how to run the C preprocessor" >&5
# On Suns, sometimes $CPP names a directory.
@@ -1381,11 +1376,6 @@ EOF
fi
-if test "x${LEX}" != "xflex"; then
- echo "AIDE requires GNU flex"
- exit 5
-fi
-