Create template config file for Interix 3.x.

As part of this, do something special for xmesaP.h:  Because XShm.h does
exist on the Interix platform, and Mesa binaries were already buildable,
preserve the ABI by including XShm.h there and keeping the XShmSegmentInfo
field (with -DUSE_XSHM_HDRONLY) -- thus avoiding both flag day and revbump
sweep.  However, all XShm-using code remains turned off (no -DUSE_XSHM)
so that libGL will work.

Bump PKGREVISION of MesaLib only.
This commit is contained in:
tv 2005-11-08 16:41:30 +00:00
parent e7f63a4688
commit 924b25bc16
6 changed files with 57 additions and 8 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile.common,v 1.43 2005/06/16 06:57:57 jlam Exp $
# $NetBSD: Makefile.common,v 1.44 2005/11/08 16:41:30 tv Exp $
DISTNAME= MesaLib-${MESA_VERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
@ -50,6 +50,8 @@ BUILD_TARGET= solaris-x86
BUILD_TARGET= solaris-x86-gcc
. endif
. endif
.elif ${OPSYS} == "Interix"
BUILD_TARGET= interix3
.else
BUILD_TARGET= pkgsrc
.endif

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.40 2005/06/17 15:54:06 jlam Exp $
# $NetBSD: Makefile,v 1.41 2005/11/08 16:41:30 tv Exp $
PKGNAME= MesaLib-${MESA_VERSION}
PKGREVISION= 2
PKGREVISION= 3
COMMENT= Graphics library similar to SGI's OpenGL
.include "../Mesa/Makefile.common"

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.31 2005/07/13 18:39:58 kristerw Exp $
$NetBSD: distinfo,v 1.32 2005/11/08 16:41:30 tv Exp $
SHA1 (Mesa-6.2.1/MesaLib-6.2.1.tar.bz2) = 7c4fb46ae17b066e85e90592ace496ac6b36c189
RMD160 (Mesa-6.2.1/MesaLib-6.2.1.tar.bz2) = cfc5e8db61289c017ff20dd6b4c6db5c7b66855b
@ -8,9 +8,11 @@ RMD160 (Mesa-6.2.1/MesaDemos-6.2.1.tar.bz2) = 62b3ebc47e822c4704b69c9888e74bae12
Size (Mesa-6.2.1/MesaDemos-6.2.1.tar.bz2) = 1004511 bytes
SHA1 (patch-aa) = 90457ea124a42150e3a37b48e1e0691597668606
SHA1 (patch-ab) = c257a57d4570576f160e9a4c029384718402c1bd
SHA1 (patch-ac) = 9a0717105fef41e84b5faebaa8bd91d1c0964b86
SHA1 (patch-ac) = 1791e47aa5a0e9d86002cf4c76dc66338e235fac
SHA1 (patch-ad) = 297981dfd609dab0b213ac75324e07c2364a2b27
SHA1 (patch-ae) = a92133c77b1b958dcfe9b37ddc317d6ff31157d0
SHA1 (patch-af) = 8f77d0a0e7c63de6bcc44a653767ccd04107c98c
SHA1 (patch-ag) = 3d05125b389c26b04884775f3f631247faa8a716
SHA1 (patch-ah) = 0c0a4d18531d2bc9ea1be83e89f373be5609f0e7
SHA1 (patch-ai) = 3c5e4cc1e054514111d50c1d01257f4647b14558
SHA1 (patch-aj) = 8282697af31605d07176943d7cf7e8f413e212de

View file

@ -1,6 +1,6 @@
$NetBSD: patch-ac,v 1.7 2005/01/04 15:49:24 adam Exp $
$NetBSD: patch-ac,v 1.8 2005/11/08 16:41:30 tv Exp $
--- Makefile.orig 2004-12-05 18:25:19.000000000 +0000
--- Makefile.orig 2004-12-05 13:25:19.000000000 -0500
+++ Makefile
@@ -2,7 +2,7 @@
@ -11,7 +11,15 @@ $NetBSD: patch-ac,v 1.7 2005/01/04 15:49:24 adam Exp $
default: $(TOP)/configs/current
@@ -100,6 +100,7 @@ linux-x86-64-static \
@@ -64,6 +64,7 @@ hpux11-64 \
hpux11-64-static \
hpux9 \
hpux9-gcc \
+interix3 \
irix6-64 \
irix6-64-static \
irix6-n32 \
@@ -100,6 +101,7 @@ linux-x86-64-static \
linux-x86-glide \
linux-x86-static \
netbsd \

View file

@ -0,0 +1,15 @@
$NetBSD: patch-ai,v 1.1 2005/11/08 16:41:30 tv Exp $
--- /dev/null 2004-10-25 16:57:21.000000000 +0000
+++ configs/interix3
@@ -0,0 +1,9 @@
+# Configuration for Interix 3.x
+
+include $(TOP)/configs/default
+
+CONFIG_NAME = pkgsrc
+
+# Compiler and flags
+CFLAGS+= -DUSE_XSHM_HDRONLY -DPTHREADS
+APP_LIB_DEPS = -L$(LIB_DIR) -L${PREFIX}/lib -L${X11PREFIX}/lib -lXext -lXmu -lXi -lX11 -lm
+

View file

@ -0,0 +1,22 @@
$NetBSD: patch-aj,v 1.1 2005/11/08 16:41:30 tv Exp $
--- src/mesa/drivers/x11/xmesaP.h.orig 2004-03-04 11:22:01.000000000 -0500
+++ src/mesa/drivers/x11/xmesaP.h
@@ -30,7 +30,7 @@
#ifdef XFree86Server
# include "GL/xf86glx.h"
# include "xf86glx_util.h"
-#elif defined(USE_XSHM)
+#elif defined(USE_XSHM) || defined(USE_XSHM_HDRONLY)
# include <X11/extensions/XShm.h>
#endif
#include "GL/xmesa.h"
@@ -185,7 +185,7 @@ struct xmesa_buffer {
/* 0 = not available */
/* 1 = XImage support available */
/* 2 = Pixmap support available too */
-#ifdef USE_XSHM
+#if defined(USE_XSHM) || defined(USE_XSHM_HDRONLY)
XShmSegmentInfo shminfo;
#endif
#endif