For MacOS X, make sure we have endianness information (coming from

<machine/endian.h>. Otherwise, we might be mis-identified as win32.
This commit is contained in:
hauke 2011-04-14 11:30:08 +00:00
parent 83a589a998
commit 92d541a3d9
3 changed files with 23 additions and 2 deletions

View file

@ -1,7 +1,8 @@
# $NetBSD: Makefile,v 1.22 2008/06/12 02:14:30 joerg Exp $
# $NetBSD: Makefile,v 1.23 2011/04/14 11:30:08 hauke Exp $
#
DISTNAME= plib-1.8.5
PKGREVISION= 1
CATEGORIES= games x11
MASTER_SITES= http://plib.sourceforge.net/dist/

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.10 2008/03/14 14:38:46 drochner Exp $
$NetBSD: distinfo,v 1.11 2011/04/14 11:30:08 hauke Exp $
SHA1 (plib-1.8.5.tar.gz) = c2cf7e3e1e58f7b63dae4bb21e4fa82c3e4d4cfc
RMD160 (plib-1.8.5.tar.gz) = 55019bf3758ec2542804d8e3994f4bed5a188e60
@ -7,3 +7,4 @@ SHA1 (patch-aa) = 35cd38d57f15144d659a19458a2b1c00983fb4b2
SHA1 (patch-ab) = 3976dcf78e8ba44d55d08e67ddf3fa7f23def91e
SHA1 (patch-ad) = 1ec59b079a662bfc9b5ea5fa03686292ac05659f
SHA1 (patch-ae) = ae69e86642c53ef32619d6411809f80ab973b208
SHA1 (patch-af) = ea774a54a3cff4d43abae164bbcae745d4642aea

View file

@ -0,0 +1,19 @@
$NetBSD: patch-af,v 1.5 2011/04/14 11:30:08 hauke Exp $
For MacOS X, make sure we have endianness information (coming from
<machine/endian.h>. Otherwise, we'll be mis-identified as win32.
--- src/ssg/ssgLoadFLT.cxx.orig 2008-03-11 02:06:23.000000000 +0000
+++ src/ssg/ssgLoadFLT.cxx
@@ -103,6 +103,11 @@
#include <string.h>
#include <fcntl.h>
#include <stdio.h>
+
+#if defined (__APPLE__) && defined (__GNUC__)
+#include <sys/types.h> /* Endianness on MacOS X 10.6 */
+#endif
+
#ifdef UL_IRIX
# include <sys/endian.h>
#endif