Don't hard-code libstdc++. Depend on the compiler to add the STL. Bump
revision.
This commit is contained in:
parent
8424353dbb
commit
92d72bffcd
3 changed files with 21 additions and 3 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.24 2018/01/01 21:18:24 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.25 2018/01/07 20:59:40 joerg Exp $
|
||||
|
||||
DISTNAME= libofx-0.9.10
|
||||
PKGREVISION= 6
|
||||
PKGREVISION= 7
|
||||
CATEGORIES= finance devel
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=libofx/}
|
||||
|
||||
|
|
|
@ -1,7 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.13 2015/11/03 00:12:12 agc Exp $
|
||||
$NetBSD: distinfo,v 1.14 2018/01/07 20:59:40 joerg Exp $
|
||||
|
||||
SHA1 (libofx-0.9.10.tar.gz) = 33f394c963c087217cb6c508af842d4844bc0823
|
||||
RMD160 (libofx-0.9.10.tar.gz) = 928069129cf945dc85521907325977a36dbeae7f
|
||||
SHA512 (libofx-0.9.10.tar.gz) = 061110702034dbbb9be3adaebe6236a4b0842169d8ee7671bad6c93960b380cbb33953bdf080c8b14f45930b0c817fcfe1bf71f15d9872dd2535a1415f5be895
|
||||
Size (libofx-0.9.10.tar.gz) = 1433837 bytes
|
||||
SHA1 (patch-lib_Makefile.in) = 512cf3dbaa257205ffff18f3953a08eb81d015f4
|
||||
SHA1 (patch-lib_ofx__preproc.cpp) = 355bc1db8bcdd723ef7534063a673348e3385163
|
||||
|
|
17
finance/libofx/patches/patch-lib_Makefile.in
Normal file
17
finance/libofx/patches/patch-lib_Makefile.in
Normal file
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: patch-lib_Makefile.in,v 1.1 2018/01/07 20:59:40 joerg Exp $
|
||||
|
||||
Don't hard-code the C++ runtime.
|
||||
|
||||
--- lib/Makefile.in.orig 2018-01-06 22:31:54.958490375 +0000
|
||||
+++ lib/Makefile.in
|
||||
@@ -399,8 +399,8 @@ AM_CPPFLAGS = \
|
||||
-DMAKEFILE_DTD_PATH=\"${LIBOFX_DTD_DIR}\"
|
||||
|
||||
|
||||
-#libofx_la_LIBADD = @LIBOBJS@ ${OPENSPLIBS} -lstdc++
|
||||
-libofx_la_LIBADD = $(OPENSPLIBS) $(ICONV_LIBS) -lstdc++
|
||||
+#libofx_la_LIBADD = @LIBOBJS@ ${OPENSPLIBS}
|
||||
+libofx_la_LIBADD = $(OPENSPLIBS) $(ICONV_LIBS)
|
||||
libofx_la_LDFLAGS = -no-undefined -version-info @LIBOFX_SO_CURRENT@:@LIBOFX_SO_REVISION@:@LIBOFX_SO_AGE@
|
||||
all: all-am
|
||||
|
Loading…
Reference in a new issue