Remove reference to obsolete pcre function. Bump PKGREVISION.
This commit is contained in:
parent
1b347aedba
commit
92da5ffe5f
3 changed files with 19 additions and 3 deletions
|
@ -1,9 +1,9 @@
|
|||
# $NetBSD: Makefile,v 1.23 2012/03/03 00:12:07 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.24 2012/05/03 07:34:33 wiz Exp $
|
||||
#
|
||||
|
||||
DISTNAME= goffice-0.8.17
|
||||
PKGNAME= ${DISTNAME:S/goffice/goffice0.8/}
|
||||
PKGREVISION= 4
|
||||
PKGREVISION= 5
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/goffice/0.8/}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.14 2012/05/03 06:01:35 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.15 2012/05/03 07:34:33 wiz Exp $
|
||||
|
||||
SHA1 (goffice-0.8.17.tar.bz2) = 0c8f578f30746b92f37bd8e6eb13dbbaaa124278
|
||||
RMD160 (goffice-0.8.17.tar.bz2) = 35224e53a1431b2ecf81297a081159c7297110bb
|
||||
Size (goffice-0.8.17.tar.bz2) = 2289608 bytes
|
||||
SHA1 (patch-configure) = c9c3278707c2061222cf5eb526787cc3452cf4cc
|
||||
SHA1 (patch-goffice_utils_regutf8.c) = c7aa1e2db12cddbf07aff5e71a13006b2f13420a
|
||||
|
|
15
misc/goffice0.8/patches/patch-goffice_utils_regutf8.c
Normal file
15
misc/goffice0.8/patches/patch-goffice_utils_regutf8.c
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-goffice_utils_regutf8.c,v 1.1 2012/05/03 07:34:33 wiz Exp $
|
||||
|
||||
Replace call to obsolete function.
|
||||
|
||||
--- goffice/utils/regutf8.c.orig 2009-09-05 23:52:09.000000000 +0000
|
||||
+++ goffice/utils/regutf8.c
|
||||
@@ -155,7 +155,7 @@ go_regcomp (GORegexp *gor, const char *p
|
||||
default: return GO_REG_BADPAT;
|
||||
}
|
||||
} else {
|
||||
- gor->re_nsub = pcre_info (r, NULL, NULL);
|
||||
+ pcre_fullinfo (r, NULL, PCRE_INFO_CAPTURECOUNT, &gor->re_nsub);
|
||||
gor->nosub = (cflags & GO_REG_NOSUB) != 0;
|
||||
return 0;
|
||||
}
|
Loading…
Reference in a new issue