Hopefully finally get this right:

Default Mesa Version should be 3.4.2, so that people who don't care and have
GL in XF don't need to build the whole thing.  If MESA_REQD is set to 5.0.1
(as, for example, by MesaDemos), require version 5.0.1 of MesaLib, gl* etc.

If libGL.so.5 is found to be present on the system, force MESA_REQD to be
5.0.1 to avoid accidental downgrades if MESA_REQD was not specified before-
hand.

Changes reviewed by tron@ (thanks!).
This commit is contained in:
jschauma 2003-07-15 23:31:21 +00:00
parent f9f6d8711b
commit 937d21f1b7
7 changed files with 34 additions and 12 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile.common,v 1.15 2003/07/04 16:51:00 jschauma Exp $
# $NetBSD: Makefile.common,v 1.16 2003/07/15 23:31:21 jschauma Exp $
# Latest is: 5.0.1
# Default is: 5.0.1
MESA_REQD?= 5.0.1
# Default is: 3.4.2
MESA_REQD?= 3.4.2
MESA_VERSION= ${MESA_REQD}
DISTNAME?= MesaLib-${MESA_VERSION}
@ -19,3 +19,11 @@ LIBTOOL_OVERRIDE= ${WRKSRC}/libtool
GNU_CONFIGURE?= yes
CONFIGURE_ARGS+= --enable-static
.include "../../mk/bsd.prefs.mk"
.if exists(${LOCALBASE}/lib/libGL.so.5) && empty(MESA_REQD:M5.[0-9]*)
MESA_REQD= 5.0.1
.endif
MAKEFLAGS+= MESA_REQD="${MESA_REQD}"

View file

@ -1,4 +1,4 @@
# $NetBSD: buildlink2.mk,v 1.3 2002/11/18 07:49:24 jlam Exp $
# $NetBSD: buildlink2.mk,v 1.4 2003/07/15 23:31:22 jschauma Exp $
.if !defined(MESA_BUILDLINK2_MK)
MESA_BUILDLINK2_MK= # defined
@ -6,6 +6,8 @@ MESA_BUILDLINK2_MK= # defined
MESA_REQD?= 3.4.2
BUILDLINK_PREFIX.Mesa= ${BUILDLINK_PREFIX.MesaLib}
MAKEFLAGS+= MESA_REQD="${MESA_REQD}"
.include "../../graphics/MesaLib/buildlink2.mk"
.include "../../graphics/glu/buildlink2.mk"
.include "../../graphics/glut/buildlink2.mk"

View file

@ -1,4 +1,4 @@
# $NetBSD: buildlink2.mk,v 1.13 2003/07/07 02:05:59 jschauma Exp $
# $NetBSD: buildlink2.mk,v 1.14 2003/07/15 23:31:22 jschauma Exp $
.if !defined(MESALIB_BUILDLINK2_MK)
MESALIB_BUILDLINK2_MK= # defined
@ -7,7 +7,7 @@ MESALIB_BUILDLINK2_MK= # defined
MESA_REQD?= 3.4.2
.if exists(${X11PREFIX}/lib/libGL.so.5) && empty(MESA_REQD:M5.[0-9]*)
.if exists(${LOCALBASE}/lib/libGL.so.5) && empty(MESA_REQD:M5.[0-9]*)
MESA_REQD= 5.0.1
.endif
@ -16,6 +16,8 @@ BUILDLINK_PKGSRCDIR.MesaLib?= ../../graphics/MesaLib
_REQUIRE_BUILTIN_MESALIB?= NO
MAKEFLAGS+= MESA_REQD="${MESA_REQD}"
# XXX should be >= 3.4.2
.if !empty(MESA_REQD:M5.[0-9]*)
_IS_BUILTIN_MESALIB= 0

View file

@ -1,4 +1,4 @@
# $NetBSD: buildlink2.mk,v 1.10 2003/03/24 18:07:07 jschauma Exp $
# $NetBSD: buildlink2.mk,v 1.11 2003/07/15 23:31:22 jschauma Exp $
.if !defined(GLU_BUILDLINK2_MK)
GLU_BUILDLINK2_MK= # defined
@ -11,6 +11,8 @@ BUILDLINK_PKGSRCDIR.glu?= ../../graphics/glu
_REQUIRE_BUILTIN_GLU?= NO
MAKEFLAGS+= MESA_REQD="${MESA_REQD}"
# XXX should be >= 3.4.2
.if !empty(MESA_REQD:M5.[0-9]*)
_IS_BUILTIN_GLU= 0

View file

@ -1,4 +1,4 @@
# $NetBSD: buildlink2.mk,v 1.5 2003/03/09 19:04:54 jschauma Exp $
# $NetBSD: buildlink2.mk,v 1.6 2003/07/15 23:31:23 jschauma Exp $
.if !defined(GLUT_BUILDLINK2_MK)
GLUT_BUILDLINK2_MK= # defined
@ -8,6 +8,8 @@ BUILDLINK_PACKAGES+= glut
BUILDLINK_DEPENDS.glut?= glut>=${MESA_REQD}
BUILDLINK_PKGSRCDIR.glut?= ../../graphics/glut
MAKEFLAGS+= MESA_REQD="${MESA_REQD}"
EVAL_PREFIX+= BUILDLINK_PREFIX.glut=glut
BUILDLINK_PREFIX.glut_DEFAULT= ${LOCALBASE}
BUILDLINK_FILES.glut= include/GL/glut.h

View file

@ -1,7 +1,11 @@
$NetBSD: distinfo,v 1.11 2003/07/12 01:07:11 jschauma Exp $
$NetBSD: distinfo,v 1.12 2003/07/15 23:31:23 jschauma Exp $
SHA1 (MesaLib-3.4.2.tar.bz2) = 1a41b61a29538127dbb0ab2882ac69554a0e9e37
Size (MesaLib-3.4.2.tar.bz2) = 1380805 bytes
SHA1 (MesaDemos-3.4.2.tar.bz2) = b291eb70c07ad2e12122e53039bf6d36c061a914
Size (MesaDemos-3.4.2.tar.bz2) = 854130 bytes
SHA1 (MesaLib-5.0.1.tar.bz2) = efdda1b592065b714c4cc772d05f21f88b060799
Size (MesaLib-5.0.1.tar.bz2) = 1661508 bytes
SHA1 (MesaDemos-5.0.1.tar.bz2) = 7bc5c33e3799b9cd596311e8dde800800c68c938
Size (MesaDemos-5.0.1.tar.bz2) = 889575 bytes
SHA1 (patch-aa) = 90155341635627e99eca013f5da89a2721bfb0fc
SHA1 (patch-aa) = 1a24208f58cb92d92660a8ef3033952b3fd6c7bb

View file

@ -1,12 +1,14 @@
$NetBSD: patch-aa,v 1.2 2003/07/12 01:07:11 jschauma Exp $
$NetBSD: patch-aa,v 1.3 2003/07/15 23:31:23 jschauma Exp $
--- src-glut/glutint.h.orig 2003-07-11 19:33:42.000000000 +0000
+++ src-glut/glutint.h 2003-07-11 19:33:45.000000000 +0000
@@ -33,6 +33,8 @@
@@ -33,6 +33,10 @@
#include <gl/mesa_wgl.h>
#endif
+#ifdef GL_VERSION_1_4
+#include <GL/glxext.h>
+#endif
+
#ifndef _WIN32
/* added by BrianP: */