Avoid duplicate symbol definition for GC_push_regs in
sparc_netbsd_mach_dep.s and mach_dep.c. From PR 42634 by Bertrand Joel. Bump PKGREVISION.
This commit is contained in:
parent
66ceff24e8
commit
937e1d7ac7
3 changed files with 24 additions and 3 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.64 2009/11/10 18:35:13 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.65 2010/01/20 10:01:19 wiz Exp $
|
||||
|
||||
DISTNAME= gc-7.1
|
||||
PKGNAME= ${DISTNAME:S/gc/boehm-gc/}
|
||||
PKGREVISION= 2
|
||||
PKGREVISION= 3
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.38 2009/11/10 23:31:36 asau Exp $
|
||||
$NetBSD: distinfo,v 1.39 2010/01/20 10:01:19 wiz Exp $
|
||||
|
||||
SHA1 (gc-7.1.tar.gz) = e84cba5d18f4ea5ed4e5fd3f1dc6a46bc190ff6f
|
||||
RMD160 (gc-7.1.tar.gz) = 9338c1128686395739e3acd9052a651d1dffffb2
|
||||
|
@ -6,3 +6,4 @@ Size (gc-7.1.tar.gz) = 1077714 bytes
|
|||
SHA1 (patch-aa) = 87a5bd5e83b0201d80a1e4e4ce6745c11b2e7cfe
|
||||
SHA1 (patch-ab) = 9b5133c7aa84e6824616e29613716a2fedd1d334
|
||||
SHA1 (patch-ac) = 82f869fc4f52a9936395a7f50240b81434f2cb42
|
||||
SHA1 (patch-ae) = fde8f12c8c8dd3142c191f5f1c1854cd339babe9
|
||||
|
|
20
devel/boehm-gc/patches/patch-ae
Normal file
20
devel/boehm-gc/patches/patch-ae
Normal file
|
@ -0,0 +1,20 @@
|
|||
$NetBSD: patch-ae,v 1.9 2010/01/20 10:01:19 wiz Exp $
|
||||
|
||||
--- mach_dep.c.orig 2007-08-13 21:49:11.000000000 +0000
|
||||
+++ mach_dep.c
|
||||
@@ -78,6 +78,7 @@ asm static void PushMacRegisters()
|
||||
#if defined(USE_ASM_PUSH_REGS)
|
||||
# define HAVE_PUSH_REGS
|
||||
#else /* No asm implementation */
|
||||
+#if !defined(SPARC)
|
||||
void GC_push_regs()
|
||||
{
|
||||
# if defined(M68K) && defined(AMIGA)
|
||||
@@ -150,6 +151,7 @@ void GC_push_regs()
|
||||
# endif /* __MWERKS__ */
|
||||
# endif /* MACOS */
|
||||
}
|
||||
+#endif /* !SPARC */
|
||||
#endif /* !USE_ASM_PUSH_REGS */
|
||||
|
||||
#if defined(HAVE_PUSH_REGS) && defined(THREADS)
|
Loading…
Reference in a new issue