libdrm: update to 2.4.97.

Alex Deucher (1):
      amdgpu: update to latest marketing names from 18.50

Andrey Grodzovsky (3):
      amdgpu/test: Add illegal register and memory access test v2
      amdgpu/test: Disable deadlock tests for all non gfx8/9 ASICs.
      amdgpu/test: Enable deadlock test for CI family (gfx7)

Christian König (1):
      amdgpu: add VM test to exercise max/min address space

Daniel Vetter (1):
      doc: Rename README&CONTRIBUTING to .rst

Eric Anholt (2):
      Avoid hardcoded strlens in drmParseSubsystemType().
      drm: Attempt to parse SPI devices as platform bus devices.

Eric Engestrom (6):
      xf86drmHash: remove unused loop variable
      meson: fix typo in compiler flag
      tests: skip drmdevice test if the machine doesn't have any drm device
      freedreno: remove always-defined #ifdef
      xf86atomic: #undef internal define
      README: reflow the project description to improve readability

François Tigeot (2):
      xf86drm: implement drmParseSubsystemType for DragonFly
      libdrm: Use DRM_IOCTL_GET_PCIINFO on DragonFly

Leo Liu (1):
      tests/amdgpu/vcn: fix the nop command in IBs

Lucas De Marchi (2):
      gitignore: sort file
      gitignore: add _build

Marek Olšák (3):
      amdgpu: update amdgpu_drm.h
      amdgpu: add a faster BO list API
      Bump the version to 2.4.97

Mauro Rossi (1):
      android: Fix 32-bit app crashing in 64-bit Android
This commit is contained in:
wiz 2019-01-22 21:50:47 +00:00
parent 9050353068
commit 9383e8a8bf
4 changed files with 29 additions and 29 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.90 2019/01/19 13:21:29 tnn Exp $
# $NetBSD: Makefile,v 1.91 2019/01/22 21:50:47 wiz Exp $
DISTNAME= libdrm-2.4.96
PKGREVISION= 3
DISTNAME= libdrm-2.4.97
CATEGORIES= x11 graphics
MASTER_SITES= http://dri.freedesktop.org/libdrm/
EXTRACT_SUFX= .tar.bz2

View file

@ -1,13 +1,13 @@
$NetBSD: distinfo,v 1.91 2019/01/19 13:21:29 tnn Exp $
$NetBSD: distinfo,v 1.92 2019/01/22 21:50:47 wiz Exp $
SHA1 (libdrm-2.4.96.tar.bz2) = 51eb4c248a437b3f200bd1cd84461d3e0b60d71e
RMD160 (libdrm-2.4.96.tar.bz2) = 8e13f0edf61bb0b59aaaf3cdbaadf20916782fe8
SHA512 (libdrm-2.4.96.tar.bz2) = 008cb7658d953b44e11fa3cc6e00dfeb3efb59c7fdadd59f7066101aff138acbbc2f2508e9ebe0528340e39dc7693937755d1641816ddde135c10a13e7d81e3b
Size (libdrm-2.4.96.tar.bz2) = 829518 bytes
SHA1 (libdrm-2.4.97.tar.bz2) = 7635bec769a17edd140282fa2c46838c4a44bc91
RMD160 (libdrm-2.4.97.tar.bz2) = eb9b715aef37af8b879f45fb2ee5fbb9adbba31b
SHA512 (libdrm-2.4.97.tar.bz2) = 3e08ee9d6c9ce265d783a59b51e22449905ea73aa27f25a082a1e9e1532f7c99e1c9f7cb966eb0970be2a08e2e5993dc9aa55093b1bff548689fdb465e7145ed
Size (libdrm-2.4.97.tar.bz2) = 837329 bytes
SHA1 (patch-ac) = 67c998df7dfc0dabc86320ea6d015cede3e464ea
SHA1 (patch-include_drm_drm.h) = 48a912f40bf2b2a1c23edbe4446fa7869212f17b
SHA1 (patch-libkms_vmwgfx.c) = d2204c0b79098c6c36b7f282b486c58c6354bd1d
SHA1 (patch-libsync.h) = 51623bae547e7a0c3e41fa282964b2361b1c34ab
SHA1 (patch-xf86drm.c) = ae371519320eb513f38d6856ad617dff5d05278b
SHA1 (patch-libsync.h) = 1e0603e72a54a069fc9d2ab2c9559d22381a69d3
SHA1 (patch-xf86drm.c) = 7519074f23f308e806274e003a68e66e8c01e8fc
SHA1 (patch-xf86drmMode.c) = 5f66d45a63b0915f22d0abe115aace13c53823a8
SHA1 (patch-xf86drmMode.h) = a28b02887389be8670193c119f711901af61a6b2

View file

@ -1,11 +1,11 @@
$NetBSD: patch-libsync.h,v 1.2 2018/12/25 01:13:57 sevan Exp $
$NetBSD: patch-libsync.h,v 1.3 2019/01/22 21:50:47 wiz Exp $
Fix public header on SunOS.
If ETIME is not defined, use ETIMEDOUT.
--- libsync.h.orig 2018-10-16 14:49:03.000000000 +0000
--- libsync.h.orig 2019-01-22 16:32:41.000000000 +0000
+++ libsync.h
@@ -33,8 +33,15 @@
@@ -33,9 +33,16 @@
#include <stdint.h>
#include <string.h>
#include <sys/ioctl.h>
@ -14,10 +14,11 @@ If ETIME is not defined, use ETIMEDOUT.
+#endif
#include <sys/poll.h>
#include <unistd.h>
+
+#ifndef ETIME
+#define ETIME ETIMEDOUT
+#endif
+
#if defined(__cplusplus)
extern "C" {
#endif

View file

@ -1,10 +1,10 @@
$NetBSD: patch-xf86drm.c,v 1.3 2019/01/06 02:23:00 tnn Exp $
$NetBSD: patch-xf86drm.c,v 1.4 2019/01/22 21:50:47 wiz Exp $
Implement drmParseSubsystemType, drmParsePciBusInfo for NetBSD
--- xf86drm.c.orig 2018-10-16 14:49:03.000000000 +0000
--- xf86drm.c.orig 2019-01-22 16:32:41.000000000 +0000
+++ xf86drm.c
@@ -84,7 +84,10 @@
@@ -86,7 +86,10 @@
#endif
#ifdef __NetBSD__
@ -16,10 +16,10 @@ Implement drmParseSubsystemType, drmParsePciBusInfo for NetBSD
#endif
#ifdef __OpenBSD__
@@ -3011,6 +3014,65 @@ static int drmParseSubsystemType(int maj
return DRM_BUS_VIRTIO;
@@ -3013,6 +3016,65 @@ static int drmParseSubsystemType(int maj
return bus_types[i].bus_type;
}
return -EINVAL;
+#elif defined(__NetBSD__)
+ int type, fd;
+ drmSetVersion sv;
@ -79,13 +79,13 @@ Implement drmParseSubsystemType, drmParsePciBusInfo for NetBSD
+
+ /* Success or not, we're done. */
+ return ret;
#elif defined(__OpenBSD__)
return -EINVAL;
#elif defined(__OpenBSD__) || defined(__DragonFly__)
return DRM_BUS_PCI;
#else
@@ -3060,6 +3122,73 @@ static int drmParsePciBusInfo(int maj, i
@@ -3062,6 +3124,73 @@ static int drmParsePciBusInfo(int maj, i
info->dev = dev;
info->func = func;
return 0;
+#elif defined(__NetBSD__)
+ int type, fd;
+ drmSetVersion sv;
@ -153,10 +153,10 @@ Implement drmParseSubsystemType, drmParsePciBusInfo for NetBSD
+
+ /* Success! */
+ return 0;
#elif defined(__OpenBSD__)
return 0;
#elif defined(__OpenBSD__) || defined(__DragonFly__)
struct drm_pciinfo pinfo;
int fd, type;
@@ -3227,6 +3356,48 @@ static int drmParsePciDeviceInfo(int maj
@@ -3229,6 +3358,48 @@ static int drmParsePciDeviceInfo(int maj
return parse_config_sysfs_file(maj, min, device);
return 0;
@ -202,6 +202,6 @@ Implement drmParseSubsystemType, drmParsePciBusInfo for NetBSD
+ ret = -errno;
+ close(pcifd);
+ return ret;
#elif defined(__OpenBSD__)
#elif defined(__OpenBSD__) || defined(__DragonFly__)
struct drm_pciinfo pinfo;
int fd, type;