Fix errno.

This commit is contained in:
joerg 2006-03-25 19:50:20 +00:00
parent 636c2ba036
commit 938a6f963c
4 changed files with 42 additions and 5 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.9 2005/04/04 08:56:18 adam Exp $
$NetBSD: distinfo,v 1.10 2006/03/25 19:50:20 joerg Exp $
SHA1 (mtools-3.9.10.tar.bz2) = f916e54e1bff599946bb1e72601f99096ea79456
RMD160 (mtools-3.9.10.tar.bz2) = 566d3f3e3c6201cfe750ba05826f8013778f90b9
@ -8,4 +8,6 @@ SHA1 (patch-ab) = 222ec2dac5cacc8d54eb685ce73124b1c312d93e
SHA1 (patch-ac) = 84d959c35ec65679e003f50ef6a6fb2e62ff272e
SHA1 (patch-ad) = d599f6b184c6da84abf4392b44d243b7b62bac3e
SHA1 (patch-ae) = 5281829c8c79f95ff4672fabb53acd22685c17bb
SHA1 (patch-af) = 0e2e1037be4da5f7c876cb5c9f54950e4726f6d0
SHA1 (patch-af) = 7bb55c2c48987043b18532e56e4236d22342ca60
SHA1 (patch-ag) = 9f8b3777ba34d986580af3fc9d06b84e5548e6fa
SHA1 (patch-ah) = b43f06d990e029c753659b792c4b8ec17bfbffe5

View file

@ -1,8 +1,18 @@
$NetBSD: patch-af,v 1.1 2000/12/07 14:11:37 is Exp $
$NetBSD: patch-af,v 1.2 2006/03/25 19:50:20 joerg Exp $
--- init.c.orig Fri Mar 19 09:57:59 1999
--- init.c.orig 2002-05-01 09:57:02.000000000 +0000
+++ init.c
@@ -27,15 +27,30 @@
@@ -14,9 +14,6 @@
#include "xdf_io.h"
#include "buffer.h"
-extern int errno;
-
-
#define FULL_CYL
unsigned int num_clus; /* total number of cluster */
@@ -27,15 +24,30 @@ unsigned int num_clus; /* total number
*/
static int read_boot(Stream_t *Stream, struct bootsector * boot, int size)
{

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ag,v 1.1 2006/03/25 19:50:20 joerg Exp $
--- sysincludes.h.orig 2006-03-25 18:06:25.000000000 +0000
+++ sysincludes.h
@@ -221,7 +221,6 @@ extern int ioctl(int fildes, int request
#include <sys/stat.h>
#include <errno.h>
-extern int errno;
#include <pwd.h>

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ah,v 1.1 2006/03/25 19:50:20 joerg Exp $
--- mformat.c.orig 2006-03-25 18:10:18.000000000 +0000
+++ mformat.c
@@ -37,8 +37,6 @@
#endif
-extern int errno;
-
static int init_geometry_boot(struct bootsector *boot, struct device *dev,
int sectors0, int rate_0, int rate_any,
unsigned long *tot_sectors, int keepBoot)