Updating mail/p5-Mail-Mbox-MessageParser from 1.5000nb2 to 1.5002
pkgsrc changes: - Adding license definition - Adjusting dependencies - prevent bundled Module::Install from automatic installing extra deps - removed upstream applied patches Upstream changes: Version 1.5002: Sun Aug 9 2009 - Disabled the grep interface, which has had some tricky bugs that I don't have time to figure out. - Fixed infinite loop that occurred for emails of less than 200 characters. (Thanks to Julian Ladisch <bitcard.org-prt@ladisch.de> for the bug report.) - Updated Makefile.PL to be compatible with versions of Module::Install > 0.88. - Instead of returning an error for an empty mailbox, a valid mailbox is returned that will immediately fail the end_of_mailbox check. This should simplify people's code. (Thanks to Daniel Maher <dma@witbe.net> for a bug report that suggested this change in semantics.) - More updates for the missing "m" modifier issue exposed by Perl 5.10. (Thanks to Tom Callawa <tcallawa@redhat.com> for the bug report, and Andreas K"onig <andreas.koenig@anima.de> for the patch.) - Added some debugging information for the "cache data not validated" error. Hopefully this will help catch the bug in the act. Version 1.5001: Sun Jul 20 2008 - Added the missing "m" modifier to a number of regular expressions. A change in Perl 5.10 exposed this issue. (Thanks to Anicka Bernathova <anicka@suse.cz> for the patch.) - Fixed an off-by-one error that would sometimes cause warnings about undefined values. - Added a hack to Makefile.PL to force Module::AutoInstall to be included for Module::Install::CheckOptional. - Fixed a problem in the PREOP rewriting that would cause it to fail on Windows.
This commit is contained in:
parent
b393846ad0
commit
93cc765867
5 changed files with 12 additions and 60 deletions
|
@ -1,22 +1,23 @@
|
|||
# $NetBSD: Makefile,v 1.13 2009/04/02 18:10:39 tez Exp $
|
||||
# $NetBSD: Makefile,v 1.14 2009/09/13 11:51:57 sno Exp $
|
||||
|
||||
DISTNAME= Mail-Mbox-MessageParser-1.5000
|
||||
DISTNAME= Mail-Mbox-MessageParser-1.5002
|
||||
PKGNAME= p5-${DISTNAME}
|
||||
PKGREVISION= 2
|
||||
CATEGORIES= mail perl5
|
||||
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=Mail/}
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://search.cpan.org/dist/Mail-Mbox-MessageParser/
|
||||
COMMENT= Perl5 module for parsing mail messages
|
||||
LICENSE= gnu-gpl-v2
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
DEPENDS+= p5-FileHandle-Unget-[0-9]*:../../devel/p5-FileHandle-Unget
|
||||
DEPENDS+= p5-Storable-[0-9]*:../../devel/p5-Storable
|
||||
DEPENDS+= {perl>=5.10,p5-Storable-[0-9]*}:../../devel/p5-Storable
|
||||
|
||||
BUILD_DEPENDS+= p5-Text-Diff-[0-9]*:../../textproc/p5-Text-Diff
|
||||
|
||||
PERL5_PACKLIST= auto/Mail/Mbox/MessageParser/.packlist
|
||||
MAKE_PARAMS+= < /dev/null
|
||||
|
||||
USE_TOOLS+= grep gzip
|
||||
|
||||
|
@ -26,11 +27,10 @@ SETTINGS+= INSTALLDIRS=site
|
|||
SETTINGS+= BZIP=/usr/bin/bzip2
|
||||
SETTINGS+= BZIP2=/usr/bin/bzip2
|
||||
SETTINGS+= DIFF=/usr/bin/diff
|
||||
SETTINGS+= GREP=${GREP}
|
||||
SETTINGS+= GZIP=${GZIP_CMD}
|
||||
SETTINGS+= TZIP=
|
||||
|
||||
MAKE_PARAMS+= ${SETTINGS}
|
||||
MAKE_PARAMS+= --skipdeps ${SETTINGS}
|
||||
MAKE_PARAMS+= </dev/null
|
||||
|
||||
.include "../../lang/perl5/module.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,8 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.6 2009/04/02 18:10:39 tez Exp $
|
||||
$NetBSD: distinfo,v 1.7 2009/09/13 11:51:57 sno Exp $
|
||||
|
||||
SHA1 (Mail-Mbox-MessageParser-1.5000.tar.gz) = d9a446f2700a8808297a1a8ce4bb9f972bf3e13f
|
||||
RMD160 (Mail-Mbox-MessageParser-1.5000.tar.gz) = 410b46a68360b044124dc36442729e24e6d4eda6
|
||||
Size (Mail-Mbox-MessageParser-1.5000.tar.gz) = 279116 bytes
|
||||
SHA1 (patch-aa) = c13ac36819e59578a8f5f3a64be55303a1bb9ddd
|
||||
SHA1 (patch-ab) = e8c92e569bb452d9d4a8e34352ba33e227fcc42a
|
||||
SHA1 (patch-ac) = e7cb7a428a14e5d3220c948d40e5b2cdb5d3c1b5
|
||||
SHA1 (Mail-Mbox-MessageParser-1.5002.tar.gz) = 9bf7726b52704218558a8bfe6c83892e592def19
|
||||
RMD160 (Mail-Mbox-MessageParser-1.5002.tar.gz) = 0500d0290f006a74fc7d2951cd79bf8f9b64317d
|
||||
Size (Mail-Mbox-MessageParser-1.5002.tar.gz) = 266361 bytes
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1 2009/04/02 18:10:39 tez Exp $
|
||||
|
||||
diff -ruN lib/Mail/Mbox/MessageParser/Config.pm.orig lib/Mail/Mbox/MessageParser/Config.pm > ../../patches/patch-aa
|
||||
|
||||
--- lib/Mail/Mbox/MessageParser/Config.pm.orig 2009-03-31 16:22:14.517431000 -0500
|
||||
+++ lib/Mail/Mbox/MessageParser/Config.pm 2009-03-31 16:22:41.477544900 -0500
|
||||
@@ -19,7 +19,7 @@
|
||||
|
||||
'read_chunk_size' => 20000,
|
||||
|
||||
- 'from_pattern' => q/(?x)^
|
||||
+ 'from_pattern' => q/(?mx)^
|
||||
(From\s
|
||||
# Skip names, months, days
|
||||
(?> [^:\n]+ )
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.1 2009/04/02 18:10:39 tez Exp $
|
||||
|
||||
diff -ruN lib/Mail/Mbox/MessageParser/Grep.pm.orig lib/Mail/Mbox/MessageParser/Grep.pm > ../../patches/patch-ab
|
||||
|
||||
--- lib/Mail/Mbox/MessageParser/Grep.pm.orig 2009-03-31 16:21:34.719068900 -0500
|
||||
+++ lib/Mail/Mbox/MessageParser/Grep.pm 2009-03-31 16:23:08.691314600 -0500
|
||||
@@ -289,7 +289,7 @@
|
||||
# RFC 1521 says the boundary can be no longer than 70 characters. Back up a
|
||||
# little more than that.
|
||||
my $endline = $self->{'endline'};
|
||||
- $self->_read_until_match(qr/^--\Q$boundary\E--$endline/,76)
|
||||
+ $self->_read_until_match(qr/^--\Q$boundary\E--$endline/m,76)
|
||||
or return 0;
|
||||
|
||||
return 1;
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-ac,v 1.1 2009/04/02 18:10:39 tez Exp $
|
||||
|
||||
diff -ruN lib/Mail/Mbox/MessageParser/Perl.pm.orig lib/Mail/Mbox/MessageParser/Perl.pm > ../../patches/patch-ac
|
||||
|
||||
--- lib/Mail/Mbox/MessageParser/Perl.pm.orig 2009-03-31 16:21:44.338876800 -0500
|
||||
+++ lib/Mail/Mbox/MessageParser/Perl.pm 2009-03-31 16:23:32.285106100 -0500
|
||||
@@ -265,7 +265,7 @@
|
||||
# RFC 1521 says the boundary can be no longer than 70 characters. Back up a
|
||||
# little more than that.
|
||||
my $endline = $self->{'endline'};
|
||||
- $self->_read_until_match(qr/^--\Q$boundary\E--$endline/,76)
|
||||
+ $self->_read_until_match(qr/^--\Q$boundary\E--$endline/m,76)
|
||||
or return 0;
|
||||
|
||||
return 1;
|
Loading…
Reference in a new issue