ilmbase: remove, superseeded by math/imath
This commit is contained in:
parent
18af6b07f8
commit
93dff0b6f0
8 changed files with 1 additions and 163 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.944 2021/07/05 14:41:29 nia Exp $
|
||||
# $NetBSD: Makefile,v 1.945 2021/07/08 21:22:34 markd Exp $
|
||||
#
|
||||
|
||||
COMMENT= Graphics tools and libraries
|
||||
|
@ -260,7 +260,6 @@ SUBDIR+= hugin
|
|||
SUBDIR+= iGMT
|
||||
SUBDIR+= icon-naming-utils
|
||||
SUBDIR+= icoutils
|
||||
SUBDIR+= ilmbase
|
||||
SUBDIR+= imlib
|
||||
SUBDIR+= imlib-gtk
|
||||
SUBDIR+= imlib2
|
||||
|
|
|
@ -1,10 +0,0 @@
|
|||
Half is a class that encapsulates our 16-bit floating-point format.
|
||||
|
||||
IlmThread is a thread abstraction library for use with OpenEXR
|
||||
and other software packages. It currently supports pthreads and
|
||||
Windows threads.
|
||||
|
||||
Imath implements 2D and 3D vectors, 3x3 and 4x4 matrices, quaternions
|
||||
and other useful 2D and 3D math functions.
|
||||
|
||||
Iex is an exception-handling library.
|
|
@ -1,17 +0,0 @@
|
|||
# $NetBSD: Makefile,v 1.23 2019/09/21 21:34:44 nia Exp $
|
||||
|
||||
.include "../../graphics/openexr/Makefile.common"
|
||||
|
||||
PKGNAME= ${DISTNAME:S/openexr/ilmbase/}
|
||||
|
||||
CONFIGURE_DIRS= IlmBase
|
||||
BUILD_DIRS= IlmBase
|
||||
|
||||
PKGCONFIG_OVERRIDE= IlmBase.pc.in
|
||||
|
||||
CONFLICTS= openexr<1.6
|
||||
|
||||
pre-configure:
|
||||
cd ${WRKSRC}/IlmBase && ./bootstrap
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
|
@ -1,65 +0,0 @@
|
|||
@comment $NetBSD: PLIST,v 1.5 2019/09/21 21:34:44 nia Exp $
|
||||
include/OpenEXR/Iex.h
|
||||
include/OpenEXR/IexBaseExc.h
|
||||
include/OpenEXR/IexErrnoExc.h
|
||||
include/OpenEXR/IexExport.h
|
||||
include/OpenEXR/IexForward.h
|
||||
include/OpenEXR/IexMacros.h
|
||||
include/OpenEXR/IexMathExc.h
|
||||
include/OpenEXR/IexMathFloatExc.h
|
||||
include/OpenEXR/IexMathFpu.h
|
||||
include/OpenEXR/IexMathIeeeExc.h
|
||||
include/OpenEXR/IexNamespace.h
|
||||
include/OpenEXR/IexThrowErrnoExc.h
|
||||
include/OpenEXR/IlmBaseConfig.h
|
||||
include/OpenEXR/IlmBaseConfigInternal.h
|
||||
include/OpenEXR/IlmThread.h
|
||||
include/OpenEXR/IlmThreadExport.h
|
||||
include/OpenEXR/IlmThreadForward.h
|
||||
include/OpenEXR/IlmThreadMutex.h
|
||||
include/OpenEXR/IlmThreadNamespace.h
|
||||
include/OpenEXR/IlmThreadPool.h
|
||||
include/OpenEXR/IlmThreadSemaphore.h
|
||||
include/OpenEXR/ImathBox.h
|
||||
include/OpenEXR/ImathBoxAlgo.h
|
||||
include/OpenEXR/ImathColor.h
|
||||
include/OpenEXR/ImathColorAlgo.h
|
||||
include/OpenEXR/ImathEuler.h
|
||||
include/OpenEXR/ImathExc.h
|
||||
include/OpenEXR/ImathExport.h
|
||||
include/OpenEXR/ImathForward.h
|
||||
include/OpenEXR/ImathFrame.h
|
||||
include/OpenEXR/ImathFrustum.h
|
||||
include/OpenEXR/ImathFrustumTest.h
|
||||
include/OpenEXR/ImathFun.h
|
||||
include/OpenEXR/ImathGL.h
|
||||
include/OpenEXR/ImathGLU.h
|
||||
include/OpenEXR/ImathHalfLimits.h
|
||||
include/OpenEXR/ImathInt64.h
|
||||
include/OpenEXR/ImathInterval.h
|
||||
include/OpenEXR/ImathLimits.h
|
||||
include/OpenEXR/ImathLine.h
|
||||
include/OpenEXR/ImathLineAlgo.h
|
||||
include/OpenEXR/ImathMath.h
|
||||
include/OpenEXR/ImathMatrix.h
|
||||
include/OpenEXR/ImathMatrixAlgo.h
|
||||
include/OpenEXR/ImathNamespace.h
|
||||
include/OpenEXR/ImathPlane.h
|
||||
include/OpenEXR/ImathPlatform.h
|
||||
include/OpenEXR/ImathQuat.h
|
||||
include/OpenEXR/ImathRandom.h
|
||||
include/OpenEXR/ImathRoots.h
|
||||
include/OpenEXR/ImathShear.h
|
||||
include/OpenEXR/ImathSphere.h
|
||||
include/OpenEXR/ImathVec.h
|
||||
include/OpenEXR/ImathVecAlgo.h
|
||||
include/OpenEXR/half.h
|
||||
include/OpenEXR/halfExport.h
|
||||
include/OpenEXR/halfFunction.h
|
||||
include/OpenEXR/halfLimits.h
|
||||
lib/libHalf.la
|
||||
lib/libIex.la
|
||||
lib/libIexMath.la
|
||||
lib/libIlmThread.la
|
||||
lib/libImath.la
|
||||
lib/pkgconfig/IlmBase.pc
|
|
@ -1,13 +0,0 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.9 2020/05/21 20:58:32 ryoon Exp $
|
||||
|
||||
BUILDLINK_TREE+= ilmbase
|
||||
|
||||
.if !defined(ILMBASE_BUILDLINK3_MK)
|
||||
ILMBASE_BUILDLINK3_MK:=
|
||||
|
||||
BUILDLINK_API_DEPENDS.ilmbase+= ilmbase>=1.0.1
|
||||
BUILDLINK_ABI_DEPENDS.ilmbase+= ilmbase>=2.5.1
|
||||
BUILDLINK_PKGSRCDIR.ilmbase?= ../../graphics/ilmbase
|
||||
.endif # ILMBASE_BUILDLINK3_MK
|
||||
|
||||
BUILDLINK_TREE+= -ilmbase
|
|
@ -1,8 +0,0 @@
|
|||
$NetBSD: distinfo,v 1.23 2021/03/17 11:46:08 wiz Exp $
|
||||
|
||||
SHA1 (openexr-2.5.5.tar.gz) = f55bb2051b409fef1c983cbfa37c72be79038568
|
||||
RMD160 (openexr-2.5.5.tar.gz) = 9674c852e2efe80a84968e0e53164dd713baa49d
|
||||
SHA512 (openexr-2.5.5.tar.gz) = e511af26a8fe2175a641fd25d2dcc6ef807e00bee2aff06a4784125f916ffd47fe376fe0621d385b604180a239bbfee063f8ceee3f7b731fde3c38558e9fdcdf
|
||||
Size (openexr-2.5.5.tar.gz) = 27536865 bytes
|
||||
SHA1 (patch-IlmBase_configure.ac) = 563b483c24c1fa75f7fd203082ff872266d48d50
|
||||
SHA1 (patch-IlmBase_m4_threads.m4) = 7b1f38dbc733a2f324fd5800e9def6f040f33393
|
|
@ -1,33 +0,0 @@
|
|||
$NetBSD: patch-IlmBase_configure.ac,v 1.1 2019/09/22 07:13:32 ryoon Exp $
|
||||
|
||||
* POSIX shell compatibility
|
||||
|
||||
--- IlmBase/configure.ac.orig 2019-09-18 01:02:06.000000000 +0000
|
||||
+++ IlmBase/configure.ac
|
||||
@@ -218,7 +218,7 @@ lib_suffix_valid="no"
|
||||
dnl Internal library namespace
|
||||
dnl
|
||||
lib_namespace=""
|
||||
-if test "x${library_namespace_versioning}" == xyes ; then
|
||||
+if test "x${library_namespace_versioning}" = xyes ; then
|
||||
AC_DEFINE_UNQUOTED(IMATH_INTERNAL_NAMESPACE, Imath_${ILMBASE_VERSION_API})
|
||||
AC_DEFINE_UNQUOTED(IEX_INTERNAL_NAMESPACE, Iex_${ILMBASE_VERSION_API})
|
||||
AC_DEFINE_UNQUOTED(ILMTHREAD_INTERNAL_NAMESPACE, IlmThread_${ILMBASE_VERSION_API})
|
||||
@@ -227,7 +227,7 @@ if test "x${library_namespace_versioning
|
||||
lib_namespace="${ILMBASE_VERSION_API}"
|
||||
LIB_SUFFIX="${ILMBASE_VERSION_API}"
|
||||
lib_suffix_valid="yes"
|
||||
-elif test "x${library_namespace_versioning}" == xno ; then
|
||||
+elif test "x${library_namespace_versioning}" = xno ; then
|
||||
AC_DEFINE_UNQUOTED(IMATH_INTERNAL_NAMESPACE, Imath)
|
||||
AC_DEFINE_UNQUOTED(IEX_INTERNAL_NAMESPACE, Iex)
|
||||
AC_DEFINE_UNQUOTED(ILMTHREAD_INTERNAL_NAMESPACE, IlmThread)
|
||||
@@ -244,7 +244,7 @@ else
|
||||
fi
|
||||
AC_SUBST(LIB_SUFFIX)
|
||||
|
||||
-if test "x${lib_suffix_valid}" == xyes ; then
|
||||
+if test "x${lib_suffix_valid}" = xyes ; then
|
||||
AC_SUBST(LIB_SUFFIX_DASH,"-${LIB_SUFFIX}")
|
||||
AM_CONDITIONAL(LIB_SUFFIX_EXISTS,true)
|
||||
else
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-IlmBase_m4_threads.m4,v 1.1 2020/05/21 20:58:32 ryoon Exp $
|
||||
|
||||
* Improve POSIX shell portability.
|
||||
|
||||
--- IlmBase/m4/threads.m4.orig 2020-05-11 15:53:42.000000000 +0000
|
||||
+++ IlmBase/m4/threads.m4
|
||||
@@ -258,7 +258,7 @@ if test "${enable_posix_sem:-yes}" != "n
|
||||
AC_CHECK_HEADERS([semaphore.h], [
|
||||
AC_SEARCH_LIBS(sem_init, [posix4 pthread], [
|
||||
AC_MSG_CHECKING([whether to use POSIX unnamed semaphores])
|
||||
- if test "${cross_compiling}" == "yes"; then
|
||||
+ if test "${cross_compiling}" = "yes"; then
|
||||
AC_LINK_IFELSE([
|
||||
AC_LANG_PROGRAM([#include <semaphore.h>], [
|
||||
sem_t mysem;
|
Loading…
Reference in a new issue