Fix build on SunOS. Teach configure about SunOS 5.11, preventing some

pyconfig.h weirdness.
This commit is contained in:
hans 2011-09-14 17:00:20 +00:00
parent 99819ecdc3
commit 93f070cd3e
3 changed files with 33 additions and 6 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.57 2011/08/31 14:45:27 joerg Exp $
# $NetBSD: Makefile,v 1.58 2011/09/14 17:00:20 hans Exp $
.include "dist.mk"
@ -50,6 +50,7 @@ USE_TOOLS+= gmake
PY_PLATNAME= ${LOWER_OPSYS:C/\..*//}
.elif ${OPSYS} == "SunOS"
PY_PLATNAME= sunos${OS_VERSION:C/\..*//}
CONFIGURE_ENV+= ac_cv_header_netpacket_packet_h=no
.elif ${OPSYS} == "HPUX"
PY_PLATNAME= hp-ux11
.else

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.34 2011/04/23 08:53:53 obache Exp $
$NetBSD: distinfo,v 1.35 2011/09/14 17:00:20 hans Exp $
SHA1 (Python-2.4.6.tar.bz2) = cb1972a554a458f6a26d3e047b359251865d7c96
RMD160 (Python-2.4.6.tar.bz2) = 0687989193dec2ac108142759281be7ddcf7f31e
@ -14,7 +14,7 @@ SHA1 (patch-ah) = 154b40eec926a6dcc968c635467807766d1cfaa3
SHA1 (patch-ai) = 6435c5a7269c14d94eab6fb9777b9d059507e7b8
SHA1 (patch-aj) = e471737ade95423039661b475f2dd0fc27aa9dac
SHA1 (patch-ak) = 4c6708eb29757179e6855d8fbe78cab92c5a18d5
SHA1 (patch-al) = 10acea9003d856d2663a4b5bbecbd801eca8c0c8
SHA1 (patch-al) = 3bcbdcacc451c8a354ea2d9e9887e61edaabfa41
SHA1 (patch-am) = 31158eee32363963e2f6d0bd528f0b291453de74
SHA1 (patch-an) = 0ae5b3d547c7dbe1366c5ae6c60c11516e4550b8
SHA1 (patch-ao) = 1ef48142acd8b591b11013b46048d9145f235843

View file

@ -1,7 +1,7 @@
$NetBSD: patch-al,v 1.12 2007/06/08 14:16:16 wiz Exp $
$NetBSD: patch-al,v 1.13 2011/09/14 17:00:20 hans Exp $
--- configure.orig 2006-10-17 16:03:36.000000000 +0000
+++ configure
--- configure.orig 2006-10-17 18:03:36.000000000 +0200
+++ configure 2011-09-07 15:37:19.069940155 +0200
@@ -312,7 +312,7 @@ ac_includes_default="\
# include <unistd.h>
#endif"
@ -31,6 +31,32 @@ $NetBSD: patch-al,v 1.12 2007/06/08 14:16:16 wiz Exp $
# On Solaris 2.6, sys/wait.h is inconsistent in the usage
# of union __?sigval. Reported by Stuart Bishop.
SunOS/5.6)
@@ -1591,10 +1595,10 @@ if test $define_xopen_source = yes
then
# On Solaris w/ g++ it appears that _XOPEN_SOURCE has to be
# defined precisely as g++ defines it
- # Furthermore, on Solaris 10, XPG6 requires the use of a C99
+ # Furthermore, on Solaris >=10, XPG6 requires the use of a C99
# compiler
case $ac_sys_system/$ac_sys_release in
- SunOS/5.8|SunOS/5.9|SunOS/5.10)
+ SunOS/5.8|SunOS/5.9|SunOS/5.10|SunOS/5.11)
cat >>confdefs.h <<\_ACEOF
#define _XOPEN_SOURCE 500
@@ -1614,10 +1618,10 @@ _ACEOF
# definition of _XOPEN_SOURCE_EXTENDED and _POSIX_C_SOURCE, or else
# several APIs are not declared. Since this is also needed in some
# cases for HP-UX, we define it globally.
- # except for Solaris 10, where it must not be defined,
+ # except for Solaris >=10, where it must not be defined,
# as it implies XPG4.2
case $ac_sys_system/$ac_sys_release in
- SunOS/5.10)
+ SunOS/5.10|SunOS/5.11)
;;
*)
@@ -1746,258 +1750,6 @@ fi;
echo "$as_me:$LINENO: result: $without_gcc" >&5
echo "${ECHO_T}$without_gcc" >&6