Use common patches and reset PKGREVISION.

This commit is contained in:
jperkin 2017-07-04 19:48:52 +00:00
parent d891c1b3c2
commit 93f23a9e58
4 changed files with 1 additions and 187 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.17 2016/03/05 11:29:08 jperkin Exp $
# $NetBSD: Makefile,v 1.18 2017/07/04 19:48:52 jperkin Exp $
#
PKGNAME= nagios-plugin-ldap-${PLUGINSVERSION}
PKGREVISION= 1
CATEGORIES= net sysutils databases
MAINTAINER= pkgsrc-users@NetBSD.org

View file

@ -1,8 +0,0 @@
$NetBSD: distinfo,v 1.11 2015/11/04 00:35:13 agc Exp $
SHA1 (nagios-plugins-2.0.3.tar.gz) = 29b6183ab9d796299dc17c395eef493415d1e9d6
RMD160 (nagios-plugins-2.0.3.tar.gz) = b682b126c78df51f64d9cb8599d2f9dfd411d5f4
SHA512 (nagios-plugins-2.0.3.tar.gz) = 2753e6f3fc7433a5583fee01e63a65b9ea74155964f2b6e6bf3458e56cb29ea5dbd020f83816044a717b66d6548d203b3a082fba0faedcd629c7a8457bc19b36
Size (nagios-plugins-2.0.3.tar.gz) = 2659772 bytes
SHA1 (patch-ak) = cd052cfbe669cd64038ae23c624761dd3a7da188
SHA1 (patch-configure) = 3031d396b72817d7f5d395ff9854ddcfca30252b

View file

@ -1,76 +0,0 @@
$NetBSD: patch-ak,v 1.4 2015/04/03 18:18:01 rodent Exp $
--- gl/mountlist.c.orig 2014-03-04 21:41:56.000000000 +0000
+++ gl/mountlist.c
@@ -52,7 +52,11 @@
# if HAVE_STRUCT_FSSTAT_F_FSTYPENAME
# define FS_TYPE(Ent) ((Ent).f_fstypename)
# else
-# define FS_TYPE(Ent) mnt_names[(Ent).f_type]
+# ifdef STAT_STATVFS
+# define FS_TYPE(Ent) mnt_names[(Ent).f_fsid]
+# else
+# define FS_TYPE(Ent) mnt_names[(Ent).f_type]
+# endif
# endif
#endif /* MOUNTED_GETFSSTAT */
@@ -99,6 +103,10 @@
# include <sys/statfs.h>
#endif
+#ifdef HAVE_SYS_STATVFS_H
+#include <sys/statvfs.h>
+#endif
+
#ifdef MOUNTED_LISTMNTENT
# include <mntent.h>
#endif
@@ -223,7 +231,7 @@ me_remote (char const *fs_name, char con
#if MOUNTED_GETMNTINFO
-# if ! HAVE_STRUCT_STATFS_F_FSTYPENAME
+# if ! HAVE_STRUCT_STATFS_F_FSTYPENAME && ! STAT_STATVFS
static char *
fstype_to_string (short int t)
{
@@ -320,9 +328,13 @@ fstype_to_string (short int t)
# endif
static char *
+#ifdef STAT_STATVFS
+fsp_to_string (const struct statvfs *fsp)
+#else
fsp_to_string (const struct statfs *fsp)
+#endif
{
-# if HAVE_STRUCT_STATFS_F_FSTYPENAME
+# if defined HAVE_STRUCT_STATFS_F_FSTYPENAME || defined STAT_STATVFS
return (char *) (fsp->f_fstypename);
# else
return fstype_to_string (fsp->f_type);
@@ -648,7 +660,11 @@ read_file_system_list (bool need_fs_type
{
int numsys, counter;
size_t bufsize;
+#ifdef STAT_STATVFS
+ struct statvfs *stats;
+#else
struct statfs *stats;
+#endif
numsys = getfsstat (NULL, 0L, MNT_NOWAIT);
if (numsys < 0)
@@ -658,7 +674,11 @@ read_file_system_list (bool need_fs_type
bufsize = (1 + numsys) * sizeof *stats;
stats = xmalloc (bufsize);
+#ifdef STAT_STATVFS
+ numsys = getfsstat ((struct statvfs *)stats, bufsize, MNT_NOWAIT);
+#else
numsys = getfsstat (stats, bufsize, MNT_NOWAIT);
+#endif
if (numsys < 0)
{

View file

@ -1,101 +0,0 @@
$NetBSD: patch-configure,v 1.2 2015/04/03 18:18:01 rodent Exp $
--- configure.orig 2014-06-26 16:17:37.000000000 +0000
+++ configure
@@ -17188,7 +17188,7 @@ _ACEOF
fi
- if test "$ac_cv_lib_radiusclient_rc_read_config" = "yes"; then
+ if false; then
EXTRAS="$EXTRAS check_radius\$(EXEEXT)"
RADIUSLIBS="-lradiusclient"
@@ -18791,6 +18791,9 @@ cat confdefs.h >>conftest.$ac_ext
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
#ifdef HAVE_UNISTD_H
+#if defined(__sun) && !defined(_LP64) && _FILE_OFFSET_BITS == 64
+#undef _FILE_OFFSET_BITS
+#endif
#include <unistd.h>
#endif
#include <netinet/in.h>
@@ -21524,7 +21527,7 @@ elif test "$ac_cv_uname_s" = "SunOS"; th
ac_cv_ps_cols=9
{ $as_echo "$as_me:$LINENO: result: using nagios-plugins internal ps command (pst3) for solaris" >&5
$as_echo "using nagios-plugins internal ps command (pst3) for solaris" >&6; }
- if test `isainfo -b` = 64 ; then
+ if test "$MACHINE_ARCH" = "x86_64" ; then
pst3_use_64bit=1
{ $as_echo "$as_me:$LINENO: using 64bit pst3" >&5
$as_echo "$as_me: using 64bit pst3" >&6;}
@@ -22521,7 +22524,7 @@ fi
then
{ $as_echo "$as_me:$LINENO: checking for nslookup syntax" >&5
$as_echo_n "checking for nslookup syntax... " >&6; }
- if $PATH_TO_NSLOOKUP -sil 127.0.0.1 2>&1 | grep "Invalid option: sil" >/dev/null
+ if $PATH_TO_NSLOOKUP -sil 127.0.0.1 2>&1 | grep -F "Invalid option: sil" >/dev/null
then
ac_cv_nslookup_command="$PATH_TO_NSLOOKUP"
{ $as_echo "$as_me:$LINENO: result: $ac_cv_nslookup_command" >&5
@@ -22982,7 +22985,7 @@ _ACEOF
fi
-if ( $PERL -M"Net::SNMP 3.6" -e 'exit' 2>/dev/null )
+if false
then
{ $as_echo "$as_me:$LINENO: checking for Net::SNMP perl module" >&5
$as_echo_n "checking for Net::SNMP perl module... " >&6; }
@@ -23134,7 +23137,7 @@ IFS=$as_save_IFS
esac
fi
PATH_TO_FPING=$ac_cv_path_PATH_TO_FPING
-if test -n "$PATH_TO_FPING"; then
+if test -n "$PATH_TO_FPING" -a "$PATH_TO_FPING" != "no"; then
{ $as_echo "$as_me:$LINENO: result: $PATH_TO_FPING" >&5
$as_echo "$PATH_TO_FPING" >&6; }
else
@@ -23174,7 +23177,7 @@ IFS=$as_save_IFS
esac
fi
PATH_TO_FPING6=$ac_cv_path_PATH_TO_FPING6
-if test -n "$PATH_TO_FPING6"; then
+if test -n "$PATH_TO_FPING6" -a "$PATH_TO_FPING6" != "no"; then
{ $as_echo "$as_me:$LINENO: result: $PATH_TO_FPING6" >&5
$as_echo "$PATH_TO_FPING6" >&6; }
else
@@ -23750,6 +23753,10 @@ cat confdefs.h >>conftest.$ac_ext
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
+#if defined(__sun) && !defined(_LP64) && _FILE_OFFSET_BITS == 64
+#undef _FILE_OFFSET_BITS
+#endif
+
#ifdef HAVE_SYS_PARAM_H
#include <sys/param.h>
#endif
@@ -23812,6 +23819,10 @@ cat confdefs.h >>conftest.$ac_ext
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
+#if defined(__sun) && !defined(_LP64) && _FILE_OFFSET_BITS == 64
+#undef _FILE_OFFSET_BITS
+#endif
+
#include <unistd.h>
#include <sys/types.h>
#include <sys/param.h>
@@ -24003,6 +24014,10 @@ cat confdefs.h >>conftest.$ac_ext
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
+#if defined(__sun) && !defined(_LP64) && _FILE_OFFSET_BITS == 64
+#undef _FILE_OFFSET_BITS
+#endif
+
#include <sys/types.h>
#include <sys/param.h>
#include <sys/stat.h>