Update to 0.71.2, now using GTK2.

0.71.2 - 1/16/2003
- Changed all occurrences of the deprecated jpilot_logf call to the correct
  jp_logf
- included libplugin.h from J-Pilot 0.99.4
- removed the unused prefs.h
- changed all LOG_XXX macros to the JP_LOG_XXX form used in the new
  libplugin.h
- applied and updated the patch from Ludovic which prints an error if the
  AvantGo .prc file is not installed
- added support for GTK2 (use --enable-gtk2)
    -- this does not do anything extra, it just lets jpilot-syncmal work with
    GTK2-enabled J-Pilot 0.99.4

0.71.1 - 6/21/2002
- Applied patch from Ludovic Roussea which allows GTK to set the size of the
  about box
- Reorganized Makefile.in
- Fixed the warnings about no newlines in the malsync src
This commit is contained in:
wiz 2003-03-04 16:30:18 +00:00
parent e99332c583
commit 9425280e96
3 changed files with 7 additions and 29 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.13 2003/01/13 13:21:07 wiz Exp $ # $NetBSD: Makefile,v 1.14 2003/03/04 16:30:18 wiz Exp $
DISTNAME= jpilot-syncmal_0.71 DISTNAME= jpilot-syncmal_0.71.2
PKGNAME= jpilot-syncmal-0.71 PKGNAME= jpilot-syncmal-0.71.2
CATEGORIES= comms CATEGORIES= comms
MASTER_SITES= http://jasonday.home.att.net/code/syncmal/ MASTER_SITES= http://jasonday.home.att.net/code/syncmal/
@ -19,7 +19,7 @@ USE_LIBTOOL= # defined
SHLIBTOOL_OVERRIDE= ${WRKSRC}/libtool SHLIBTOOL_OVERRIDE= ${WRKSRC}/libtool
GNU_CONFIGURE= # defined GNU_CONFIGURE= # defined
CONFIGURE_ARGS+= --with-gtk-prefix=${BUILDLINK_PREFIX.gtk} CONFIGURE_ARGS+= --enable-gtk2
CONFIGURE_ARGS+= --with-plugin-prefix=${BUILDLINK_PREFIX.jpilot}/include/jpilot CONFIGURE_ARGS+= --with-plugin-prefix=${BUILDLINK_PREFIX.jpilot}/include/jpilot
CONFIGURE_ARGS+= --with-pilot-prefix=${BUILDLINK_PREFIX.pilot-link-libs} CONFIGURE_ARGS+= --with-pilot-prefix=${BUILDLINK_PREFIX.pilot-link-libs}
MAKE_ENV+= PILOT_LINK_DIR=${BUILDLINK_PREFIX.pilot-link-libs} MAKE_ENV+= PILOT_LINK_DIR=${BUILDLINK_PREFIX.pilot-link-libs}

View file

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.3 2003/01/13 13:21:08 wiz Exp $ $NetBSD: distinfo,v 1.4 2003/03/04 16:30:18 wiz Exp $
SHA1 (jpilot-syncmal_0.71.tar.gz) = 561b5b1e090d883cf4cd04d801ae24deeab391ad SHA1 (jpilot-syncmal_0.71.2.tar.gz) = f7a81e69155df2423873ed8a98549ccb56480ec6
Size (jpilot-syncmal_0.71.tar.gz) = 302724 bytes Size (jpilot-syncmal_0.71.2.tar.gz) = 299645 bytes
SHA1 (patch-aa) = eaf02c8e0e0fc3664ed9f821aa30f06973039b92
SHA1 (patch-ab) = 3cfe2caa22b973411602323bd922480815143e19 SHA1 (patch-ab) = 3cfe2caa22b973411602323bd922480815143e19

View file

@ -1,21 +0,0 @@
$NetBSD: patch-aa,v 1.4 2003/01/13 13:21:09 wiz Exp $
--- malsync/mal/client/unix/Makefile.orig Sat Feb 9 20:21:06 2002
+++ malsync/mal/client/unix/Makefile
@@ -16,7 +16,6 @@ LINKLIBS = -lm
endif
TREETOP = ../../..
-PILOT_LINK_DIR = $(TREETOP)/vendor/pilot/pilot-link.0.9.5
CFLAGS = -Wall -g -DMALSYNC -I$(TREETOP)/mal/common \
-I$(TREETOP)/mal/client/common -I$(PILOT_LINK_DIR)/include -I.
@@ -70,7 +69,7 @@ endif
$(TARGET): $(OBJS)
$(CC) $(DYNLINK) $(CFLAGS) -o $@ $(OBJS) \
- -L${PILOT_LINK_DIR}/libsock -lpisock $(LINKLIBS)
+ -L${PILOT_LINK_DIR}/lib -lpisock $(LINKLIBS)
clean:
rm -f $(OBJS) $(TARGET)