Fix build with gcc4.6
Add -fpermissive for Linux
This commit is contained in:
parent
0bdb9fc44f
commit
94365f1c95
6 changed files with 64 additions and 2 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.21 2012/03/03 00:13:00 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.22 2012/03/10 20:55:46 markd Exp $
|
||||
#
|
||||
|
||||
DISTNAME= lyx-1.6.9
|
||||
|
@ -69,6 +69,8 @@ USE_LIBTOOL= YES
|
|||
USE_PKGLOCALEDIR= YES
|
||||
GCC_REQD+= 2.95
|
||||
|
||||
CXXFLAGS.Linux+= -fpermissive
|
||||
|
||||
CONFIGURE_ARGS+= --with-extra-prefix=${BUILDLINK_PREFIX.qt4-libs} \
|
||||
--with-qt4-dir=${QTDIR:Q} \
|
||||
--with-qt4-includes=${BUILDLINK_PREFIX.qt4-libs}/qt4/include \
|
||||
|
|
|
@ -1,6 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.6 2011/04/15 16:32:33 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.7 2012/03/10 20:55:46 markd Exp $
|
||||
|
||||
SHA1 (lyx-1.6.9.tar.bz2) = a1acacc8a26546542e32977ae222e811c98b1ca4
|
||||
RMD160 (lyx-1.6.9.tar.bz2) = 30e37efc4c9cf3d335e78a1a1940dba2a0df1645
|
||||
Size (lyx-1.6.9.tar.bz2) = 12560174 bytes
|
||||
SHA1 (patch-development_MacOSX_Makefile.in) = ae9e51e3458f8986ae392b146f8684305b7fe25b
|
||||
SHA1 (patch-src_WordList.cpp) = d747efcd6ca4d7015a5c6860a8844ac79a65672a
|
||||
SHA1 (patch-src_mathed_InsetMath.h) = c178b1436c7a969e29b328dde1a800e9ccb7af0e
|
||||
SHA1 (patch-src_mathed_MathData.h) = fcd51f36aa2aae29f75e041d7adb1d88baa370a5
|
||||
SHA1 (patch-src_support_unicode.cpp) = 71bdc1b929a3c90bed84d6de5aa0734e548c67de
|
||||
|
|
14
editors/lyx/patches/patch-src_WordList.cpp
Normal file
14
editors/lyx/patches/patch-src_WordList.cpp
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-src_WordList.cpp,v 1.1 2012/03/10 20:55:47 markd Exp $
|
||||
|
||||
Fix build with gcc 4.6
|
||||
|
||||
--- src/WordList.cpp.orig 2008-04-30 08:26:40.000000000 +0000
|
||||
+++ src/WordList.cpp
|
||||
@@ -9,6 +9,7 @@
|
||||
*/
|
||||
|
||||
#include <config.h>
|
||||
+#include <cstddef>
|
||||
|
||||
#include "WordList.h"
|
||||
|
14
editors/lyx/patches/patch-src_mathed_InsetMath.h
Normal file
14
editors/lyx/patches/patch-src_mathed_InsetMath.h
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-src_mathed_InsetMath.h,v 1.1 2012/03/10 20:55:47 markd Exp $
|
||||
|
||||
Fix build with gcc 4.6
|
||||
|
||||
--- src/mathed/InsetMath.h.orig 2010-12-29 15:36:35.000000000 +0000
|
||||
+++ src/mathed/InsetMath.h
|
||||
@@ -13,6 +13,7 @@
|
||||
#ifndef MATH_INSET_H
|
||||
#define MATH_INSET_H
|
||||
|
||||
+#include <cstddef>
|
||||
#include "MathData.h"
|
||||
|
||||
#include "insets/Inset.h"
|
14
editors/lyx/patches/patch-src_mathed_MathData.h
Normal file
14
editors/lyx/patches/patch-src_mathed_MathData.h
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-src_mathed_MathData.h,v 1.1 2012/03/10 20:55:47 markd Exp $
|
||||
|
||||
Fix build with gcc 4.6
|
||||
|
||||
--- src/mathed/MathData.h.orig 2010-01-20 02:10:29.000000000 +0000
|
||||
+++ src/mathed/MathData.h
|
||||
@@ -15,6 +15,7 @@
|
||||
#ifndef MATH_DATA_H
|
||||
#define MATH_DATA_H
|
||||
|
||||
+#include <cstddef>
|
||||
#include "Dimension.h"
|
||||
#include "MathAtom.h"
|
||||
|
14
editors/lyx/patches/patch-src_support_unicode.cpp
Normal file
14
editors/lyx/patches/patch-src_support_unicode.cpp
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-src_support_unicode.cpp,v 1.1 2012/03/10 20:55:47 markd Exp $
|
||||
|
||||
Fix build with gcc 4.6
|
||||
|
||||
--- src/support/unicode.cpp.orig 2009-05-19 20:30:43.000000000 +0000
|
||||
+++ src/support/unicode.cpp
|
||||
@@ -11,6 +11,7 @@
|
||||
*/
|
||||
|
||||
#include <config.h>
|
||||
+#include <cstddef>
|
||||
|
||||
#include "support/unicode.h"
|
||||
#include "support/debug.h"
|
Loading…
Reference in a new issue