Don't pick up stray librle.so if it exists. We don't want to build

translation support to/from GIF and RLE format.  Closes PR#10172.
This commit is contained in:
jlam 2000-07-14 09:52:45 +00:00
parent f808842e76
commit 944cc9204c
6 changed files with 50 additions and 4 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.21 2000/06/09 05:34:25 jlam Exp $
# $NetBSD: Makefile,v 1.22 2000/07/14 09:52:45 jlam Exp $
#
DISTNAME= giflib-4.1.0
@ -10,6 +10,8 @@ HOMEPAGE= http://prtr-13.ucsc.edu/~badger/software/libungif/index.shtml
CONFLICTS= libungif-*
BUILD_DEPENDS+= autoconf:../../devel/autoconf
USE_LIBTOOL= # defined
LTCONFIG_OVERRIDE= ${WRKSRC}/ltconfig
@ -27,6 +29,9 @@ MAKE_ENV+= CC="${CC} -I${LOCALBASE}/include"
post-patch:
${RM} ${WRKSRC}/doc/gif2x11.html
pre-configure:
cd ${WRKSRC} && autoconf
post-install:
${INSTALL_DATA_DIR} ${DOCDIR}
cd ${WRKSRC}; ${INSTALL_DATA} COPYING PATENT_PROBLEMS ${DOCDIR}

View file

@ -1,3 +1,4 @@
$NetBSD: patch-sum,v 1.4 2000/06/09 05:34:27 jlam Exp $
$NetBSD: patch-sum,v 1.5 2000/07/14 09:52:46 jlam Exp $
MD5 (patch-aa) = 6886eeb2c09f6612f0f236094dadf759
MD5 (patch-ab) = c74223ef8d6f51235a56930377ea6558

View file

@ -0,0 +1,17 @@
$NetBSD: patch-aa,v 1.8 2000/07/14 09:52:46 jlam Exp $
--- configure.in.orig Wed Feb 10 01:19:36 1999
+++ configure.in Fri Jul 14 05:48:33 2000
@@ -16,12 +16,6 @@
AC_CHECK_LIB(m, pow, [MATH_LIB="${MATH_LIB} -lm"
COMPILABLE_EXTRAS="${COMPILABLE_EXTRAS} gifclrmp gifrotat"] )
-if test ${MATH_LIB}; then
- AC_CHECK_LIB(rle, rle_hdr_init, [RLE_LIB="${RLE_LIBS} -lrle -lm"
- COMPILABLE_EXTRAS="${COMPILABLE_EXTRAS} gif2rle rle2gif"],
- ,"-lm" )
-fi
-
dnl I don't have this on my system. Could someone else configure it and
dnl check that it works? (Need to change "main" to a function that's in the
dnl library, check that giflib can be reautoconf'd, configured, and

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.5 2000/06/03 20:11:11 wiz Exp $
# $NetBSD: Makefile,v 1.6 2000/07/14 09:52:46 jlam Exp $
#
DISTNAME= libungif-4.1.0
@ -10,6 +10,8 @@ HOMEPAGE= http://prtr-13.ucsc.edu/~badger/software/libungif/index.shtml
CONFLICTS= giflib-*
BUILD_DEPENDS+= autoconf:../../devel/autoconf
USE_LIBTOOL= yes
LTCONFIG_OVERRIDE= ${WRKSRC}/ltconfig
@ -27,6 +29,9 @@ MAKE_ENV+= CC="${CC} -I${LOCALBASE}/include"
post-patch:
${RM} ${WRKSRC}/doc/gif2x11.html
pre-configure:
cd ${WRKSRC} && autoconf
post-install:
cd ${PREFIX}; for f in libungif.a libungif.so.5.0; do \
g=`echo $$f | ${SED} "s,libungif,libgif,"`; \

View file

@ -1,3 +1,4 @@
$NetBSD: patch-sum,v 1.2 2000/06/03 20:11:11 wiz Exp $
$NetBSD: patch-sum,v 1.3 2000/07/14 09:52:47 jlam Exp $
MD5 (patch-aa) = de061c593cc9ab136d6cb0452d8b90f6
MD5 (patch-ab) = dacda410c2da4d0695fdee220e00ce69

View file

@ -0,0 +1,17 @@
$NetBSD: patch-aa,v 1.3 2000/07/14 09:52:47 jlam Exp $
--- configure.in.orig Tue Jan 19 21:55:27 1999
+++ configure.in Fri Jul 14 05:47:11 2000
@@ -16,12 +16,6 @@
AC_CHECK_LIB(m, pow, [MATH_LIB="${MATH_LIB} -lm"
COMPILABLE_EXTRAS="${COMPILABLE_EXTRAS} gifclrmp gifrotat"] )
-if test ${MATH_LIB}; then
- AC_CHECK_LIB(rle, rle_hdr_init, [RLE_LIB="${RLE_LIBS} -lrle -lm"
- COMPILABLE_EXTRAS="${COMPILABLE_EXTRAS} gif2rle rle2gif"],
- ,"-lm" )
-fi
-
dnl I don't have this on my system. Could someone else configure it and
dnl check that it works? (Need to change "main" to a function that's in the
dnl library, check that giflib can be reautoconf'd, configured, and