Initial import of freezetag-0.9.2, a GTK-based id3 tag editor.

This commit is contained in:
kleink 1999-06-16 15:00:39 +00:00
parent d55c62c778
commit 947552d135
9 changed files with 87 additions and 0 deletions

15
audio/freezetag/Makefile Normal file
View file

@ -0,0 +1,15 @@
# $NetBSD: Makefile,v 1.1.1.1 1999/06/16 15:00:39 kleink Exp $
#
DISTNAME= freezetag-0.9.2
CATEGORIES= audio
MASTER_SITES= http://katz.linuxpower.org/freezetag/current/
MAINTAINER= kleink@netbsd.org
HOMEPAGE= http://katz.linuxpower.org/freezetag/
DEPENDS= gtk+-1.2.2:../../x11/gtk
GNU_CONFIGURE= yes
.include "../../mk/bsd.pkg.mk"

View file

@ -0,0 +1,3 @@
$NetBSD: md5,v 1.1.1.1 1999/06/16 15:00:39 kleink Exp $
MD5 (freezetag-0.9.2.tar.gz) = d84cd138700ee0afae5c3f4ee70646e0

View file

@ -0,0 +1,13 @@
$NetBSD: patch-aa,v 1.1.1.1 1999/06/16 15:00:40 kleink Exp $
--- src/freezetag.h.orig Fri Apr 9 00:12:25 1999
+++ src/freezetag.h Wed Jun 16 02:04:00 1999
@@ -7,6 +7,8 @@
#include <sys/stat.h>
#include <unistd.h>
#include <fcntl.h>
+#include <stdio.h>
+#include <string.h>
#include "dirbrowser.h"

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ab,v 1.1.1.1 1999/06/16 15:00:40 kleink Exp $
--- src/edit_box.c.orig Fri Apr 9 05:42:58 1999
+++ src/edit_box.c Wed Jun 16 01:37:41 1999
@@ -86,7 +86,7 @@
int fd, length,i, genre;
gchar *song, *artist, *album, *year, *comments;
char tag[4];
- char fulltag = "TAG ";
+ char *fulltag = "TAG ";
extern GtkWidget *filelist;
if ( ! ((song_flag != 0) || (artist_flag != 0) || (album_flag != 0) || (year_flag != 0) || (comments_flag != 0) || (genre_flag != 0) )) {

View file

@ -0,0 +1,22 @@
$NetBSD: patch-ac,v 1.1.1.1 1999/06/16 15:00:40 kleink Exp $
--- src/freezetag.c.orig Sat Apr 10 03:46:02 1999
+++ src/freezetag.c Wed Jun 16 02:17:13 1999
@@ -174,7 +174,7 @@
genre = genre_table[genrenum];
- if ( (buf[0] != 'T') && (buf[1] != 'A') && (buf[2] != 'G') ) {
+ if ( (buf[0] != 'T') || (buf[1] != 'A') || (buf[2] != 'G') ) {
gtk_clist_append( GTK_CLIST (clist), line );
} else {
gchar *row[7] = { file, song, artist, album, year, comment, genre };
@@ -322,7 +322,7 @@
gtk_box_pack_start (GTK_BOX (mainbox), topbox, FALSE, TRUE, 0);
gtk_widget_show(topbox);
- directorylist = create_dir_browser((gchar *) get_current_dir_name(), window);
+ directorylist = create_dir_browser((gchar *) getcwd(NULL, 0), window);
gtk_widget_set_usize( GTK_WIDGET (directorylist), 400, 100);
gtk_box_pack_start (GTK_BOX (topbox), directorylist, FALSE, TRUE, 0);
gtk_widget_show (directorylist);

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ad,v 1.1.1.1 1999/06/16 15:00:40 kleink Exp $
--- src/rename.c.orig Sat Apr 10 03:46:18 1999
+++ src/rename.c Wed Jun 16 02:14:25 1999
@@ -53,7 +53,7 @@
lseek(fd, -128, SEEK_END);
read(fd, tag, 128);
- if ( (tag[0] != 'T') && (tag[1] != 'A') && (tag[2] != 'G') ) {
+ if ( (tag[0] != 'T') || (tag[1] != 'A') || (tag[2] != 'G') ) {
#ifdef DEBUG
g_warning("Can't rename a file without a tag - %s\n", filename);
#endif

View file

@ -0,0 +1 @@
An id3 tag editor for GTK+-1.2.0 and higher

View file

@ -0,0 +1,5 @@
freezetag is an id3 tag editor for GTK+-1.2.0 and higher. It currently
supports adding directories recursively, changing multiple tags at a time,
and the viewing of current tags. In addition to viewing and changing tags,
freezetag can also rename your files based on the tag from a format specifier
Also, since freezetag uses GTK+ 1.2.0+, it takes advantage of your GTK+ themes.

View file

@ -0,0 +1,2 @@
@comment $NetBSD: PLIST,v 1.1.1.1 1999/06/16 15:00:39 kleink Exp $
bin/freezetag